Control Web Panel

WebPanel => Apache => Topic started by: Administrator on October 31, 2014, 06:02:36 AM

Title: Default Page Displayed for all domains
Post by: Administrator on October 31, 2014, 06:02:36 AM
If you get default web page displayed for the all domains then please follow this instructions.

1. Logout and Login again as root (CWP automatically tries to fix known issues on the root login)
2. Set shared IP address (Left Menu --> CWP Settings --> Edit Settings)
3. Rebuild Apache vHosts (Left Menu --> Apache Settings --> Rebuild Apache vHosts)
4. Delete index.html file from users folder: /home/USERNAME/public_html/index.html

Check your website now, if you are still getting the same screen then check IP address set for your domain, goto:
Left Menu --> Apache Settings --> Edit Apache vHosts (and check IP address set for domain)

Title: Re: Default Page Displayed for all domains
Post by: apmuthu on November 05, 2014, 05:44:48 PM
This does not work on a fresh install - still all resolve to default domain.
Title: Re: Default Page Displayed for all domains
Post by: apmuthu on November 05, 2014, 06:37:05 PM
Compared settings of /usr/local/apache/conf.d/vhosts.conf in the demo install and mine and found that the setting should be:
Code: [Select]
..
..
<Directory "/">
        AllowOverride All
</Directory>
..
..

In mine it was by default: /home/tester/public_html

After this change it works now!

Title: Re: Default Page Displayed for all domains
Post by: Diego on November 13, 2014, 05:13:55 PM
Unfortunately neither of the options worked for me.
Title: Re: Default Page Displayed for all domains
Post by: Administrator on November 15, 2014, 05:56:18 AM
have you maybe checked apache logs and if the configuration is correct in the vhosts file?
Title: Re: Default Page Displayed for all domains
Post by: cst on November 20, 2014, 09:51:14 PM

Hi

I'm having similar issue.

When i tried to visit mytestdomain.com, i get default apache page
Then i used ftp to override the index.html file, i also added index.php and colors.html but when i try accessing mytestdomain.com, i still see the default apached page.

when i try accessing any of the files i uploaded (like mytestdomain.com/colors.html), i get 404 error.



my log messages show

[servertest@ddwwservers logs]$ tail -n 20 error_log
[Thu Nov 20 18:43:17 2014] [error] [client 41.206.1.4] File does not exist: /usr/local/apache/htdocs/favicon.ico
[Thu Nov 20 18:43:17 2014] [error] [client 41.206.1.4] File does not exist: /usr/local/apache/htdocs/favicon.ico
[Thu Nov 20 18:43:19 2014] [error] [client 41.206.1.4] File does not exist: /usr/local/apache/htdocs/favicon.ico
[Thu Nov 20 18:43:19 2014] [error] [client 41.206.1.4] File does not exist: /usr/local/apache/htdocs/img, referer: http://mytestdomain.com/
[Thu Nov 20 18:43:19 2014] [error] [client 41.206.1.4] File does not exist: /usr/local/apache/htdocs/favicon.ico
[Thu Nov 20 18:43:22 2014] [error] [client 41.206.1.4] File does not exist: /usr/local/apache/htdocs/favicon.ico
[Thu Nov 20 18:43:22 2014] [error] [client 41.206.1.4] File does not exist: /usr/local/apache/htdocs/img, referer: http://mytestdomain.com/
[Thu Nov 20 18:43:23 2014] [error] [client 41.206.1.4] File does not exist: /usr/local/apache/htdocs/favicon.ico
[Thu Nov 20 18:43:32 2014] [error] [client 41.206.1.4] File does not exist: /usr/local/apache/htdocs/index.php
[Thu Nov 20 18:43:35 2014] [error] [client 41.206.1.4] File does not exist: /usr/local/apache/htdocs/index.php
[Thu Nov 20 18:43:39 2014] [error] [client 41.206.1.4] File does not exist: /usr/local/apache/htdocs/index.php
[Thu Nov 20 18:43:47 2014] [error] [client 41.206.1.4] File does not exist: /usr/local/apache/htdocs/colors.html
[Thu Nov 20 18:43:50 2014] [error] [client 41.206.1.4] File does not exist: /usr/local/apache/htdocs/colors.html
[Thu Nov 20 18:43:54 2014] [error] [client 41.206.1.4] File does not exist: /usr/local/apache/htdocs/colors.html
[Thu Nov 20 18:43:57 2014] [error] [client 41.206.1.4] File does not exist: /usr/local/apache/htdocs/colors.html
[Thu Nov 20 18:45:16 2014] [error] [client 41.206.1.4] File does not exist: /usr/local/apache/htdocs/favicon.ico
[Thu Nov 20 18:45:16 2014] [error] [client 41.206.1.4] File does not exist: /usr/local/apache/htdocs/favicon.ico
[Thu Nov 20 18:55:14 2014] [error] [client 41.206.1.4] File does not exist: /usr/local/apache/htdocs/favicon.ico
[Thu Nov 20 18:55:36 2014] [error] [client 41.206.1.4] File does not exist: /usr/local/apache/htdocs/favicon.ico
[Thu Nov 20 19:15:57 2014] [error] [client 41.206.1.4] File does not exist: /usr/local/apache/htdocs/favicon.ico


Thanks

Will appreciate your reply
Title: Re: Default Page Displayed for all domains
Post by: Administrator on November 23, 2014, 03:57:53 AM
you need to follow instructions in the first post, if you have server with a public IP address.
Title: Re: Default Page Displayed for all domains
Post by: zajacmp3 on December 03, 2014, 02:37:50 PM
Your default configuration does not handle ipv6 properly.

Code: [Select]
[Wed Dec 03 14:59:56 2014] [error] [client 2001:41d0:a:XXXX::1] File does not exist: /usr/local/apache/htdocs/img, referer: http://blog.xxxxxx.ovh/

while the original vhost configuration looked like:
Code: [Select]
<VirtualHost 37.187.98.XXX:80>
and in this case it should look like:
Code: [Select]
<VirtualHost [client 2001:41d0:a:XXXX::1]:80 37.187.98.XXX:80>
more readable example:
Code: [Select]
<VirtualHost [ipv6]:80 ipv4:80>


Actually as far as I see this your soft does not handle ipv6 at all. Every domain should have ipv4 configuration and ipv6. Please add this as a feature in future releases.

is this even open source?
Title: Re: Default Page Displayed for all domains
Post by: sprabowo on December 14, 2014, 03:54:28 PM
still in problem, i've tried to follow that instruction and tried to reinstall... :(
Title: Re: Default Page Displayed for all domains
Post by: Glenn on December 15, 2014, 01:26:31 PM
Try and set your Varnish (if you use it) or shared ip to 127.0.0.1 and rebuild virtual hosts
Title: Re: Default Page Displayed for all domains
Post by: Administrator on December 16, 2014, 12:18:13 AM
forgot about this, ipv6 should be included in the future versions.

sprabowo, your virtual hosts needs to have a same ip which you are using for apache...rebuild vhosts options should help as glenn said.
Title: Re: Default Page Displayed for all domains
Post by: eretek on December 24, 2014, 05:48:28 PM
This is my first time with CWP.

I am very very disappointed.  >:( >:( >:( >:( >:( >:(

A fresh installation... tried everything... spent 3 hours... default page is displayed !!!

Using VestaCP for a year at a production environment. There has never ever been a single problem to date.
Title: Re: Default Page Displayed for all domains
Post by: Administrator on December 25, 2014, 05:01:13 PM
have you followed instructions and have you checked server logs?
Title: Re: Default Page Displayed for all domains
Post by: erm3nda on December 26, 2014, 05:16:58 PM
Using VestaCP for a year at a production environment. There has never ever been a single problem to date.

Aha, i saw VestaCP, it's a little gem of hosting software, but powerless than cwp.
The more stuff you put the more ways to broke it.
Title: Re: Default Page Displayed for all domains
Post by: eretek on December 27, 2014, 12:12:56 AM
have you followed instructions and have you checked server logs?

No I didn't check anything. It was a default and clean install. I was expecting it to get working. The guys above didn't come up with a solution nor their problems were resolved.
This looks like a common issue.
By the way CWP looks awesome. So much control under my hands. I really really wanted it to work. But unfortunately it did not.
Title: Re: Default Page Displayed for all domains
Post by: eretek on December 27, 2014, 12:15:33 AM
Using VestaCP for a year at a production environment. There has never ever been a single problem to date.

Aha, i saw VestaCP, it's a little gem of hosting software, but powerless than cwp.
The more stuff you put the more ways to broke it.

Vesta is so basic. I just works. Vesta is VW Beetle.. slow and reliable... CWP looks like a Ferrari.. Fast but you don't know when it is going to break.
Title: Re: Default Page Displayed for all domains
Post by: erm3nda on December 30, 2014, 09:19:09 AM
Aha.... i see like that.

VestaCP
(http://i.dailymail.co.uk/i/pix/2011/07/06/article-2011537-0CE28A7A00000578-307_468x313.jpg)

CWP
(http://theurbanfarmhouse.typepad.com/.a/6a01287699c3f2970c0148c6c5af3f970c-800wi)

Wich of them do you think will run faster?
Title: Re: Default Page Displayed for all domains
Post by: erm3nda on December 30, 2014, 09:30:44 AM
Fast but you don't know when it is going to break.

humm... you have rebuild powers, templated config files (the stuff on the luggage-rack of previous images). Really, the most things can be rebuilded in minutes.

I really don't know how to backup email inboxes, lists and other configs. Just see html files and mysql.

I can understand you about stable and powerfull choice :)

I guess that you can't get real stability for a currently developing software. But it promises!

Title: Re: Default Page Displayed for all domains
Post by: orgest on February 16, 2015, 05:51:01 PM
Hi
I followed the instructions and
I have the same problem Default Page Displayed for all domains.Ip of the server is 192.168.1.30 and I use port forwarding to  access the server with public IP. can you help me to resolve please.
Title: Re: Default Page Displayed for all domains
Post by: rekast on February 18, 2015, 03:17:21 PM
Orgest, I was running into a similar issue before. You are on both a Public and Private IP it seems. Make sure your domain's vHost is set to map to the private IP rather than the public, or give it a wildcard IP (*).
Also make sure you are allowing the directory over ride. If you want post a sample of your vhost configuration for that domain and maybe I can find out what is going on for you. you can blank out the server name or use a dummy address if you want not to list the domain address you are using on here.
Title: Re: Default Page Displayed for all domains
Post by: orgest on February 18, 2015, 03:45:50 PM
Thanks a lot
Title: Re: Default Page Displayed for all domains
Post by: iccamilo on March 04, 2015, 03:47:51 PM
I have the same problem.
All my domains are the default apache page.
But if it works well if access: mydomain.lts / ~ mysite /
My vhost configuration is:

# vhost_start memeupb.com
<VirtualHost 54.172.196.30:80>
ServerName memeupb.com
ServerAlias www.memeupb.com
ServerAdmin iccamilo@gmail.com
DocumentRoot "/home/memeupb/public_html"
ScriptAlias /cgi-bin/ "/home/memeupb/public_html/cgi-bin/
#
# Custom settings are loaded below this line (if any exist)
# Include "/usr/local/apache/conf/userdata/memeupb/memeupb.com/*.conf

<IfModule mod_suexec.c>
        SuexecUserGroup memeupb memeupb
</IfModule>

<IfModule mod_suphp.c>
        suPHP_UserGroup memeupb memeupb
        suPHP_ConfigPath /home/memeupb
</IfModule>

<Directory "/">
        AllowOverride All
</Directory>

</VirtualHost>
Error Log:
[Wed Mar 04 11:20:38 2015] [error] [client 181.131.202.47] File does not exist: /usr/local/apache/htdocs/img, referer: http://www.memeupb.com/
Title: Re: Default Page Displayed for all domains
Post by: erm3nda on March 06, 2015, 07:08:51 AM
Are you talking about that?
http://www.shrinktheweb.com/reqstatus?status=1&hash=4857af93764512512d97b0b7abd3ac36

This is not default webpage.
Title: Re: Default Page Displayed for all domains
Post by: Administrator on March 10, 2015, 12:58:15 PM
on the wiki/FAQ you have solution which you need to check
Title: Re: Default Page Displayed for all domains
Post by: chuprex on March 27, 2015, 08:25:56 AM
i Already trying on first post, but still can't work properly on my different domain.
Title: Re: Default Page Displayed for all domains
Post by: Administrator on March 27, 2015, 07:28:56 PM
it would be the best to check your issue with the hosting support or your sys admin if you have followed instructions on the wiki.
Title: Re: Default Page Displayed for all domains
Post by: kyme32.ro on April 24, 2015, 10:05:26 AM
i lost my day trying to make it work and i noticed that if you are behind a router it won't work, every domain and subdomain will point to usr/local/apache/htdocs, but if you put in shared ip your lan ip, for ex 192.168.1.130, it will work and yes, after that you need to edit your domain ip and rebuild vhosts, and sadly that will be only for you, b'cuz propagation will be made with 192.168.1.130.

Maybe this will help you guys to firgure it out, i'm kinda noob in linux
Title: Re: Default Page Displayed for all domains
Post by: erm3nda on April 24, 2015, 07:48:41 PM
I've reintalled my CWP few weeks ago and is working out of the box (Centos 6.6 64bit).

I really think you missed some step. Rebuild all your vhost files. Double check the IP you have set as main.

Check for the install log, and also for lastest logs of the Apache.
Paste them and we will check. (Remember to wipe out sensitive data)
Title: Re: Default Page Displayed for all domains
Post by: skintekx on April 26, 2015, 06:08:42 PM
i have same problem i tryed hours and hours, i have some experiences with apache2 on debian, litespeed also but i can't find any solution here ...
Title: Re: Default Page Displayed for all domains
Post by: brijendrasial on April 26, 2015, 06:38:31 PM
what is the output of command below:

Quote
yum list installed | grep httpd
or
rpm -qa | grep httpd
Title: Re: Default Page Displayed for all domains
Post by: kyme32.ro on April 28, 2015, 02:33:52 AM
i have following settings
188.215.77.24 is my external ip(internet provider)
192.168.1.130 is my lan ip

vhosts

Code: [Select]
# vhost_start kyme32.ro
<VirtualHost 188.215.77.24:80>
ServerName kyme32.ro
ServerAlias www.kyme32.ro
ServerAdmin kyme32@yahoo.com
DocumentRoot "/home/kyme32/public_html"
ScriptAlias /cgi-bin/ "/home/kyme32/public_html/cgi-bin/
#
# Custom settings are loaded below this line (if any exist)
# Include "/usr/local/apache/conf/userdata/kyme32/kyme32.ro/*.conf

<IfModule mod_suexec.c>
        SuexecUserGroup kyme32 kyme32
</IfModule>

<IfModule mod_suphp.c>
        suPHP_UserGroup kyme32 kyme32
        suPHP_ConfigPath /home/kyme32
</IfModule>

<Directory "/home/kyme32/public_html">
        AllowOverride All
</Directory>

</VirtualHost>
# vhost_end kyme32.ro

# vhost_start cs.kyme32.ro
<VirtualHost 188.215.77.24:80>
ServerName cs.kyme32.ro
ServerAlias www.cs.kyme32.ro
ServerAdmin kyme32@yahoo.com
DocumentRoot "/home/kyme32/public_html/cs_kyme32_ro"
ScriptAlias /cgi-bin/ /home/kyme32/public_html/cs_kyme32_ro/cgi-bin/
#
# Custom settings are loaded below this line (if any exist)
# Include "/usr/local/apache/conf/userdata/kyme32/cs.kyme32.ro/*.conf

<IfModule mod_suexec.c>
        SuexecUserGroup kyme32 kyme32
</IfModule>

<IfModule mod_suphp.c>
        suPHP_UserGroup kyme32 kyme32
</IfModule>

<Directory "/home/kyme32/public_html/cs_kyme32_ro">
        AllowOverride All
</Directory>

</VirtualHost>
# vhost_end cs.kyme32.ro

they are all rebuilded and default template

under accounts the ip address for domain kyme32.ro is 188.215.77.24

NS1: ns1.kyme32.ro | IP:188.215.77.24 [Change]
NS2: ns2.kyme32.ro | IP:188.215.77.24 [Change]
Server IP: 192.168.1.130 | 192.168.1.130
Shared IP: 188.215.77.24 [Change]
Hostname: localhost.kyme32.ro [Change]

NS are configured on website tld as in cwp

/var/named/kyme32.ro.db
Code: [Select]
; Panel %version%
; Zone file for kyme32.ro
$TTL 14400
kyme32.ro.      86400        IN      SOA     ns1.kyme32.ro. kyme32.yahoo.com. (
         2013071600      ; serial, todays date+todays
                86400           ; refresh, seconds
          7200            ; retry, seconds
            3600000         ; expire, seconds
           86400 )         ; minimum, seconds

kyme32.ro. 86400 IN NS ns1.kyme32.ro.
kyme32.ro. 86400 IN NS ns2.kyme32.ro.

kyme32.ro. IN A 188.215.77.24

localhost.kyme32.ro. IN A 127.0.0.1

kyme32.ro. IN MX 0 kyme32.ro.

mail IN CNAME kyme32.ro.
www IN CNAME kyme32.ro.
ftp IN CNAME kyme32.ro.
; Add additional settings below this line
ns1.kyme32.ro. 14400 IN A 188.215.77.24

ns2.kyme32.ro. 14400 IN A 188.215.77.24

cs     14400   IN      A       188.215.77.24 ; #subdomain cs

i am behind a router, what has dmz to 192.168.1.130, every port pointing to server
now can anybody please tell me why my domain point to default page and that's in /usr/local/apache/htdocs/index.html

the install of centos is made in minimal desktop version 6.6

the yum list installed | grep httpd returns
Code: [Select]
httpd-tools.x86_64    2.2.15-39.el6.centos
any hints what can i do to get it working and don't return again to microsux?
Title: Re: Default Page Displayed for all domains
Post by: Glenn on April 28, 2015, 10:43:16 AM
Hi

do you have Varnish enabled ?
Title: Re: Default Page Displayed for all domains
Post by: kyme32.ro on April 28, 2015, 05:11:25 PM
i didn't installed it at first but after i've installed it, same result

there are the settings of it
Code: [Select]
Apache IP (recommended: your Shared IP, or 127.0.0.1): 188.215.77.24
Apache Port (recommended: 82): 80
Varnish IP (recommended: Shared IP or all): all
Varnish Port (recommended: 80): 6081
Varnish Storage Size (recommended: 1G): 1G

netstat info
Code: [Select]
Netstat info
tcp        0      0 :::80                       :::*                        LISTEN      2319/httpd         
tcp        0      0 0.0.0.0:6081                0.0.0.0:*                   LISTEN      2366/varnishd       
tcp        0      0 127.0.0.1:6082              0.0.0.0:*                   LISTEN      2363/varnishd       
tcp        0      0 :::6081                     :::*                        LISTEN      2366/varnishd       

if anyone can tell me what's wrong please let me know, i will share the root pass with support team if anybody is good willing to take a look at it and maybe make it working for me and for every user with this problem
Title: Re: Default Page Displayed for all domains
Post by: brijendrasial on May 01, 2015, 03:35:18 PM
Better contact your server provider.
Title: Re: Default Page Displayed for all domains
Post by: jeeva on May 24, 2015, 02:44:11 PM
Hi

I've got the same issue, running on MICROSOFT AZURE. Followed all the steps as posted throughout this thread. Nothing fixed it.

public ip: 137.116.193.163 (CWP automatically filled it in as the "shared ip")
server ip: 10.2.0.4 (but shows as "default" next to "shared ip"

Running CENTOS 6.5 vanilla install. I've reinstalled a couple of times modifying items to try to get it to work but couldn't.

I added one account "account1" with one domain "domain1.com"
When I open up that domain1.com it shows the HTTP Server Test Page (even if i remove the /USERNAME/Public_html/index.html)

Code: [Select]
# vhost_start domain1.com
<VirtualHost 137.116.193.163:80>
ServerName domain1.com
ServerAlias www.domain1.com
ServerAdmin jeevadotnet@mail.com
DocumentRoot "/home/user1/public_html"
ScriptAlias /cgi-bin/ "/home/user1/public_html/cgi-bin/
#
# Custom settings are loaded below this line (if any exist)
# Include "/usr/local/apache/conf/userdata/user1/domain1.com/*.conf

<IfModule mod_suexec.c>
        SuexecUserGroup user1 user1
</IfModule>

<IfModule mod_suphp.c>
        suPHP_UserGroup user1 user1
        suPHP_ConfigPath /home/user1
</IfModule>

<Directory "/home/user1/public_html">
        AllowOverride All
</Directory>

</VirtualHost>
# vhost_end domain1.com

user1 & domain1.com = example
Regards
Title: Re: Default Page Displayed for all domains
Post by: NALF on June 03, 2015, 04:05:05 AM
Same problem here. When I try to setup a domain on different IP it always shows the default page...  >:(
Title: Re: Default Page Displayed for all domains
Post by: tfbpa on June 16, 2015, 04:00:44 PM
I had the same problem and the problem had to do with Varnish.

It was solved when I finally saw the "If you have more than one IP on your server then click here to use Varnish Multiple IP." option.

This should help IF you have multiple IP's on your server AND are using Varnish.
Title: Re: Default Page Displayed for all domains
Post by: tfbpa on June 16, 2015, 05:29:05 PM
Hmm, now I don't understand it anymore...

With the above setup my domains were working, both the one on shared and dedicated IP, but for some reason my subdomain was simply showing the content of the main domain...

I tried all different Varnish settings and nothing worked, but in the end I went back to DISABLE Varnish multiple IP option and after many times saving the exact same settings, all of a sudden all domains + subdomain are working...

I have noticed in the past few months using the panel that many times the Varnish settings don't get saved properly and that you have to do the same thing 3 or 4 times before the settings are saved correctly, this time it looked to be the same.

So at some level I am happy that all is working now, but since I don't know what actually caused all my misery and the misery from other posters, I cannot help but feel that Varnish needs to be looked into more as it always gives problems, in my case most likely due to not saving settings correctly.

Hope you can fix it in some newer version.
Title: Re: Default Page Displayed for all domains
Post by: jlallen75 on July 13, 2015, 03:23:43 PM
I went to CWP Settings and changed my Default IP to * and the restarted Apache and now my other sites work.

Only took me like 8 hours and 4 complete rebuilds to figure that out...  :-\
Title: Re: Default Page Displayed for all domains
Post by: Treiero on July 13, 2015, 05:29:20 PM
I have the same problem here and I've tried all the solutions proposed since the first message post.

The only thing that changed was when I pointed to the vhost *: 80 instead of "ip": 80.

Before the default page did not display the image and centos_webpanel_logo.png now typically displays.

However, in any field I keep seeing the default page instead of the files contained in public_html.

I'm installing on a EC2 in AWS and the installation correctly recognized the public ip.
Title: Re: Default Page Displayed for all domains
Post by: Administrator on July 13, 2015, 06:43:02 PM
new WebServer selector should have this issue resolved as there is no any-more varnish and nginx separated modules.
Title: Re: Default Page Displayed for all domains
Post by: Treiero on September 11, 2015, 03:06:41 AM
Server IP: xxx.31.33.132 | ip-xxx-31-33-132.sa-east-1.compute.internal
Shared IP: xxx.94.229.218

// Account 1
<VirtualHost xxx.31.33.132:80>
ServerName domain.com

// Account 2
<VirtualHost xxx.31.33.132:80>
ServerName subdomain.domain.com


Problem: subdomain shows the main page of the domain.

Title: Re: Default Page Displayed for all domains
Post by: Igor S. on September 11, 2015, 06:09:30 PM
Hello.

Check the DocumentRoot for the domain and subdomain it must be different.
Title: Re: Default Page Displayed for all domains
Post by: duxzor on September 18, 2015, 05:40:56 PM
Solution:

Go: Apache Configuration ( index.php?module=file_editor&file=/usr/local/apache/conf/httpd.conf )


#Virtual hosts
#Include conf/extra/httpd-vhosts.conf


Remove # only for Include....

And Restart Apache.

: )
Title: Re: Default Page Displayed for all domains
Post by: Igor S. on September 20, 2015, 08:41:06 AM
Solution:

Go: Apache Configuration ( index.php?module=file_editor&file=/usr/local/apache/conf/httpd.conf )


#Virtual hosts
#Include conf/extra/httpd-vhosts.conf


Remove # only for Include....

And Restart Apache.

: )

CWP does not using conf/extra/httpd-vhosts.conf
Title: Re: Default Page Displayed for all domains
Post by: charliefinale on September 25, 2015, 06:09:09 AM
I too faced this problem for hours and in my case it was so simple. In the CWP settings I had put in my public IP address. Put the one that it defaults to, probably 172.xxx.xxx.xxx and all was fixed. You will have to edit your user(s) too so they have this IP address, rebuild virtual hosts and for me anyway the web page was no longer the default one, but the one in the users public directory. I preferred to delete the user and add them again as the option for the 172...IP for users only appeared after I did

I have just looked back on all the posts in this thread and all the server IPs that are listed (many are not)  are either public, or the one given to your PC by your routers (eg 192.xxx.xxx.xxx). Both of these will give the wretched default page for all your domains. There is a third IP to consider, the one that apache creates which is then shares, probably 172.....

So in my case

NS1: a.dxmx.com | IP:78.12.123.232 [Change] Public
NS2: b.dxmx.com | IP:78.12.123.232 [Change] Public
Server IP: 172.31.1.100 | CentOS-67-64-minimal apache IP
Shared IP: 172.31.1.100 [Change] apache IP

For those who have their machines on a router, and I am guessing here, you  will need to forward the ports in the router to the 192.xxx of the machine hosting the webpanel, but that is a completely different issue.

In both cases all domains should point to single public IP address as set with your domain providor (the nameservers) and webpanel/apache will share an internal IP it made up all on its own.

BTW I took out all other suggestions in this thread on the basis that the I think the best config is the one the coders provided in the first place.

Hope this helps.

Title: Re: Default Page Displayed for all domains
Post by: xHalloweenx on October 17, 2015, 03:39:10 PM
/usr/local/apache/conf/httpd.conf
Add
Code: [Select]
NameVirtualHost *:80 -> resolves apache default host to an adaptive address
Comment out
Code: [Select]
#DocumentRoot "/usr/local/apache/htdocs" -> Skips apache default htdocs and default to Virtual Host instance

Apache virtual host template
Replace VirtualHost instance ip with *
Code: [Select]
<VirtualHost *:%domain_port%> -> resolves to common address

Rebuild VirtualHost -> Restart apache [httpd]

Title: Re: Default Page Displayed for all domains
Post by: lordofaxe on December 20, 2015, 02:34:46 PM
Hi every body
I,m a new  on cwp, and have a big problem
i install my cwp then set the shared ip and Setup nameserversand create new account (USER) by domain for example (TEST.COM)
when i open my address insted open my "public-html" folder it,s related to "/usr/local/apache/htdocs/" folder
i " Rebuild Apache vHosts" but problem is still
how can i fix it?


Title: Re: Default Page Displayed for all domains
Post by: ozgur on January 03, 2016, 02:53:20 PM
I have just experienced this problem.
Thanks to @charliefinale. Your method resolved my problem.

To sum up, I deleted the user and recreate it with local IP (192.168.1.xxx) address rather than shared global IP address.
Global "index.html" (it is a welcome page) in "/usr/local/apache/htdocs" changed to user's index.html (it is a welcome page too) in user's public_html directory.

In addition, take into consideration that restart Apache WebServer in Services Status.
Title: Re: Default Page Displayed for all domains
Post by: Jae on January 23, 2016, 07:52:45 AM
/usr/local/apache/conf/httpd.conf
Add
Code: [Select]
NameVirtualHost *:80 -> resolves apache default host to an adaptive address
Comment out
Code: [Select]
#DocumentRoot "/usr/local/apache/htdocs" -> Skips apache default htdocs and default to Virtual Host instance

Apache virtual host template
Replace VirtualHost instance ip with *
Code: [Select]
<VirtualHost *:%domain_port%> -> resolves to common address

Rebuild VirtualHost -> Restart apache [httpd]

I faced this problem too, follow your post, can fix problem.
Only in my cwp, file must edited is "/usr/local/apache/conf/sharedip.conf"
Title: Re: Default Page Displayed for all domains
Post by: Administrator on January 25, 2016, 11:27:22 PM
using local ip isn't necessary anymore since you can enable NAT-ed mod in the CWP settings.
Title: Re: Default Page Displayed for all domains
Post by: shamarkellman on March 03, 2016, 01:55:24 AM
I have this issue and none of these fixes work. This is not a fresh install.. please help. I have tired rebuilding the virtual host. When I click Apache Stautus this is what I get   
Quote
Not Found

   The requested URL /server-status was not found on this server.


My Netstat info gives me this:
Quote
Netstat info
tcp        0      0 :::80                       :::*     
Title: Re: Default Page Displayed for all domains
Post by: kerfiseining on April 30, 2016, 09:46:13 AM
I went to CWP Settings and changed my Default IP to * and the restarted Apache and now my other sites work.

Only took me like 8 hours and 4 complete rebuilds to figure that out...  :-\


This worked for me :) But this will create an error in named. Like this

Checking DNS Zone Record for Domain: yourdomain.ltd   
Checking Zone File: /var/named/yourdomain.ltd.db

dns_rdata_fromtext: /var/named/yourdomain.ltd.db:15: near '*': bad dotted quad
zone yourdomain.ltd/IN: loading from master file /var/named/yourdomain.ltd.db failed: bad dotted quad
zone yourdomain.ltd/IN: not loaded due to errors.

But if your'e behind a router NAT I found out that to fix this is to change the Shared IP: from my external IP to my Local IP.

Now all my websites are working :)
Title: Re: Default Page Displayed for all domains
Post by: aniruddh2511 on July 08, 2016, 08:29:48 AM
 :(

same issues.. check all settings and forum post but no solution..
can anyone help me ?
my all website display default page.. i think vhost not work.. how can i fix it ?
Title: Re: Default Page Displayed for all domains
Post by: imgrooot on September 21, 2016, 05:00:32 PM
What I realized that CWP Apache was not running, but default one was running, so as mentioned in the post below
http://forum.centos-webpanel.com/apache/warning!-you-are-not-running-cwp-apache/

New Installation
1. I had to fix the permission on the new account to server the page but when I
2. Reboot the System , it was loading default apache.

Clicking  [Try Fixing This] resolved the issue on one of my system.

To Determine the cause, we first need to determine which apache is running, If CWP Apache is running then the modifications will help otherwise kill all the apache process and launch the apache from within CWP Panel.

It would help to know what commands are run in the background when [Try Fixing This] link is clicked.

Title: Re: Default Page Displayed for all domains
Post by: Darkroom on September 25, 2016, 04:48:14 AM
^^^ This happened to me recently. I noticed that the apache status was orange (subsystem still running). I tried a service httpd restart and it failed because it couldn't stop http. So a killall -9 httpd it was. Service httpd restart was reportedly successful but all domains gave the default test page. I followed the advice in this thread and nothing helped. A couple apache and vhost rebuilds and nothing. I logged out and logged back in and got the  "WARNING! You are not running CWP Apache and this could cause that your domains do not work!" error. Clicked "Try Fixing this" and it did.

I'm not sure what went wrong or how it was actually fixed so I don't really feel like I have complete closure on this issue.
Title: Re: Default Page Displayed for all domains
Post by: pivey on October 18, 2016, 03:25:25 PM
I am aslo fighting for hours now to fix same issue.
Default page is showing up.
Followed all instructions here + http://wiki.centos-webpanel.com/default-page-displayed-for-all-domains

Problem still there.
vhost config is ok
Nat IP entered as per instructions

Help?  :P
Title: Re: Default Page Displayed for all domains
Post by: ozgur on December 19, 2016, 02:22:20 PM
I have just experienced this problem.
Thanks to @charliefinale. Your method resolved my problem.

To sum up, I deleted the user and recreate it with local IP (192.168.1.xxx) address rather than shared global IP address.
Global "index.html" (it is a welcome page) in "/usr/local/apache/htdocs" changed to user's index.html (it is a welcome page too) in user's public_html directory.

In addition, take into consideration that restart Apache WebServer in Services Status.

I have faced with the same situtation. At those times, I tried to configure CWP in home network and open to the worldwide.
Now, I am reconfiguring CWP in data center and trying to open to the worldwide again. Previous solution is not solving at this time.

I've just resolved my problem with these steps:
I have 2 dedicated ip address and 3 domains.
* I entered local ip address to Shared Ip in CWP Settings page.
* I didn't activated NAT-ed mode and not entered any IP there.
* I rebuilded Virtual Hosts in Apache Settings page.
* I restarted Apache Server in Dashboard page.
* I recreated user1 for domain1 with dedicatedIP1.
* I recreated user2 for domain2 with dedicatedIP1.
* I recreated user3 for domain3 with dedicatedIP2.
* I rebuilded Virtual Hosts in Apache Settings page as well
* I restarted Apache Server in Dashboard page as well.
Then, done!

Note 1: I'm only using Apache as webserver with 80 port.
Note 2: I switched Apache version to Apache/2.2.31 (Unix) from Apache/2.2.27 in "Apache Re-Build" page.
Title: Re: Default Page Displayed for all domains
Post by: indiemy on September 24, 2017, 05:29:57 AM
changing <VirtualHost "public_ip":80>

to

<VirtualHost *:80>

worked for me. the site is still in test stage, I'm not sure if other issues will arise later due to this * setting.
Title: Re: Default Page Displayed for all domains
Post by: studio4host on September 25, 2017, 01:28:43 PM
worked for me. the site is still in test stage, I'm not sure if other issues will arise later due to this * setting.

Any rebuild will cause you the same issue again so its tbest to resolve the issue as * could cause you issue and requires manual changes.

try checking this instructions (all info should be there)
http://wiki.centos-webpanel.com/default-page-displayed-for-all-domains
Title: Re: Default Page Displayed for all domains
Post by: styrcn on January 05, 2018, 09:50:43 PM
all i want is actually install the wordpress on my server before point my domain to the server i need to configure some setting. i mean im gonna use with my servers ip on browser then after finish my work i will launch my site. please help me
Title: Re: Default Page Displayed for all domains
Post by: sreenu143to on December 12, 2018, 01:13:21 PM
I am facing same problem, I tried with new installation and added two domains with wordpress, but it not navigating to wordpress page( domain page), it is showing default page only.   
Title: Re: Default Page Displayed for all domains
Post by: charithabuddhika on December 16, 2018, 10:22:16 AM
I was able to fix this issue following the instructions on the link on EC2 instance.

01. Activate NAT-ed network configuration.
02. Rebuild WebServers' when enabling/disabling NAT-ed mod.

http://wiki.centos-webpanel.com/default-page-displayed-for-all-domains
Title: Re: Default Page Displayed for all domains
Post by: crmgddn63 on December 17, 2018, 07:20:52 AM
i try to everything.

this works for me.

https://www.linuxhelp.com/how-to-update-apache-and-suphp-apache-module-in-centos-web-panel