Author Topic: Domain in Browser doesn't display from user directory  (Read 139 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
Domain in Browser doesn't display from user directory
« on: October 29, 2018, 02:43:59 PM »
I installed CWP, went pro, added mod security.  Went to add a directory and populate it, so I did so and verified that the files were changed to be owned and grouped to the proper user account, and had permissions set correctly.  I even did the User Accounts -> Fix Permissions.

No matter what I do, the actual in browser domain.com shows the default apache page.  It also does not detect file changes, renames, addition of directories or anything else.  This is after using winscp, and the built in cwp file manager.  Even tried to add on extplorer, and it won't recognize the new directory that addon created.  It's as if the domain is somehow locked into the apache directory instead of the user's home/public_html directory where it should be.

Here is the Apache vhosts.conf
Code: [Select]
# vhost_start example.com
<VirtualHost myip:80>
ServerName example.com
ServerAlias www.example.com
ServerAdmin webmaster@example.com
DocumentRoot /home/example/public_html
UseCanonicalName Off
ScriptAlias /cgi-bin/ /home/example/public_html/cgi-bin/

# Custom settings are loaded below this line (if any exist)
# Include "/usr/local/apache/conf/userdata/example/example.com/*.conf"

<IfModule mod_userdir.c>
UserDir disabled
UserDir enabled example
</IfModule>

<IfModule mod_suexec.c>
SuexecUserGroup example example
</IfModule>

<IfModule mod_suphp.c>
suPHP_UserGroup example example
suPHP_ConfigPath /home/example
</IfModule>

<Directory "/home/example/public_html">
AllowOverride All
</Directory>

</VirtualHost>
# vhost_end example.com

It appears to be pointing properly to /home/xotikz/public_html but nothing on the browser has it appearing that way.  I edited the base index.html file in the public_html folder, then I even changed it's name to add a _ so that it would go away and instead display a 404 or something.  No change.  I'm obviously missing something, but not sure where else I'd go look at settings other than the vhosts.

I also tried rebuilding vhosts multiple times, as well as played around with the SSL.

Added:  Not sure if this is an associated issue, but having an issue trying to generate an AutoSSL:

'DNS of your domain doesn't point to this server or you have htaccess restrictions',

Can not make a certificate for main domain or subdomain.  I stopped and disabled named locally since I use a third party DNS service.
« Last Edit: October 29, 2018, 03:20:25 PM by Dumgard »

Offline
*
Re: Domain in Browser doesn't display from user directory
« Reply #1 on: October 29, 2018, 04:16:49 PM »
Went through the stickied post about this issue again, but still no solution.

My apache error log is here https://pastebin.com/Zs5v9FFv.

Offline
*
Re: Domain in Browser doesn't display from user directory
« Reply #2 on: October 29, 2018, 07:12:49 PM »
I just did another complete reinstall of CentOS 7.  I followed https://www.webhostface.com/kb/knowledgebase/centos-web-panel-installation/  which is pretty simple, just updating and then installing the version for centos 7 on the 100% clean install.

After that, I run update_cwp script and it shows my pro status.  I make a new user for my domain (the same domain that the server references --- I use server.domain.com for the domain, and then domain.com for my site.) and then log into FTP with that username and password.  I then create a directory, and move the old index.html into the new directory.  Same problem as above.  The website www.domain.com shows the old index.html default page, when it should be a 404... and the new directory pulls up a 404 as if it does not exist.

Offline
*
[SOLVED] Re: Domain in Browser doesn't display from user directory
« Reply #3 on: October 29, 2018, 07:18:13 PM »
It was the NAT settings in Left-Menu > CWP-Settings > Edit Settings

Afterward, I rebuilt Apache Virtual Hosts and restarted Apache.