Author Topic: ERROR STARTING APACHE - HELP PLEASE PLEASE  (Read 187 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
ERROR STARTING APACHE - HELP PLEASE PLEASE
« on: September 28, 2017, 10:56:01 AM »
Hello community, thanks for having me here.

I am currently experiencing issues with apache as it wont start for over 24hrs now. All i did was change the hostname because i was trying to configure email settings correctly.

Every time i try to start apache from console or ssh, i receive this message:
Code: [Select]
Job for httpd.service failed because the control process exited with error code. See "systemctl status httpd.service" and "journalctl -xe" for details.

When i enter: systemctl status httpd.service, i get the errors below:
Code: [Select]
[root@server ~]# systemctl status httpd.service
* httpd.service - Web server Apache
   Loaded: loaded (/usr/lib/systemd/system/httpd.service; enabled; vendor preset: disabled)
   Active: failed (Result: exit-code) since Thu 2017-09-28 06:28:49 EDT; 12min ago
  Process: 25805 ExecStart=/usr/local/apache/bin/apachectl start (code=exited, status=1/FAILURE)
 Main PID: 490 (code=exited, status=1/FAILURE)

Sep 28 06:28:49 bella systemd[1]: Starting Web server Apache...
Sep 28 06:28:49 bella apachectl[25805]: AH00526: Syntax error on line 8 of /...:
Sep 28 06:28:49 bella apachectl[25805]: Invalid command '<Proxy', perhaps mi...n
Sep 28 06:28:49 bella systemd[1]: httpd.service: control process exited, co...=1
Sep 28 06:28:49 bella systemd[1]: Failed to start Web server Apache.
Sep 28 06:28:49 bella systemd[1]: Unit httpd.service entered failed state.
Sep 28 06:28:49 bella systemd[1]: httpd.service failed.


When i enter: journalctl -xe, i get the errors below:
Code: [Select]
[root@server ~]# journalctl -xe
-- Subject: Unit session-34131082.scope has begun start-up
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
--
-- Unit session-34131082.scope has begun starting up.
Sep 27 02:07:01 bella CROND[29866]: (XXXXX) CMD (/usr/local/bin/php -q /home/XXX
Sep 27 02:07:01 bella systemd[1]: Started Session 34131081 of user XXX.
-- Subject: Unit session-34131081.scope has finished start-up
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
--
-- Unit session-34131081.scope has finished starting up.
--
-- The start-up result is done.
Sep 27 02:07:01 bella systemd[1]: Starting Session 34131081 of user XXX.
-- Subject: Unit session-34131081.scope has begun start-up
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
--
-- Unit session-34131081.scope has begun starting up.
Sep 27 02:07:01 server CROND[29867]: (XXXXX) CMD (/usr/local/bin/php -q /home/XXX
Sep 27 02:07:01 server CROND[29868]: (XXXXX) CMD (/usr/local/bin/php -q /home/XXX
Sep 27 02:07:01 server CROND[29865]: (XXXXX) CMD (/usr/local/bin/php -q /home/XXX
lines 3227-3249/3249 (END)

This is a production server with our main website, anyone can assist please please. I really need help.

Thanks in advance

Offline
*
Re: ERROR STARTING APACHE - HELP PLEASE PLEASE
« Reply #1 on: September 28, 2017, 09:14:23 PM »
try to get this more detailed

Sep 28 06:28:49 bella apachectl[25805]: AH00526: Syntax error on line 8 of /...:
Sep 28 06:28:49 bella apachectl[25805]: Invalid command '<Proxy', perhaps mi...n


you can also try this command
yum reinstall cwp-httpd
AntiDDoS Protection (web + mail)
http://centos-webpanel.com/website-ddos-protection-proxy

Join our Development Team and get paid !
http://centos-webpanel.com/develope-modules-for-cwp


Services Monitoring & RBL Monitoring
http://centos-webpanel.com/services-monitor


Do you need Fast and FREE Support included for your CWP linux server?
http://centos-webpanel.com/noc-partner-list
Installation Instructions
http://centos-webpanel.com/installation-instructions
Get Fast Support Here
http://centos-webpanel.com/support-services

Offline
*
Re: ERROR STARTING APACHE - HELP PLEASE PLEASE
« Reply #2 on: September 29, 2017, 12:46:14 PM »
Thanks for your help but reinsalling using the command did not work : yum reinstall cwp-httpd

We are actually giving up on this as every few months our system breaks and it takes days and sometimes we have to backup to another server and reinstall CWP.

Right now we have lost 2 days of revenue because of this system.
I think its great to use for hobby but not serious product website that makes money.

Thanks again and ciao

Offline
**
Re: ERROR STARTING APACHE - HELP PLEASE PLEASE
« Reply #3 on: September 29, 2017, 02:57:35 PM »
Sounds like a config problem to me. You could get the CWP admins to do a professional install if you ask them nicely and buy a CWP Pro licence.

I host ecommerce sites on servers that run CWP 6 & 7, all are stable with some having an up time greater than 150 days.
Web Design, Development & VPS Hosting
https://6sense.com.au