Author Topic: Mod Pagespeed not working (Solution)  (Read 329 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
Mod Pagespeed not working (Solution)
« on: July 03, 2018, 06:29:03 PM »
Hi,

I've followed the guide from:
http://wiki.centos-webpanel.com/how-to-install-mod_pagespeed

but there is a little error in it.
The config:
/usr/local/apache/conf.d/pagespeed.conf

contains:
Code: [Select]
ModPagespeedFileCachePath            "/var/mod_pagespeed/cache/"
So you need to change this location to
Code: [Select]
ModPagespeedFileCachePath     "/var/cache/mod_pagespeed"
Because the wiki creates the cache file:
Code: [Select]
mkdir -p /var/cache/mod_pagespeed/
chown -R nobody:nobody /var/cache/mod_pagespeed/

So either change the config or lets change the wiki.
Anyone know how to contact the wiki person?


Offline
**
Re: Mod Pagespeed not working (Solution)
« Reply #1 on: July 04, 2018, 05:57:28 AM »
What want kind of websites are you running? If you're running WordPress I think it's better to use these two plugins together, Autoptimize and WP Super Cache. I used to install Mod Pagespeed on my server while it helps but it breaks other scripts. I end up disabling it for many scripts because it doesn't work with mod_pagespeed enabled.

Anyways, I think those 2 plugins together work just as good or even better. Plus Varnish, it's get even more awesome.