Author Topic: Unable to write .htaccess in my CWP  (Read 647 times)

0 Members and 1 Guest are viewing this topic.

Unable to write .htaccess in my CWP
« on: September 26, 2018, 10:37:32 PM »
Hello, I have been stuck with this problem for a week now.

My issue is, all WordPress site cannot create their own .htaccess for permalinks, one of this site is my http://tutorials.kurtobando.com

At this point, I have created it manually, however, if you rename .htaccess to .htaccess_old and let WordPress create new .htaccess, Settings > Permalinks. This is not making any changes on the backend.

By any chance, do you know how to sort this out, or any related article that I can use for isolation. I hope you guys can help me out.

Here are the screenshots of my current setup at the moment.

Directory Permission of tutorials.kurtobando.com
https://snag.gy/LxfMHa.jpg

vHost for tutorials.kurtobando.com
https://snag.gy/0HZqbf.jpg

In addition to this case, here are the latest log, after I click on Permalinks before sending this message.
https://snag.gy/Eh8IrF.jpg

I do not see any error in Mod_sec as well, please see:
Code: [Select]
[Wed Sep 26 18:21:46.355153 2018] [:notice] [pid 18725:tid 139673502525312] ModSecurity: LIBXML compiled version="2.9.1"
[Wed Sep 26 18:21:46.355155 2018] [:notice] [pid 18725:tid 139673502525312] ModSecurity: Original server signature: Apache/2.4.34 (Unix) OpenSSL/1.0.1e-fips
[Wed Sep 26 18:21:46.355158 2018] [:notice] [pid 18725:tid 139673502525312] ModSecurity: Status engine is currently disabled, enable it by set SecStatusEngine to On.
[Wed Sep 26 22:41:07.935974 2018] [:error] [pid 18841:tid 139673108166400] [client 115.231.219.28:41938] [client 115.231.219.28] ModSecurity: Access denied with code 403 (phase 2). Pattern match "(?i:(?:^(?:microsoft url|user-Agent|www\\\\.weblogs\\\\.com|(?:jakart|vi)a|(google|i{0,1}explorer{0,1}\\\\.exe|(ms){0,1}ie( [0-9.]{1,}){0,1} {0,1}(compatible( browser){0,1}){0,1})$)|\\\\bdatacha0s\\\\b|; widows|\\\\\\\\r|a(?: href=|d(?:sarobot|vanced email extractor ..." at REQUEST_HEADERS:User-Agent. [file "/usr/local/apache/modsecurity-cwaf/rules/03_Global_Agents.conf"] [line "29"] [id "210831"] [rev "2"] [msg "COMODO WAF: Rogue web site crawler||178.128.119.56|F|4"] [data "Indy Library"] [severity "WARNING"] [tag "CWAF"] [tag "Agents"] [hostname "178.128.119.56"] [uri "/manager/html"] [unique_id "W6uag0I2KkEgyxXUjl8DNQAAANE"]

Code: [Select]
===============================================
Kernel:
Linux webcloud.sg.kurtobando.com 4.18.8-1.el7.elrepo.x86_64 #1 SMP Sat Sep 15 10                                                      :10:09 EDT 2018 x86_64 x86_64 x86_64 GNU/Linux

CPU info:
model name      : Intel(R) Xeon(R) CPU E5-2650 v4 @ 2.20GHz

Release:
CentOS Linux release 7.5.1804 (Core)

Arch:
x86_64

Virtualization Type:
kvm

Memory:
              total        used        free      shared  buff/cache   available
Mem:           1993         816          71          13        1105         936
Swap:          4095         543        3552

MySQL info:
mysql  Ver 15.1 Distrib 10.1.36-MariaDB, for Linux (x86_64) using readline 5.1

Disk Info:
Filesystem      Size  Used Avail Use% Mounted on
devtmpfs        973M     0  973M   0% /dev
tmpfs           997M     0  997M   0% /dev/shm
tmpfs           997M   25M  973M   3% /run
tmpfs           997M     0  997M   0% /sys/fs/cgroup
/dev/vda1        60G   18G   43G  30% /
tmpfs           200M     0  200M   0% /run/user/0
tmpfs           200M     0  200M   0% /run/user/1003


#
# /etc/fstab
# Created by anaconda on Wed May 16 20:44:20 2018
#
# Accessible filesystems, by reference, are maintained under '/dev/disk'
# See man pages fstab(5), findfs(8), mount(8) and/or blkid(8) for more info
#
/dev/vda1 / xfs rw,relatime,attr2,inode64,noquota 0 0
/swapfile   swap    swap    sw  0   0

Apache PHP info:
PHP 7.1.0 (cli) (built: Sep 10 2018 19:20:23) ( NTS )
Copyright (c) 1997-2016 The PHP Group
Zend Engine v3.1.0-dev, Copyright (c) 1998-2016 Zend Technologies
    with the ionCube PHP Loader (enabled) + Intrusion Protection from ioncube24.                                                      com (unconfigured) v10.2.4, Copyright (c) 2002-2018, by ionCube Ltd.

Apache start script check:
grep: /etc/init.d/httpd: No such file or directory

CWP Admin check:
/usr/local/cwpsrv/htdocs/admin

CWP version:
0.9.8.740
===============================================

At this point, I do not know where to start. I hope you can guide me instead.

Regards,
Kurt

Offline
*
Re: Unable to write .htaccess in my CWP
« Reply #1 on: February 25, 2019, 03:26:11 AM »
Hi i have just the same issue, did you were able to fix it? how?!

Thanks a lot in advance.

Offline
**
Re: Unable to write .htaccess in my CWP
« Reply #2 on: February 25, 2019, 05:53:39 PM »
Who is the owner of the files and folders? How did you install  WordPress?

Offline
*
Re: Unable to write .htaccess in my CWP
« Reply #3 on: February 27, 2019, 12:22:19 PM »
Hi everyone,

I'm having same trouble, if someone find the solution :)

Best regards,

Offline
*
Re: Unable to write .htaccess in my CWP
« Reply #4 on: February 27, 2019, 04:30:12 PM »
same problem here... fresh installation, changed to php 7.2.x and my htaccess not works. any solution?

Offline
*
Re: Unable to write .htaccess in my CWP
« Reply #5 on: March 01, 2019, 05:19:55 PM »
Who is the owner of the files and folders? How did you install  WordPress?

I create an account for "exampleuser"

I check via Admin an SSH and the user has permission on the files (home/exampleuser,  home/exampleuser/public_html and so on) , (i even tried CHOWN for that) no luck, also I read you need to give Apache permission, so  i try but never found apache user, or www-data user. So i got lost.

For know i used the manual creation of htaccess, wich works fine, but Permalinks in wordpress is not updating (overwriting or creating) the htaccess file..

I install Wordpress manually, upload wordpress via zip, then unzip, then create Database and user, and then install.

In the PRO versión this works fine?
« Last Edit: March 01, 2019, 05:21:55 PM by Monclee »