Author Topic: Wordfence / Ninja Firewall  (Read 330 times)

0 Members and 1 Guest are viewing this topic.

Offline
**
Wordfence / Ninja Firewall
« on: December 09, 2018, 06:14:36 PM »
Hi,


Since the update to PHP-FPM I can't install Wordfence or Ninja Firewall (both are using auto_prepend_file) on my wordpress sites.
My webserver is apache + varnish + php-fpm. I've also tried changing the webserver to use fastcgi, but it didn't change anything.


Any idea?

Offline
*
Re: Wordfence / Ninja Firewall
« Reply #1 on: December 09, 2018, 07:13:13 PM »
I'm running Wordfence. Did you configure the domain with

Web Server Setting>WebServers domain conf

FPM uses .user.ini which wordfence altered to

; Wordfence WAF
auto_prepend_file = '/home/jet/public_html/wordfence-waf.php'
; END Wordfence WAF

Offline
**
Re: Wordfence / Ninja Firewall
« Reply #2 on: December 11, 2018, 01:15:40 PM »
All my domains are configured to use PHP-FPM
When I login to wp-admin I'm getting this:




And when trying to configure wordfence clicking "CLICK HERE TO CONFIGURE",  I get this:
« Last Edit: December 11, 2018, 01:18:05 PM by ring_c »