Author Topic: 502 Bad Gateway  (Read 3897 times)

0 Members and 1 Guest are viewing this topic.

Offline
***
Re: 502 Bad Gateway
« Reply #15 on: August 07, 2018, 07:37:07 AM »
[root@host ~]# /sbin/service cwpsrv status
cwpsrv (pid  29955) is running...
[root@host ~]#
[root@host ~]# /sbin/service cwp-phpfpm status
cwp-phpfpm (pid  30138) is running...

Now it seems ok....

Offline
*
Re: 502 Bad Gateway
« Reply #16 on: August 11, 2018, 12:30:50 PM »
my server is centos release 6.10 final 32 bit

admin panel not work and apache logs

2018/08/11 14:45:36 [crit] 1843#0: *2029 connect() to unix:/usr/local/cwp/php71/var/sockets/cwpsrv.sock failed (2: No such file or directory) while connecting to upstream, client: 85.96.203.95, server: localhost, request: "GET / HTTP/1.$
2018/08/11 14:45:36 [error] 1843#0: *2029 open() "/usr/local/cwpsrv/htdocs/admin/favicon.ico" failed (2: No such file or directory), client: 85.96.203.95, server: localhost, request: "GET /favicon.ico HTTP/1.1", host: "ziyasuzen.com:203$




and services status



[root@svr1 scripts]# service cwpsrv status
service cwp-phpfpm statuscwpsrv (pid  14706) is running...
[root@svr1 scripts]# service cwp-phpfpm status
cwp-phpfpm: unrecognized service

[root@svr1 scripts]# service php-fpm start
php-fpm: unrecognized service




what happen?


i want to update my php versiyon php7


now my admin panel not open please help

Offline
****
Re: 502 Bad Gateway
« Reply #17 on: August 12, 2018, 12:34:58 PM »
The below command will fix issue for you

Code: [Select]
yum install cwp-phpfpm -y
sh /scripts/cwpsrv_rebuild_user_conf

Offline
*
Re: 502 Bad Gateway
« Reply #18 on: August 19, 2019, 03:56:24 AM »
I have done as you told and get this:

[root@vps ~]# sh /scripts/cwpsrv_rebuild_user_conf
Reloading cwpsrv:
Reloading cwp-phpfpm: [19-Aug-2019 10:52:50] NOTICE: configuration file /usr/local/cwp/php71/etc/php-fpm.conf test is successful

                                                           [FAILED]

Please tell me how to do now?

Offline
*
Re: 502 Bad Gateway
« Reply #19 on: September 05, 2019, 08:47:54 AM »
On 3 different servers
same problems help me

CentOS release 6.10 (Final)
------
service cwp-phpfpm status
cwp-phpfpm (pid  14037) is running...
------
[root@server users]# service cwpsrv status
cwpsrv (pid  2963) is running...
------
[05-Sep-2019 11:37:11] NOTICE: fpm is running, pid 14037
[05-Sep-2019 11:37:11] NOTICE: ready to handle connections
[05-Sep-2019 11:44:04] NOTICE: Terminating ...
[05-Sep-2019 11:44:04] NOTICE: exiting, bye-bye!
[05-Sep-2019 11:44:04] NOTICE: fpm is running, pid 16268
[05-Sep-2019 11:44:04] NOTICE: ready to handle connections
--------
$webpanel_version = "0.9.8.683";
--------
sh /scripts/restart_cwpsrv  #no work
sh /scripts/cwpsrv_rebuild_user_conf  #no work




Offline
*
Re: 502 Bad Gateway
« Reply #20 on: September 05, 2019, 03:57:02 PM »
Try to using this command in ssh :

First rebuild user conf :
Code: [Select]
sh /scripts/cwpsrv_rebuild_user_conf

And update the CWP :
Code: [Select]
sh /scripts/update_cwp

Then restart the cwpsrv :
Code: [Select]
service cwpsrv restart
service cwpsrv-phpfpm restart