Author Topic: Starting cwpsrv: cwpsrv: [emerg] SL_CTX_use_PrivateKey_file("/etc/pki/tls/privat  (Read 1792 times)

0 Members and 2 Guests are viewing this topic.

Offline
*
Quote
Starting cwpsrv: cwpsrv: [emerg] SL_CTX_use_PrivateKey_file("/etc/pki/tls/private/hostname.key") failed (SSL: error:0B080074:x509 certificate routines:X509_check_private_key:key values mismatch)

How to fix this ?

Offline
*
I had the same error after creating a subdomain for my hostname and generating a letsencrypt-ssl forit.I was ableto resolve that error by logging in as root via ssh and running

Code: [Select]
root@hostname# ./scripts/generate_hostname_ssl
then

Code: [Select]
root@hostname# systemctl start cwpsrv.service
That got cwpsrv.service running, however after that httpd.service didn't want to start, so right now i'm going to try a couple things to get that going (rebuild vhosts, etc). But atleast I'm able to access cwp-admin now.

Best of luck, I'll update this when I find the fix for httpd.service

Offline
*
I have the same problem after CWP support worked on my server and then I rebooted and now I cant start CWP.

All this happened because of conflicts and issues with the old lets encrypt and the new autossl.

it was a nightmare, I am scared to try the above command it it then does not start httpd

So any luck ?

Offline
*
Hey, I've got the same issue and cwpsrv doesn't start:

Code: [Select]
Starting CentOS Web Panel service (daemon)...
cwpsrv: [emerg] SL_CTX_use_PrivateKey_file("/etc/pki/tls/private/hostname.key") failed (SSL: error:0B080074:x509 certificate routines:X509_check_private_key:key valu
cwpsrv[10853]: cwpsrv:configuration file /usr/local/cwpsrv/conf/cwpsrv.conf test failed
systemd[1]: cwpsrv.service: control process exited, code=exited status=1
systemd[1]: Failed to start CentOS Web Panel service (daemon).
systemd[1]: Unit cwpsrv.service entered failed state.
systemd[1]: cwpsrv.service failed.
systemd[1]: cwpsrv.service holdoff time over, scheduling restart.

I do not have the script you mention
Code: [Select]
/scripts/generate_hostname_ssl, where can I get it or how can I solve this?

Thank you in advance

Damon H.

Offline
*
I found it! Sorry for the dumb question.
For anyone else with this problem, the script is located in
Code: [Select]
/usr/local/cwpsrv/htdocs/resources/scripts/generate_hostname_sslSolved!