Author Topic: (HY000/1045): Access denied for user postfix@localhost  (Read 204 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
(HY000/1045): Access denied for user postfix@localhost
« on: August 17, 2017, 07:37:24 AM »
Hello,

Due to aliyun china i have to process installation two times, because it always stuck on pure-ftpd installation and clamav and in second attempt it done it and install it.

now the only issue i have is this error shows when i login to cwp "Warning: [obfuscated](): (HY000/1045): Access denied for user 'postfix'@'localhost' (using password: YES) in /usr/local/cwpsrv/htdocs/admin/admin/index.php on line 0"

i already try deleted user "postfix'@'localhost" and re-added it with default privileges but it still shows, even after deleting postfix database it still shows. any clue how can i fix this ?

thanks

Offline
*
Re: (HY000/1045): Access denied for user postfix@localhost
« Reply #1 on: August 17, 2017, 08:22:11 AM »
Error log at /usr/local/cwpsrv/logs/error_log

2017/08/17 16:18:04 [error] 1473#0: *1547 FastCGI sent in stderr: "PHP message: PHP Warning:  [obfuscated](): (HY000/1045): Access denied for user 'postfix'@'localhost' (using password: YES) in /usr/local/cwpsrv/htdocs/admin/user/index.php on line 0" while reading response header from upstream, client: 182.182.3.186, server: localhost, request: "GET /user/index.php HTTP/1.1", upstream: "fastcgi://unix:/usr/local/cwp/php71/var/sockets/cwpsrv.sock:", host: "48.42.228.213:2030", referrer: "http://48.42.228.213:2030/user/index.php?module=phpini_editor"

Offline
***
Re: (HY000/1045): Access denied for user postfix@localhost
« Reply #2 on: August 21, 2017, 01:22:18 PM »
you need to check that postifx user and password is correctly set for all scripts in:

/etc/postifx
/etc/dovecot
/usr/local/cwpsrv/htdocs/resources/admin/include/postfix.php
VPS & Dedicated server provider with included FREE Managed support for CWP.
http://www.studio4host.com/

Offline
*
Re: (HY000/1045): Access denied for user postfix@localhost
« Reply #3 on: August 22, 2017, 11:21:15 AM »
Thanks brother,

the problem was with the password, i found password in the file /usr/local/cwpsrv/htdocs/resources/admin/include/postfix.php and i copy that password and change it from the phpmyadmin for the user postfix and the error gone.

Thanks again