Author Topic: 503 Service Unavailable The server is temporarily unable to service your request  (Read 461 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
Quote
[Tue Oct 08 11:19:31.627585 2019] [proxy_fcgi:error] [pid 24068:tid 140644047570688] [client 195.69.223.251:48924] AH01079: failed to make connection to backend: httpd-UDS
[Tue Oct 08 11:21:24.842921 2019] [proxy:error] [pid 24068:tid 140644030785280] (2)No such file or directory: AH02454: FCGI: attempt to connect to Unix domain socket /opt/alt/php-fpm56/usr/var/sockets/forbs.sock (*) failed
[Tue Oct 08 11:21:24.842989 2019] [proxy_fcgi:error] [pid 24068:tid 140644030785280] [client 195.69.223.251:49064] AH01079: failed to make connection to backend: httpd-UDS
[Tue Oct 08 11:21:25.913588 2019] [proxy:error] [pid 24068:tid 140644013999872] (2)No such file or directory: AH02454: FCGI: attempt to connect to Unix domain socket /opt/alt/php-fpm56/usr/var/sockets/forbs.sock (*) failed
[Tue Oct 08 11:21:25.913664 2019] [proxy_fcgi:error] [pid 24068:tid 140644013999872] [client 195.69.223.251:49068] AH01079: failed to make connection to backend: httpd-UDS
[Tue Oct 08 11:21:30.943771 2019] [proxy:error] [pid 24068:tid 140644207032064] (2)No such file or directory: AH02454: FCGI: attempt to connect to Unix domain socket /opt/alt/php-fpm56/usr/var/sockets/forbs.sock (*) failed
[Tue Oct 08 11:21:30.943808 2019] [proxy_fcgi:error] [pid 24068:tid 140644207032064] [client 195.69.223.251:49072] AH01079: failed to make connection to backend: httpd-UDS
[Tue Oct 08 11:21:35.900440 2019] [proxy:error] [pid 1183:tid 139809607628544] (2)No such file or directory: AH02454: FCGI: attempt to connect to Unix domain socket /opt/alt/php-fpm56/usr/var/sockets/forbs.sock (*) failed
[Tue Oct 08 11:21:35.900649 2019] [proxy_fcgi:error] [pid 1183:tid 139809607628544] [client 195.69.223.251:49076] AH01079: failed to make connection to backend: httpd-UDS
[Tue Oct 08 11:21:45.940573 2019] [proxy:error] [pid 1183:tid 139809641199360] (2)No such file or directory: AH02454: FCGI: attempt to connect to Unix domain socket /opt/alt/php-fpm56/usr/var/sockets/forbs.sock (*) failed
[Tue Oct 08 11:21:45.940663 2019] [proxy_fcgi:error] [pid 1183:tid 139809641199360] [client 195.69.223.251:49080] AH01079: failed to make connection to backend: httpd-UDS

Offline
*
Quote
Redirecting to /bin/systemctl status php-fpm56.service
● php-fpm56.service - The PHP FastCGI Process Manager
   Loaded: loaded (/usr/lib/systemd/system/php-fpm56.service; enabled; vendor preset: disabled)
   Active: failed (Result: exit-code) since вт 2019-10-08 12:26:32 EEST; 9s ago
  Process: 19253 ExecStart=/opt/alt/php-fpm56/usr/sbin/php-fpm --nodaemonize --fpm-config /opt/alt/php-fpm56/usr/etc/php-fpm.conf (code=exited, status=203/EXEC)
 Main PID: 19253 (code=exited, status=203/EXEC)

жов 08 12:26:32 cwp.forbs.shop systemd[1]: Started The PHP FastCGI Process Manager.
жов 08 12:26:32 cwp.forbs.shop systemd[1]: php-fpm56.service: main process exited, code=exited, status=203/EXEC
жов 08 12:26:32 cwp.forbs.shop systemd[1]: Unit php-fpm56.service entered failed state.
жов 08 12:26:32 cwp.forbs.shop systemd[1]: php-fpm56.service failed.

Offline
*
it's very simple, if you want to use a php-selector then you need to use cwppro version.
You still can use php switcher to change php version.
VPS & Dedicated server provider with included FREE Managed support for CWP.
http://www.studio4host.com/

*** Don't allow that your server or website is down, choose hosting provider with included expert managed support for your CWP.

Offline
*
After update CWP7:

php-fpm72.service failed.

All my servers are down

Offline
*
Same issue here. Even on servers that are NOT using PHP or FPM Selector. Issue with permissions on the PHP bin exec after updates.

Has this been done deliberately to get user to move over pro? If so this is a massive break in trust - forcing server malfunctions to get pro take up should not be the way to go. Disable the feature in the UI if you really want people to sign up for pro.

Secondly, something else broke as well. If with manually configure PHP it seems you setting permissions on /opt/alt/ such that PHP version cannot be executed. So in instances where PHP Selector or FPM were tried and then DISABLED you still get a 503 or 500.



   

Offline
*
same issue!!!
+++++
Disable the feature in the UI if you really want people to sign up for pro.
+++++
« Last Edit: October 09, 2019, 08:45:30 AM by apsuva »

Offline
*
I faced the same problem!
Obviously, the problem appears after updates. In order to fix this I switched php to latest version from PHP Version Switcher.
Then, I went to Select WebSevers sub-menu, click "Apache only" and uncheck " Force Apache to use PHP-FPM Selector, this will disable PHP Selector 2 and PHP Version Switcher."
Save and rebuild configuration and all things look good.

Offline
*
same issue!!!
+++++
Disable the feature in the UI if you really want people to sign up for pro.
+++++

Agreed. For a temporary fix, I had to create a script executed by cron after the cwp daily cron executed to automatically set php-fpm executable permission and restart the service.
Though in one of my server where I deleted php-fpm managed by cwp and then installed it manually, the php-fpm permission did not get modified by cwp daily cron