Author Topic: Apache not loading (correct config it seems) after reboot(s)  (Read 1099 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
Apache not loading (correct config it seems) after reboot(s)
« on: February 21, 2018, 05:07:19 PM »
Hello,

I am using CentOs 7 and have it running for quite some time now. Months ago I noticed a problem that when rebooting the server my configuration for Apache was incorrect. Is was not loading all the Vhost and was only showing the default welcome page or the 'index of /' webpage. I found out that after a (couple of) reboot it somehow somewhy started working again. But now I have restarted the server again and I cannot get it to work anymore. I think it is not loading the correct configuration. I used this website to set up my server: https://www.digitalocean.com/community/ ... n-centos-7

Now I have in my /etc/httpd/conf/conf.d the 'correct' configuration. That is where all the virtualhosts are loaded. But now it seems somehow that httpd when started is loading the configuration from /usr/local/apache/conf/conf.d.

I tried creating a symbolic link for the /usr one to the /etc one but then I got all kind of other errors. I have set a complete backup back. I have uninstalled httpd (manually removed both directories), reinstalled it and copied the config back. But somehow it just does not work. It seems not to load my config from the sites-enabled directories. Even though, when I do "apachectl configtest" I do get some warnings from my virtualhosts it seems.

I have no clue how I can get my sites to show up correctly again. Does anyone have any pointers of what I could do to do further troubleshooting? Thanks in advance! I am running CWP7.admin.

The strange thing is that if I run rpm -qc httpd" I do get the config I expect (httpd.conf from /etc/httpd/conf).

/etc/httpd/conf.d/autoindex.conf
/etc/httpd/conf.d/userdir.conf
/etc/httpd/conf.d/welcome.conf
/etc/httpd/conf.modules.d/00-base.conf
/etc/httpd/conf.modules.d/00-dav.conf
/etc/httpd/conf.modules.d/00-lua.conf
/etc/httpd/conf.modules.d/00-mpm.conf
/etc/httpd/conf.modules.d/00-proxy.conf
/etc/httpd/conf.modules.d/00-systemd.conf
/etc/httpd/conf.modules.d/01-cgi.conf
/etc/httpd/conf/httpd.conf
/etc/httpd/conf/magic
/etc/logrotate.d/httpd
/etc/sysconfig/htcacheclean
/etc/sysconfig/httpd

Offline
****
Re: Apache not loading (correct config it seems) after reboot(s)
« Reply #1 on: February 21, 2018, 05:15:16 PM »
see if the logs provide a clue

Code: [Select]
tail -f /usr/local/apache/logs/error_log

Offline
*
Re: Apache not loading (correct config it seems) after reboot(s)
« Reply #2 on: February 21, 2018, 05:42:12 PM »
Only thing I see in there atm are ModSecurity errors regarding "Request Missing a Host Header" (id 960008)

Offline
****
Re: Apache not loading (correct config it seems) after reboot(s)
« Reply #3 on: February 21, 2018, 05:43:59 PM »
try uninstall mod_security for the moment and see what the result is

Offline
*
Re: Apache not loading (correct config it seems) after reboot(s)
« Reply #4 on: February 21, 2018, 06:43:27 PM »
mod_security installed. Websites still not showing up (and apache not running on https at all). Nothing noticable in the error_log.

Only thing I see on all my webpages is the CWP "HTTP test page".

Could it be a problem that it is running two webservers (CWP on 2030) and next to it the default httpd on 80 and 443?

Offline
****
Re: Apache not loading (correct config it seems) after reboot(s)
« Reply #5 on: February 21, 2018, 07:07:52 PM »
if you see that CWP test page means that httpd is working, just on port 80 then. For it work on port 443 ssl needs to be enabled and a certificate to be installed

Offline
*
Re: Apache not loading (correct config it seems) after reboot(s)
« Reply #6 on: February 21, 2018, 07:14:43 PM »
Thanks for your reply (and time)

Everything worked previously. I have a letencrypt cert with all required host names. If I press F5 on the website I get the 'Index of /' page without any files.

It has worked for like 1.5 year, but somehow after todays reboot it does not anymore. And I have no idea how to troubleshoot, since I get no error message or something. This is my httpd.conf, maybe that someone sees an error there?

Code: [Select]
#
# This is the main Apache HTTP server configuration file.  It contains the
# configuration directives that give the server its instructions.
# See <URL:http://httpd.apache.org/docs/2.4/> for detailed information.
# In particular, see
# <URL:http://httpd.apache.org/docs/2.4/mod/directives.html>
# for a discussion of each configuration directive.
#
# Do NOT simply read the instructions in here without understanding
# what they do.  They're here only as hints or reminders.  If you are unsure
# consult the online docs. You have been warned. 
#
# Configuration and logfile names: If the filenames you specify for many
# of the server's control files begin with "/" (or "drive:/" for Win32), the
# server will use that explicit path.  If the filenames do *not* begin
# with "/", the value of ServerRoot is prepended -- so 'log/access_log'
# with ServerRoot set to '/www' will be interpreted by the
# server as '/www/log/access_log', where as '/log/access_log' will be
# interpreted as '/log/access_log'.

#
# ServerRoot: The top of the directory tree under which the server's
# configuration, error, and log files are kept.
#
# Do not add a slash at the end of the directory path.  If you point
# ServerRoot at a non-local disk, be sure to specify a local disk on the
# Mutex directive, if file-based mutexes are used.  If you wish to share the
# same ServerRoot for multiple httpd daemons, you will need to change at
# least PidFile.
#
ServerRoot "/etc/httpd"

#
# Listen: Allows you to bind Apache to specific IP addresses and/or
# ports, instead of the default. See also the <VirtualHost>
# directive.
#
# Change this to Listen on specific IP addresses as shown below to
# prevent Apache from glomming onto all bound IP addresses.
#
#Listen 12.34.56.78:80
Listen 80

#
# Dynamic Shared Object (DSO) Support
#
# To be able to use the functionality of a module which was built as a DSO you
# have to place corresponding `LoadModule' lines at this location so the
# directives contained in it are actually available _before_ they are used.
# Statically compiled modules (those listed by `httpd -l') do not need
# to be loaded here.
#
# Example:
# LoadModule foo_module modules/mod_foo.so
#
Include conf.modules.d/*.conf

#
# If you wish httpd to run as a different user or group, you must run
# httpd as root initially and it will switch. 
#
# User/Group: The name (or #number) of the user/group to run httpd as.
# It is usually good practice to create a dedicated user and group for
# running httpd, as with most system services.
#
User apache
Group apache

# 'Main' server configuration
#
# The directives in this section set up the values used by the 'main'
# server, which responds to any requests that aren't handled by a
# <VirtualHost> definition.  These values also provide defaults for
# any <VirtualHost> containers you may define later in the file.
#
# All of these directives may appear inside <VirtualHost> containers,
# in which case these default settings will be overridden for the
# virtual host being defined.
#

#
# ServerAdmin: Your address, where problems with the server should be
# e-mailed.  This address appears on some server-generated pages, such
# as error documents.  e.g. admin@your-domain.com
#
ServerAdmin **removed**

#
# ServerName gives the name and port that the server uses to identify itself.
# This can often be determined automatically, but we recommend you specify
# it explicitly to prevent problems during startup.
#
# If your host doesn't have a registered DNS name, enter its IP address here.
#
ServerName eubeprovps.eubepro.com:80

#
# Deny access to the entirety of your server's filesystem. You must
# explicitly permit access to web content directories in other
# <Directory> blocks below.
#
<Directory />
    AllowOverride none
    Require all denied
</Directory>

#
# Note that from this point forward you must specifically allow
# particular features to be enabled - so if something's not working as
# you might expect, make sure that you have specifically enabled it
# below.
#

#
# DocumentRoot: The directory out of which you will serve your
# documents. By default, all requests are taken from this directory, but
# symbolic links and aliases may be used to point to other locations.
#
DocumentRoot "/var/www/html"

#
# Relax access to content within /var/www.
#
<Directory "/var/www">
    AllowOverride All
    # Allow open access:
    Require all granted
</Directory>

# Further relax access to the default document root:
<Directory "/var/www/html">
    #
    # Possible values for the Options directive are "None", "All",
    # or any combination of:
    #   Indexes Includes FollowSymLinks SymLinksifOwnerMatch ExecCGI MultiViews
    #
    # Note that "MultiViews" must be named *explicitly* --- "Options All"
    # doesn't give it to you.
    #
    # The Options directive is both complicated and important.  Please see
    # http://httpd.apache.org/docs/2.4/mod/core.html#options
    # for more information.
    #
    Options Indexes FollowSymLinks

    #
    # AllowOverride controls what directives may be placed in .htaccess files.
    # It can be "All", "None", or any combination of the keywords:
    #   Options FileInfo AuthConfig Limit
    #
    AllowOverride None

    #
    # Controls who can get stuff from this server.
    #
    Require all granted
</Directory>

#
# DirectoryIndex: sets the file that Apache will serve if a directory
# is requested.
#
<IfModule dir_module>
    DirectoryIndex index.php index.html index.htm
</IfModule>

#
# The following lines prevent .htaccess and .htpasswd files from being
# viewed by Web clients.
#
<Files ".ht*">
    Require all denied
</Files>

#
# ErrorLog: The location of the error log file.
# If you do not specify an ErrorLog directive within a <VirtualHost>
# container, error messages relating to that virtual host will be
# logged here.  If you *do* define an error logfile for a <VirtualHost>
# container, that host's errors will be logged there and not here.
#
ErrorLog "logs/error_log"

#
# LogLevel: Control the number of messages logged to the error_log.
# Possible values include: debug, info, notice, warn, error, crit,
# alert, emerg.
#
LogLevel warn

<IfModule log_config_module>
    #
    # The following directives define some format nicknames for use with
    # a CustomLog directive (see below).
    #
    LogFormat "%h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\"" combined
    LogFormat "%h %l %u %t \"%r\" %>s %b" common

    <IfModule logio_module>
      # You need to enable mod_logio.c to use %I and %O
      LogFormat "%h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\" %I %O" combinedio
    </IfModule>

    #
    # The location and format of the access logfile (Common Logfile Format).
    # If you do not define any access logfiles within a <VirtualHost>
    # container, they will be logged here.  Contrariwise, if you *do*
    # define per-<VirtualHost> access logfiles, transactions will be
    # logged therein and *not* in this file.
    #
    #CustomLog "logs/access_log" common

    #
    # If you prefer a logfile with access, agent, and referer information
    # (Combined Logfile Format) you can use the following directive.
    #
    CustomLog "logs/access_log" combined
</IfModule>

<IfModule alias_module>
    #
    # Redirect: Allows you to tell clients about documents that used to
    # exist in your server's namespace, but do not anymore. The client
    # will make a new request for the document at its new location.
    # Example:
    # Redirect permanent /foo http://www.example.com/bar

    #
    # Alias: Maps web paths into filesystem paths and is used to
    # access content that does not live under the DocumentRoot.
    # Example:
    # Alias /webpath /full/filesystem/path
    #
    # If you include a trailing / on /webpath then the server will
    # require it to be present in the URL.  You will also likely
    # need to provide a <Directory> section to allow access to
    # the filesystem path.

    #
    # ScriptAlias: This controls which directories contain server scripts.
    # ScriptAliases are essentially the same as Aliases, except that
    # documents in the target directory are treated as applications and
    # run by the server when requested rather than as documents sent to the
    # client.  The same rules about trailing "/" apply to ScriptAlias
    # directives as to Alias.
    #
    ScriptAlias /cgi-bin/ "/var/www/cgi-bin/"

</IfModule>

#
# "/var/www/cgi-bin" should be changed to whatever your ScriptAliased
# CGI directory exists, if you have that configured.
#
<Directory "/var/www/cgi-bin">
    AllowOverride None
    Options None
    Require all granted
</Directory>

<IfModule mime_module>
    #
    # TypesConfig points to the file containing the list of mappings from
    # filename extension to MIME-type.
    #
    TypesConfig /etc/mime.types

    #
    # AddType allows you to add to or override the MIME configuration
    # file specified in TypesConfig for specific file types.
    #
    #AddType application/x-gzip .tgz
    #
    # AddEncoding allows you to have certain browsers uncompress
    # information on the fly. Note: Not all browsers support this.
    #
    #AddEncoding x-compress .Z
    #AddEncoding x-gzip .gz .tgz
    #
    # If the AddEncoding directives above are commented-out, then you
    # probably should define those extensions to indicate media types:
    #
    AddType application/x-compress .Z
    AddType application/x-gzip .gz .tgz

    #
    # AddHandler allows you to map certain file extensions to "handlers":
    # actions unrelated to filetype. These can be either built into the server
    # or added with the Action directive (see below)
    #
    # To use CGI scripts outside of ScriptAliased directories:
    # (You will also need to add "ExecCGI" to the "Options" directive.)
    #
    #AddHandler cgi-script .cgi

    # For type maps (negotiated resources):
    #AddHandler type-map var

    #
    # Filters allow you to process content before it is sent to the client.
    #
    # To parse .shtml files for server-side includes (SSI):
    # (You will also need to add "Includes" to the "Options" directive.)
    #
    AddType text/html .shtml
    AddOutputFilter INCLUDES .shtml
</IfModule>

#
# Specify a default charset for all content served; this enables
# interpretation of all content as UTF-8 by default.  To use the
# default browser choice (ISO-8859-1), or to allow the META tags
# in HTML content to override this choice, comment out this
# directive:
#
AddDefaultCharset UTF-8

<IfModule mime_magic_module>
    #
    # The mod_mime_magic module allows the server to use various hints from the
    # contents of the file itself to determine its type.  The MIMEMagicFile
    # directive tells the module where the hint definitions are located.
    #
    MIMEMagicFile conf/magic
</IfModule>

#
# Customizable error responses come in three flavors:
# 1) plain text 2) local redirects 3) external redirects
#
# Some examples:
#ErrorDocument 500 "The server made a boo boo."
#ErrorDocument 404 /missing.html
#ErrorDocument 404 "/cgi-bin/missing_handler.pl"
#ErrorDocument 402 http://www.example.com/subscription_info.html
#

#
# EnableMMAP and EnableSendfile: On systems that support it,
# memory-mapping or the sendfile syscall may be used to deliver
# files.  This usually improves server performance, but must
# be turned off when serving from networked-mounted
# filesystems or if support for these functions is otherwise
# broken on your system.
# Defaults if commented: EnableMMAP On, EnableSendfile Off
#
#EnableMMAP off
EnableSendfile on

# Supplemental configuration
#
# Load config files in the "/etc/httpd/conf.d" directory, if any.

IncludeOptional conf.d/*.conf

IncludeOptional sites-enabled/default.conf
IncludeOptional sites-enabled/*.conf

AddHandler h264-streaming.extensions .mp4

Offline
****
Re: Apache not loading (correct config it seems) after reboot(s)
« Reply #7 on: February 21, 2018, 07:18:31 PM »
what version of os and cwp are you running?

did you install/compile the httpd yourselves? Because CWP is installing its own version - cwp-httpd

Offline
*
Re: Apache not loading (correct config it seems) after reboot(s)
« Reply #8 on: February 21, 2018, 07:32:59 PM »
I am running:

- CentOS Linux release 7.4.1708 (Core)
- Apache/2.4.29
- CWP: 0.9.8.506

Nope, I am not installing/compiling httpd myself. I have been playing around with the Apache Re-Build option for a while. But since that also eventually did not solve my problem in any way, I have reverted back to my original configuration (backup restored from before the 'Re-Build' tryout).

The thing is, that CWP7.admin is giving me a different httpd.conf (/usr/local/apache/conf/httpd.conf) than the one that is loaded through default httpd. But as far as I know (and can filter from your post) that is as expected.

Offline
****
Re: Apache not loading (correct config it seems) after reboot(s)
« Reply #9 on: February 21, 2018, 07:35:44 PM »
run from the cli
Code: [Select]
yum list installed | grep httpd and post the output

Offline
*
Re: Apache not loading (correct config it seems) after reboot(s)
« Reply #10 on: February 21, 2018, 07:39:23 PM »
Code: [Select]
cwp-httpd.x86_64                       2.4.29-2                        @cwp
httpd.x86_64                           2.4.6-67.el7.centos.6           @updates
httpd-tools.x86_64                     2.4.6-67.el7.centos.6           @updates

Offline
****
Re: Apache not loading (correct config it seems) after reboot(s)
« Reply #11 on: February 21, 2018, 07:44:10 PM »
perhaps the stock httpd slipped in as dependency of another package since yum does not recognise the cwp-httpd installed by CWP (http://forum.centos-webpanel.com/centos-webpanel-bugs/cwp-httpd-not-recognized-by-yum-as-webserver/)

see if removing the stock httpd (2.4.6-67) sorts this issue.
Code: [Select]
yum -y remove httpd httpd-tools
systemctl restart cwp-httpd

Offline
*
Re: Apache not loading (correct config it seems) after reboot(s)
« Reply #12 on: February 21, 2018, 07:52:43 PM »
I removed the package, but restart of cwp-httpd did not work. But I rebooted the complete server. The apache service did not work (since httpd was not found). So I reinstalled httpd and now I get the default Apache "Testing 123" website on all my domains. Https is still not working, but at least I am seeing something.

I'll try to see if I can fix the configuration from here on (although tips and tricks are always welcome). Thanks so far.

Offline
*
Re: Apache not loading (correct config it seems) after reboot(s)
« Reply #13 on: February 21, 2018, 08:37:40 PM »
Webserver is running again. Complete uninstall of httpd and after that started from scratch with complete reconfiguration of httpd with modules etc. It seems to be working now.

Thank you very much for your help!