Author Topic: AutoSSL, DNS of your domain doesn't point to this server  (Read 365 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
AutoSSL, DNS of your domain doesn't point to this server
« on: September 13, 2018, 04:44:51 PM »
Getting the fabled error:

"DNS of your domain doesn't point to this server or you have htaccess restrictions"

I've skimmed the support forums and see that I'm not the only one, I've tried the solutions that have been posted to no avail. Any help would be greatly appreciated.

Some info: I've check to make sure my DNS servers are in fact pointed to the server IP through whatsmydns, I've also tried renaming and completely removing the .htaccess file.

Offline
*
Re: AutoSSL, DNS of your domain doesn't point to this server
« Reply #1 on: September 13, 2018, 07:19:30 PM »
Didn't see a way to edit my post above, but I tried doing the certbot installation through shell access as well just to see what kind of results that would give. It's giving me the error:

"Unable to find a virtual host listening on port 80 which is currently needed for Certbot to prove to the CA that you control your domain. Please add a virtual host for port 80."

What's weird is my vhost appears to be just fine. See below:

Code: [Select]
# vhost_start media.net
<VirtualHost 144.202.75.100:80>
ServerName media.net
ServerAlias www.media.net
ServerAdmin webmaster@mediar.net
DocumentRoot /home/media/public_html
UseCanonicalName Off
ScriptAlias /cgi-bin/ /home/media/public_html/cgi-bin/

# Custom settings are loaded below this line (if any exist)
# Include "/usr/local/apache/conf/userdata/media/media.net/*.conf"

<IfModule mod_userdir.c>
UserDir disabled
UserDir enabled media
</IfModule>

<IfModule mod_suexec.c>
SuexecUserGroup media media
</IfModule>

<IfModule mod_suphp.c>
suPHP_UserGroup media media
suPHP_ConfigPath /home/media
</IfModule>

<Directory "/home/media/public_html">
AllowOverride All
</Directory>

</VirtualHost>
# vhost_end media.net

And here is my DNS zone file as well just in case I didn't do it right:

Code: [Select]
; Generated by CWP
; Zone file for media.net
$TTL 14400
media.net.      86400      IN      SOA      ns1.media.net.      smt.gmail.com.      (
      2018091316 ;serial, todays date+todays
      86400 ;refresh, seconds
      7200 ;retry, seconds
      3600000 ;expire, seconds
      86400 ;minimum, seconds
      )


media.net.      86400      IN      NS      ns1.medianet.
media.net.      86400      IN      NS      ns2.media.net.
media.net.      0      IN      A      144.202.75.100
localhost.media.net.      0      IN      A      127.0.0.1
media.net.      0      IN      MX      5      media.net.
mail      0      IN      CNAME      media.net.
www      0      IN      CNAME      media.net.
ftp      0      IN      CNAME      media.net.
;      Add      additional           
_dmarc      14400      IN      TXT      "v=DMARC1; p=none"
ns1      14400      IN      A      144.202.75.100
ns2      14400      IN      A      144.202.70.100

« Last Edit: September 14, 2018, 12:25:13 PM by Administrator »

Offline
*
Re: AutoSSL, DNS of your domain doesn't point to this server
« Reply #2 on: September 13, 2018, 08:17:26 PM »
Please do the following and then let me know how it went

- Update CWP to its latest version
- Restart Webservers
- You try again to generate the ssl

Offline
*
Re: AutoSSL, DNS of your domain doesn't point to this server
« Reply #3 on: September 14, 2018, 01:03:23 AM »
Please do the following and then let me know how it went

- Update CWP to its latest version
- Restart Webservers
- You try again to generate the ssl

I'm not sure why this worked, but it worked. Thanks! I'm unable to edit my posts above, if you or a mod could remove my server information (coded texts) that would be great.

Offline
*
Re: AutoSSL, DNS of your domain doesn't point to this server
« Reply #4 on: October 16, 2018, 03:00:34 AM »
I followed these steps and it did not resolve my problem, I am still getting the "DNS does not point to your server" error.
Can this be done via CLI ?
How is it checking the DNS ? I do not see this error in the apache logs.