Author Topic: BIND DNS Server - Failed  (Read 183 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
BIND DNS Server - Failed
« on: November 09, 2019, 09:53:16 PM »
Hello All,

New install of Centos 7 with CWP.

After install and config it cannot start the BIND DNS Server. Here's the error when I try to start it:

Code: [Select]
Failed to start named.service: Unit not found.
Here is the last part of the journalcrl:
Quote
-- Subject: A new session 9 has been created for user root
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- Documentation: http://www.freedesktop.org/wiki/Software/systemd/multiseat
--
-- A new session with the ID 9 has been created for the user root.
--
-- The leading process of the session is 32645.
Nov 09 16:55:18 Script-UAT sshd[32645]: pam_unix(sshd:session): session closed for user root
Nov 09 16:55:18 Script-UAT systemd-logind[368]: Removed session 9.
-- Subject: Session 9 has been terminated
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- Documentation: http://www.freedesktop.org/wiki/Software/systemd/multiseat
--
-- A session with the ID 9 has been terminated.

Here is the tail log file:

Quote
Nov  9 16:49:47 Script-UAT systemd-logind: New session 9 of user root.
Nov  9 16:55:18 Script-UAT systemd-logind: Removed session 9.

I try to edit the Nameservers IP and names to the Google DNS servers and get the following:

Code: [Select]
Nameservers updated.
Code: [Select]
Saving Nameserver Zones
But also warnings:

Code: [Select]
Warning: file_put_contents(/var/named/ns1.google.com.db): failed to open stream: No such file or directory in /usr/local/cwpsrv/htdocs/resources/admin/modules/nameservers.php on line 0
Code: [Select]
Warning: file_put_contents(/var/named/ns2.google.com.db): failed to open stream: No such file or directory in /usr/local/cwpsrv/htdocs/resources/admin/modules/nameservers.php on line 0
There is no /var/named directory in the system so I'm wondering if there's an issue with CWP...

Any ideas?

Doug

Offline
*
Re: BIND DNS Server - Failed
« Reply #1 on: November 12, 2019, 04:20:04 AM »
On the terminal, if you type the command
Code: [Select]
which named what do results do you get?