Author Topic: can't seem to get quota to work  (Read 509 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
can't seem to get quota to work
« on: April 28, 2017, 10:30:43 AM »
i go to disk quota menu and it says this:
You should setup quota for the / partition.
/dev/mapper/centos-root / xfs defaults,usrquota,grpquota 1 2

i press "save changes" it says "Data Updated!" i don't get any errors.

my fstab info says this
/dev/mapper/centos-root /                       xfs    defaults,usrquota,grpquota   1 2
UUID=c2551cc7-2837-4cff-96d9-e43bfe9549d7 /boot                   xfs     defaults        0 0
/dev/mapper/centos-tmp  /tmp                    xfs     defaults        0 0
/dev/mapper/centos-swap swap                    swap    defaults        0 0

when i go to set quota from the packages screen, i get this error
setquota: Only XFS quota format is allowed on XFS filesystem. setquota: Not all specified mountpoints are using quota.

I have tried to do this myself by using google
command: xfs_quota –x -c 'limit bsoft=978000m  bhard=980000m usernamehere' /

i get this error:
xfs_quota: cannot setup path for mount –x: No such file or directory
command "limit" not found

After a 4hr fight i have given up. My CWP version is: CWPpro version: 0.9.8.314

Offline
*
Re: can't seem to get quota to work
« Reply #1 on: May 06, 2017, 02:41:27 PM »
hi,

Though i see that quota is enabled, coz when i goto User Accounts > User Quota, i see the following:

---
*** Report for user quotas on device /dev/mapper/centos-root
Block grace time: 7days; Inode grace time: 7days
---

I have not pasted full thing. So it seems that quotas are enabled but, when I try to enable quota in packages I get this:

---
setquota: Only XFS quota format is allowed on XFS filesystem. setquota: Not all specified mountpoints are using quota.
×SUCCESS! Data Updated !
---

And the "Update Quota: (Update quota for all users using this package, also disables inode limits !)" gets unchecked.

What is the issue here ???? How to fix this ??

Thanks.