Author Topic: Filemanager Cannot upload large files to server  (Read 555 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
Filemanager Cannot upload large files to server
« on: August 02, 2019, 12:39:48 AM »
Hi,
I have just updated today 2 August 2019. I cannot say if it this latest update that has caused the following problem or not.
It is not possible to upload large files to the server using the Filemanager. I have tried logged in as Admin with root access. It is not possible to upload files (around 80MB), using the drag and drop interface of directory selection. Does not work using the Basic File manager either. (Wanting to upload cPanel migration files).

It is also not possible to upload files when logged in as an CWP user.

I have tried with small files (approx 30kB) and this works. The problem seems to be with larger files.

Offline
*
Re: Filemanager Cannot upload large files to server
« Reply #1 on: August 02, 2019, 03:11:08 AM »
Increase your php limits.

Offline
*
Re: Filemanager Cannot upload large files to server
« Reply #2 on: August 02, 2019, 12:48:19 PM »
I have increased max_post_size and upload_max_filesize both to 512M

I have checked that this is reflected in PHP Settings >> PHP Info and it is, but still the upload fails for big files (e.g. 70MB).

It would be logical that that the FileManager might have a different php.ini file with large file sizes by default, so that it is not restrained by normal file size limits that might apply elsewhere. I think this might be what is happening and so adjusting the normal php.ini is not resolving the issue. I just don't know where this alternative php.ini file is.

Offline
*
Re: Filemanager Cannot upload large files to server
« Reply #3 on: August 28, 2019, 12:22:49 PM »
Did you find any solution for this?
I am also facing the same issue.

Offline
*
Re: Filemanager Cannot upload large files to server
« Reply #4 on: August 30, 2019, 11:20:35 AM »
edit
/usr/local/cwp/php71/php.ini

post_max_size = 512M
upload_max_filesize = 512M
memory_limit = 256M


edit
/usr/local/cwpsrv/conf/cwpsrv.conf

client_max_body_size 512M



service cwp-phpfpm restart

service cwpsrv restart