Author Topic: Has anyone used CWP in real production server?  (Read 122 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
Has anyone used CWP in real production server?
« on: January 11, 2019, 07:31:46 PM »
As a long time centos users, I was happy to know there we a webpanel dedicated to centos, when someone recently asked me to make a full fledged site including email and I searched and was happy to find CWP.

So, I got a new VPS from digital ocean, with centos 7 distro and followed the instructions. Even though I can log in in the dashboard, it seems to me that is the only thing you are able to do in CWP.

If tried to add a domain, it askes me to install PHP-FPM, which I chose form the list, I choose nearly all PHP 7 versions, and waited for it to rebuildfinish, but I always get the same page, when I want to add a domain. I just installed PHP 7, rebooted server and still it Always asks me to install PHP-FPM. If I got to "File Manager" table and choose "Simple File manger" there it is again, asking me to install php-fpm which I already did. It doesn't matter how many times I install PHP-FPM, or waited or rebooted. I even erased my VPS and started from scratch and it is the same message, there are also errors in red panel which never go away even if I follow the instruction.

There is absolutely nothing to do except get the same question, and the software has lots of errors, which makes me think there are no error or exception handlers in CWP. One of the errors I get is this:

Code: [Select]
Notice: Undefined variable: [obfuscated] in /usr/local/cwpsrv/htdocs/resources/admin/include/functions.php on line 0
Also:
Code: [Select]
Notice: Undefined index: backup in /usr/local/cwpsrv/htdocs/resources/admin/modules/new_account.php on line 0
I really hate to complain on something given to me for free, but even I as a long time contributor to OS projects on github with  a couple of mine, I always make sure the software works before releasing it to the public.


I am a bit confused, is CWP tagged v1? or is this a pre-release? Is anyone using this on anything other than localhost?


« Last Edit: January 11, 2019, 07:40:49 PM by kylix »

Offline
*
Re: Has anyone used CWP in real production server?
« Reply #1 on: January 11, 2019, 07:38:32 PM »
Just to add something, since I won't be visiting this thread again, I have decided to choose another panel. So, don't ask me and wait for an answer, I can't read your message.

If someone figures out the answer though, you can post it to help the next person.

But please improve your software, this is worse than wordpress or phpmyadmin

Also, sorry for ranting, I just wasted TWO days so I can't help it