Author Topic: Users - Shell Access enable/disable  (Read 4171 times)

0 Members and 1 Guest are viewing this topic.

Users - Shell Access enable/disable
« on: January 30, 2015, 10:18:59 PM »
Hey everyone, I am having issues with SSH working for a user I created when logging in it tells me the following:

root@cyrus:~# ssh cfc@
cfc@'s password:
Write failed: Broken pipe

It works perfectly for root login, so I began troubleshooting. When I had set up the new user in the panel initially I had un-checked shell access box which is default. However when I do check it, the settings don't take effect. And I still get the above error. I also created an additional new account this time; and checked the shell access box, and the user shell account login does work successfully. But if I try to un-check shell access on that account and save, the settings don't change.

Anyway I have a user account that I would really hate to delete and redo just to get shell access. Does anyone know how I can manually enable shell access for this user since the panel is not allowing me? I also want to note I did check some files in /etc/passwd, and the problem user account configuration lines does have /bin/bash already enabled..

CWP version: 0.9.7

Thanks so much for your time, I surely do appreciate this panel so much that I am going to donate to your cause :)
« Last Edit: January 30, 2015, 10:30:53 PM by drkilra »

Re: Users - Shell Access enable/disable
« Reply #1 on: February 04, 2015, 01:33:37 AM »
hmmm strange if you already have enabled /bin/bash.

Try using su from the root to test the user, example:

su USERNAME -s /bin/bash
AntiDDoS Protection (web + mail)

Join our Development Team and get paid !

Services Monitoring & RBL Monitoring

Do you need Fast and FREE Support included for your CWP linux server?
Installation Instructions
Get Fast Support Here