Author Topic: Almost all pages lead to "High Performace WebServers Configuration"  (Read 454 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
I recently installed a fresh copy of CWP to a centos 7 CT running on proxmox.

The install went without any hiccups and it seemingly works fine. However, when I logged on the admin panel, I noticed that more than half the pages show the "High Performace WebServers Configuration" page instead of what they are supposed to.

Screenshot: https://imgur.com/5xNOw06

As you can see I've clicked on the Firewall Manager, and the url also shows this, yet I am greeted with the "High Performace WebServers Configuration" page..

I've not attempted a reinstall yet, that would be next on my list. But as this server is a completely fresh one it beats me as to why this is happening.

Any ideas?

Offline
*
Re: Almost all pages lead to "High Performace WebServers Configuration"
« Reply #1 on: March 14, 2019, 11:16:25 PM »
I am having this problem too on CWP Pro.

The GUI is stuck on this page. I can't go anywhere!!!


TheUnknownNO, I see that you had this problem over a month ago. if you fixed it please tell me how.



http://cloud.utirex.com:8080/index.php/s/55MKn53zPEFHYjj


Thanks

Offline
*
Re: Almost all pages lead to "High Performace WebServers Configuration"
« Reply #2 on: March 15, 2019, 10:05:54 AM »
simply you need to rebuild webservers like you have the info there on the image you have sent
VPS & Dedicated server provider with included FREE Managed support for CWP.
http://www.studio4host.com/

*** Don't allow that your server or website is down, choose hosting provider with included expert managed support for your CWP.

Offline
*
Re: Almost all pages lead to "High Performace WebServers Configuration"
« Reply #3 on: March 23, 2019, 07:14:59 PM »
I did.

and it took me to PHP-FPM Selector. I wanted to change the PHP-FPM 7.3 to 7.3.3 and then I hit green play music button but never becomes 7.3.3.

Anyway, I hit the start building or start compiling button at the bottom, which I cannot see it anymore because in place of the button now I have this message
"Task already running in the background, please wait a few minutes and then check again!!!" for the last 3 weeks.

Please help.

Screenshot:
http://cloud.utirex.com:8080/index.php/s/aZ38RZeSgPetgXz

« Last Edit: March 23, 2019, 08:08:29 PM by mambo jambo »

Offline
***
Re: Almost all pages lead to "High Performace WebServers Configuration"
« Reply #4 on: March 23, 2019, 09:23:16 PM »
Surely, the  building process does not take three weeks.
Check the last lines of your logfiles, with the following command:
Code: [Select]
# tail -50 /var/log/php-selector-rebuild.log

Regards,
Netino

Offline
*
Re: Almost all pages lead to "High Performace WebServers Configuration"
« Reply #5 on: March 23, 2019, 09:57:31 PM »
I don't see anything wrong here except that error about the notification.

Code: [Select]
[root@vps log]# tail -50 php-selector-rebuild.log
/bin/sh /usr/local/src/apcu-5.1.12/libtool --mode=compile cc -D_GNU_SOURCE -DZEND_ENABLE_STATIC_TSRMLS_CACHE=1 -I. -I/usr/local/src/apcu-5.1.12 -DPHP_ATOM_INC -I/usr/local/src/apcu-5.1.12/include -I/usr/local/src/apcu-5.1.12/main -I/usr/local/src/apcu-5.1.12 -I/opt/alt/php-fpm73/usr/include/php -I/opt/alt/php-fpm73/usr/include/php/main -I/opt/alt/php-fpm73/usr/include/php/TSRM -I/opt/alt/php-fpm73/usr/include/php/Zend -I/opt/alt/php-fpm73/usr/include/php/ext -I/opt/alt/php-fpm73/usr/include/php/ext/date/lib  -DHAVE_CONFIG_H  -g -O2   -c /usr/local/src/apcu-5.1.12/apc_signal.c -o apc_signal.lo
 cc -D_GNU_SOURCE -DZEND_ENABLE_STATIC_TSRMLS_CACHE=1 -I. -I/usr/local/src/apcu-5.1.12 -DPHP_ATOM_INC -I/usr/local/src/apcu-5.1.12/include -I/usr/local/src/apcu-5.1.12/main -I/usr/local/src/apcu-5.1.12 -I/opt/alt/php-fpm73/usr/include/php -I/opt/alt/php-fpm73/usr/include/php/main -I/opt/alt/php-fpm73/usr/include/php/TSRM -I/opt/alt/php-fpm73/usr/include/php/Zend -I/opt/alt/php-fpm73/usr/include/php/ext -I/opt/alt/php-fpm73/usr/include/php/ext/date/lib -DHAVE_CONFIG_H -g -O2 -c /usr/local/src/apcu-5.1.12/apc_signal.c  -fPIC -DPIC -o .libs/apc_signal.o
/bin/sh /usr/local/src/apcu-5.1.12/libtool --mode=compile cc -D_GNU_SOURCE -DZEND_ENABLE_STATIC_TSRMLS_CACHE=1 -I. -I/usr/local/src/apcu-5.1.12 -DPHP_ATOM_INC -I/usr/local/src/apcu-5.1.12/include -I/usr/local/src/apcu-5.1.12/main -I/usr/local/src/apcu-5.1.12 -I/opt/alt/php-fpm73/usr/include/php -I/opt/alt/php-fpm73/usr/include/php/main -I/opt/alt/php-fpm73/usr/include/php/TSRM -I/opt/alt/php-fpm73/usr/include/php/Zend -I/opt/alt/php-fpm73/usr/include/php/ext -I/opt/alt/php-fpm73/usr/include/php/ext/date/lib  -DHAVE_CONFIG_H  -g -O2   -c /usr/local/src/apcu-5.1.12/apc_pool.c -o apc_pool.lo
 cc -D_GNU_SOURCE -DZEND_ENABLE_STATIC_TSRMLS_CACHE=1 -I. -I/usr/local/src/apcu-5.1.12 -DPHP_ATOM_INC -I/usr/local/src/apcu-5.1.12/include -I/usr/local/src/apcu-5.1.12/main -I/usr/local/src/apcu-5.1.12 -I/opt/alt/php-fpm73/usr/include/php -I/opt/alt/php-fpm73/usr/include/php/main -I/opt/alt/php-fpm73/usr/include/php/TSRM -I/opt/alt/php-fpm73/usr/include/php/Zend -I/opt/alt/php-fpm73/usr/include/php/ext -I/opt/alt/php-fpm73/usr/include/php/ext/date/lib -DHAVE_CONFIG_H -g -O2 -c /usr/local/src/apcu-5.1.12/apc_pool.c  -fPIC -DPIC -o .libs/apc_pool.o
/bin/sh /usr/local/src/apcu-5.1.12/libtool --mode=compile cc -D_GNU_SOURCE -DZEND_ENABLE_STATIC_TSRMLS_CACHE=1 -I. -I/usr/local/src/apcu-5.1.12 -DPHP_ATOM_INC -I/usr/local/src/apcu-5.1.12/include -I/usr/local/src/apcu-5.1.12/main -I/usr/local/src/apcu-5.1.12 -I/opt/alt/php-fpm73/usr/include/php -I/opt/alt/php-fpm73/usr/include/php/main -I/opt/alt/php-fpm73/usr/include/php/TSRM -I/opt/alt/php-fpm73/usr/include/php/Zend -I/opt/alt/php-fpm73/usr/include/php/ext -I/opt/alt/php-fpm73/usr/include/php/ext/date/lib  -DHAVE_CONFIG_H  -g -O2   -c /usr/local/src/apcu-5.1.12/apc_iterator.c -o apc_iterator.lo
 cc -D_GNU_SOURCE -DZEND_ENABLE_STATIC_TSRMLS_CACHE=1 -I. -I/usr/local/src/apcu-5.1.12 -DPHP_ATOM_INC -I/usr/local/src/apcu-5.1.12/include -I/usr/local/src/apcu-5.1.12/main -I/usr/local/src/apcu-5.1.12 -I/opt/alt/php-fpm73/usr/include/php -I/opt/alt/php-fpm73/usr/include/php/main -I/opt/alt/php-fpm73/usr/include/php/TSRM -I/opt/alt/php-fpm73/usr/include/php/Zend -I/opt/alt/php-fpm73/usr/include/php/ext -I/opt/alt/php-fpm73/usr/include/php/ext/date/lib -DHAVE_CONFIG_H -g -O2 -c /usr/local/src/apcu-5.1.12/apc_iterator.c  -fPIC -DPIC -o .libs/apc_iterator.o
/bin/sh /usr/local/src/apcu-5.1.12/libtool --mode=link cc -DPHP_ATOM_INC -I/usr/local/src/apcu-5.1.12/include -I/usr/local/src/apcu-5.1.12/main -I/usr/local/src/apcu-5.1.12 -I/opt/alt/php-fpm73/usr/include/php -I/opt/alt/php-fpm73/usr/include/php/main -I/opt/alt/php-fpm73/usr/include/php/TSRM -I/opt/alt/php-fpm73/usr/include/php/Zend -I/opt/alt/php-fpm73/usr/include/php/ext -I/opt/alt/php-fpm73/usr/include/php/ext/date/lib  -DHAVE_CONFIG_H  -g -O2   -o apcu.la -export-dynamic -avoid-version -prefer-pic -module -rpath /usr/local/src/apcu-5.1.12/modules  apc.lo apc_lock.lo php_apc.lo apc_cache.lo apc_mmap.lo apc_shm.lo apc_sma.lo apc_stack.lo apc_signal.lo apc_pool.lo apc_iterator.lo -lrt
cc -shared  .libs/apc.o .libs/apc_lock.o .libs/php_apc.o .libs/apc_cache.o .libs/apc_mmap.o .libs/apc_shm.o .libs/apc_sma.o .libs/apc_stack.o .libs/apc_signal.o .libs/apc_pool.o .libs/apc_iterator.o  -lrt  -Wl,-soname -Wl,apcu.so -o .libs/apcu.so
.libs/apc_mmap.o: In function `apc_mmap':
/usr/local/src/apcu-5.1.12/apc_mmap.c:95: warning: the use of `mktemp' is dangerous, better use `mkstemp'
creating apcu.la
(cd .libs && rm -f apcu.la && ln -s ../apcu.la apcu.la)
/bin/sh /usr/local/src/apcu-5.1.12/libtool --mode=install cp ./apcu.la /usr/local/src/apcu-5.1.12/modules
cp ./.libs/apcu.so /usr/local/src/apcu-5.1.12/modules/apcu.so
cp ./.libs/apcu.lai /usr/local/src/apcu-5.1.12/modules/apcu.la
PATH="$PATH:/sbin" ldconfig -n /usr/local/src/apcu-5.1.12/modules
----------------------------------------------------------------------
Libraries have been installed in:
   /usr/local/src/apcu-5.1.12/modules

If you ever happen to want to link against installed libraries
in a given directory, LIBDIR, you must either use libtool, and
specify the full pathname of the library, or use the `-LLIBDIR'
flag during linking and do at least one of the following:
   - add LIBDIR to the `LD_LIBRARY_PATH' environment variable
     during execution
   - add LIBDIR to the `LD_RUN_PATH' environment variable
     during linking
   - use the `-Wl,--rpath -Wl,LIBDIR' linker flag
   - have your system administrator add LIBDIR to `/etc/ld.so.conf'

See any operating system documentation about shared libraries for
more information, such as the ld(1) and ld.so(8) manual pages.
----------------------------------------------------------------------

Build complete.
Don't forget to run 'make test'.

Installing shared extensions:     /opt/alt/php-fpm73/usr/lib/php/extensions/no-debug-non-zts-20180731/
Installing header files:          /opt/alt/php-fpm73/usr/include/php/

Creating config file
exe:/opt/alt/php-fpm73/usr/sbin/php-fpm
Redirecting to /bin/systemctl restart httpd.service

Build Completed
###################


Error:Can't add notification!
[root@vps log]#


Offline
***
Re: Almost all pages lead to "High Performace WebServers Configuration"
« Reply #6 on: March 23, 2019, 10:05:39 PM »
I think the build process is ended.
I have the exact same logs, ending with the same messages, and my server is already working in the new version.

Offline
*
Re: Almost all pages lead to "High Performace WebServers Configuration"
« Reply #7 on: March 23, 2019, 10:19:37 PM »
OK,

but how can I get rid of this page

http://cloud.utirex.com:8080/index.php/s/55MKn53zPEFHYjj

It's coming up everywhere. It basically makes CWP useless.


Offline
*
Re: Almost all pages lead to "High Performace WebServers Configuration"
« Reply #8 on: March 24, 2019, 01:42:14 AM »
Netino,
you are right. I see php-fpm56, 70 and 73 are running and that's exactly what I want.

Code: [Select]
  php-fpm56.service                                        loaded active running   The PHP FastCGI Process Manager
  php-fpm70.service                                        loaded active running   The PHP FastCGI Process Manager
  php-fpm73.service                                        loaded active running   The PHP FastCGI Process Manager

I just need to get rid of "High Performace WebServers Configuration" page popping up everywhere.

Offline
***
Re: Almost all pages lead to "High Performace WebServers Configuration"
« Reply #9 on: March 25, 2019, 02:29:42 AM »
For some reason, the system is not considering that you have upgraded. You may have to rebuild (re-install) the Apache server again through the "Install" button. Again.:(

Offline
*
I just fixed the problem.

as web server I had selected "nginx + varnish + apache". This time I selected "apache only" and it worked.

Thanks