Author Topic: Can Not Log in Client Side  (Read 2902 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
Can Not Log in Client Side
« on: January 17, 2018, 02:46:58 AM »
Hello,

I am unable to log in as client,
  • Client panel is opened
  • When I enter a username and password don't go anywhere, it is stuck here.

Centos 7.

Anybody could help?

Thanks,

Asrofi
Indonesia

Offline
*
Re: Can Not Log in Client Side
« Reply #1 on: January 19, 2018, 09:38:55 AM »
I have the same issue but it login but very very slow, in 2-5 minutes

CWP version: 0.9.8.424
CentOS Linux release 7.4.1708 - updated

On /usr/local/cwpsrv/logs/error_log the i have these errors:

Code: [Select]
2018/01/19 11:32:37 [error] 13971#0: *3187 FastCGI sent in stderr: "PHP message: PHP Warning:  session_start(): open(/tmp/session/sess_kc9ngs9hm36ug13fa80hp54697, O_RDWR) failed: Permission denied (13) in /usr/local/cwpsrv/var/services/users/login/index.php on line 0" while reading response header from upstream, client: 172.16.1.126, server: localhost, request: "POST /login/index.php?acc=validate HTTP/1.1", upstream: "fastcgi://unix:/usr/local/cwp/php71/var/sockets/login.sock:", host: "s2.user.biz:2082", referrer: "http://s2.user.biz:2082/login/index.php?login=userlogin"
2018/01/19 11:32:37 [error] 13971#0: *3187 FastCGI sent in stderr: "PHP message: PHP Warning:  Unknown: open(/tmp/session/sess_kc9ngs9hm36ug13fa80hp54697, O_RDWR) failed: Permission denied (13) in Unknown on line 0
PHP message: PHP Warning:  Unknown: Failed to write session data (files). Please verify that the current setting of session.save_path is correct (/tmp/session) in Unknown on line 0" while reading upstream, client: 172.16.1.126, server: localhost, request: "POST /login/index.php?acc=validate HTTP/1.1", upstream: "fastcgi://unix:/usr/local/cwp/php71/var/sockets/login.sock:", host: "s2.user.biz:2082", referrer: "http://s2.user.biz:2082/login/index.php?login=userlogin"


I tried to force into /usr/local/cwpsrv/conf.d/users.conf the session, but still i got the issue
Code: [Select]
fastcgi_param   PHP_ADMIN_VALUE "session.save_path = /tmp/session";


On the php-fpm-slowlog-cwpsrv.log i have these:

Code: [Select]
[19-Jan-2018 11:32:47]  [pool cwpsrv] pid 32150
script_filename = /usr/local/cwpsrv/var/services/user_api/v1/index.php
[0x00007f13166163d0] shell_exec() /usr/local/cwpsrv/var/services/user_api/v1/app/routes/api.php:0
[0x00007f13166142b0] {closure}() /usr/local/cwpsrv/var/services/user_api/v1/Slim/Route.php:0
[0x00007f1316614230] call_user_func_array() /usr/local/cwpsrv/var/services/user_api/v1/Slim/Route.php:0
[0x00007f1316614070] dispatch() /usr/local/cwpsrv/var/services/user_api/v1/Slim/Slim.php:0
[0x00007f1316613ca0] call() /usr/local/cwpsrv/var/services/user_api/v1/Slim/Middleware/Flash.php:0
[0x00007f1316613b40] call() /usr/local/cwpsrv/var/services/user_api/v1/Slim/Middleware/MethodOverride.php:0
[0x00007f13166138a0] call() /usr/local/cwpsrv/var/services/user_api/v1/Slim/Middleware/PrettyExceptions.php:0
[0x00007f1316613620] call() /usr/local/cwpsrv/var/services/user_api/v1/Slim/Slim.php:0
[0x00007f1316613170] run() /usr/local/cwpsrv/var/services/user_api/v1/index.php:0


Offline
****
Re: Can Not Log in Client Side
« Reply #2 on: January 19, 2018, 06:32:41 PM »
Do your tmp folder have space?

Offline
*
Re: Can Not Log in Client Side
« Reply #3 on: January 26, 2018, 03:00:01 PM »
ofc i have space :|

Offline
*
Re: Can Not Log in Client Side
« Reply #4 on: March 03, 2018, 12:26:32 AM »
I have the same problem  :'(

Offline
*
Re: Can Not Log in Client Side
« Reply #5 on: March 03, 2018, 03:09:59 AM »
you could indicate that this script answers  sh /scripts/check_api

Offline
*
Re: Can Not Log in Client Side
« Reply #6 on: March 07, 2018, 01:14:20 PM »
Same here CWP6, when trying to log in to user's panel (2083 port) get the login page again.
relevant error_log (domain.com is fake, not the real one used):
Code: [Select]
2018/03/07 14:39:02 [info] 1817#0: *518 client closed connection while waiting for request, client: 127.0.0.1, server: 127.0.0.1:2302
2018/03/07 14:39:02 [info] 1816#0: *520 client closed connection while waiting for request, client: 127.0.0.1, server: 127.0.0.1:2302
2018/03/07 14:39:02 [info] 1817#0: *521 client closed connection while waiting for request, client: 127.0.0.1, server: 127.0.0.1:2302
2018/03/07 14:39:02 [error] 1816#0: *516 FastCGI sent in stderr: "PHP message: PHP Warning:  session_start(): open(/tmp/session/sess_8eincqamai531tm09jtle6jo11, O_RDWR) failed: Permission denied (13) in /usr/local/cwpsrv/var/services/users/index.php on line 0
PHP message: PHP Notice:  Undefined index: username in /usr/local/cwpsrv/var/services/users/index.php on line 0
PHP message: PHP Notice:  Undefined index: username in /usr/local/cwpsrv/var/services/users/index.php on line 0
PHP message: PHP Notice:  Undefined offset:1 in /usr/local/cwpsrv/var/services/users/index.php on line 0
PHP message: PHP Warning:  strpos(): Empty needle in /usr/local/cwpsrv/var/services/users/index.php on line 0
PHP message: PHP Notice:  Undefined offset:1 in /usr/local/cwpsrv/var/services/users/index.php on line 0
PHP message: PHP Warning:  Unknown: open(/tmp/session/sess_8eincqamai531tm09jtle6jo11, O_RDWR) failed: Permission denied (13) in Unknown on line 0
PHP message: PHP Warning:  Unknown: Failed to write session data (files). Please verify that the current setting of session.save_path is correct (/tmp/session) in Unknown on line 0" while reading response header from upstream, client: 5.248.17.23, server: localhost, request: "POST /av/index.php?acc=validate HTTP/1.1", upstream: "fastcgi://unix:/usr/local/cwp/php71/var/sockets/av.sock:", host: "lamp1.domain.com:2083", referrer: "https://lamp1.domain.com:2083/"
the session file and parent directory:
Code: [Select]
[root@lamp1 session]# ls -la
total 340
drwxr-xr-x  2 login login 163840 Mar  7 14:02 .
drwxrwxrwt. 9 root  root  176128 Mar  7 14:39 ..
-rw-------  1 login login      0 Mar  7 14:02 sess_8eincqamai531tm09jtle6jo11
what i tried:
deleting the session file, the new one was created with the same permissions.
ensured that /tmp is not full.

upd:
have also a CWP7 server,  checked it's error_log and it has the same permission errors about the session files but user login works fine there, so this is not the cause of login failure.
« Last Edit: March 07, 2018, 01:50:36 PM by skidnik »

Offline
*
Re: Can Not Log in Client Side
« Reply #7 on: March 07, 2018, 10:11:20 PM »
Try to update your version to the newest one,
Code: [Select]
sh /script/update_cwp

and tell me how it was

Offline
*
Re: Can Not Log in Client Side
« Reply #8 on: March 09, 2018, 09:32:13 AM »

Code: [Select]
sh /script/update_cwp
well, i tried, but it did nothing, as i expected.
my situation is the same as OP's: this issue appeared after i applied the update, which changed the user panel to 208{2,3} port and apparently introduced the new user panel written in php7, thus we now have cwpphp package.

Offline
*
Re: Can Not Log in Client Side
« Reply #9 on: March 12, 2018, 10:38:21 PM »
i tried many times same problem and solved..

need to first that, clean install again..

and do everything step by step before create user or domain on ur cwp..

update everything, install wget and reboot..
install cwp and configure,

what configure?
- root mail,
- name servers,
- one package create,
- change ssh port and restart,
- enable firewall,
- you can create user and domain for test..

and i hope it will work after all that..

when i try to install first time, cannot open user control panel (i think 3-4 times re-install) after that i can reach the control panel..

but dont forget the upgrade the roundcube.. because it's have bug too.. no have function inside of bootstrap.php and trying to call function. copy your roundcube folder and download latest version and copy there.. just copy old conf. files to new files inside and its working..

good luck ;)

Offline
*
Re: Can Not Log in Client Side
« Reply #10 on: June 13, 2018, 10:00:58 PM »
Hello everyone,

I have at least a dozen CentOS servers with both CWP6 and CWP7 among them. They all have sites that have been imported from cPanel.

I am also having trouble authenticating in the user dashboard on some of these servers and they all have updated CWP scripts.

After performing some tests and analyzing the error logs, I got that the user panel always returns to the login screen when the account username has more than eight characters.

And this problem occurs in both CWP6 and CWP7. Did anyone else notice this kind of behavior?

Regards,
Humberto