Author Topic: CWP.USER PHP.INI not stored on the right folder  (Read 109 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
CWP.USER PHP.INI not stored on the right folder
« on: January 08, 2019, 07:47:48 PM »
When I login to my domain using CWP User, I can edit my php.ini file (CWP settings -> Edit Php.ini) for my website, but this changes only apply to one folder of my website (/home/andresre/public_html), and doesn't apply to the sub-folders. 

After placing the php.ini in the main folder /home/andresre then changes will apply to all sub-folders on my website.

Shouldn't the php.ini file be stored on "/home/username" folder instead directly by CWP so changes apply to all website instead of having to copy php.ini to every sub-folder? 

Offline
*
Re: CWP.USER PHP.INI not stored on the right folder
« Reply #1 on: January 08, 2019, 08:47:48 PM »
There is a trailing slash error in the template. I have reported the bug and it's supposed to be fixed. Look in
/usr/local/apache/conf.d/vhosts.

Check the domain.conf and domain.ssl.conf file for:

Code: [Select]
<IfModule proxy_fcgi_module>
<FilesMatch \.php$>
SetHandler "proxy:unix:/opt/alt/php-fpm73/usr/var/sockets/gtmanage.sock|fcgi://localhost"
</FilesMatch>
</IfModule>

Make sure there is no trailing slash after localhost.

Offline
*
Re: CWP.USER PHP.INI not stored on the right folder
« Reply #2 on: January 08, 2019, 09:53:45 PM »
Hi,

I found the file but I have different settings,

Code: [Select]
<IfModule mod_suphp.c>
suPHP_UserGroup andresre andresre
suPHP_ConfigPath /home/andresre
</IfModule>

Offline
*
Re: CWP.USER PHP.INI not stored on the right folder
« Reply #3 on: January 09, 2019, 03:09:57 PM »
Hi,

I found the file but I have different settings,

Code: [Select]
<IfModule mod_suphp.c>
suPHP_UserGroup andresre andresre
suPHP_ConfigPath /home/andresre
</IfModule>

Ok I see ... try putting a trailing slash after:  suPHP_ConfigPath /home/andresre/