Author Topic: Login issues with CWP  (Read 931 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
Login issues with CWP
« on: November 08, 2019, 04:51:33 PM »
When logging in with admin credentials the screen flashes and returns to the login screen.
I didn't see any log errors.

https://www.youtube.com/watch?v=zWQs9MIlweo
« Last Edit: November 08, 2019, 04:53:51 PM by gplamondon »

Offline
**
Re: Login issues with CWP
« Reply #1 on: November 08, 2019, 05:03:07 PM »
When logging in with admin credentials the screen flashes and returns to the login screen.
I didn't see any log errors.

https://www.youtube.com/watch?v=zWQs9MIlweo

Every time I have this problem I check to see if there is any other tabs open and loged in.  Make sure you do not have
any other session. Log out from any other windows and this should not happen

Offline
*
Re: Login issues with CWP
« Reply #2 on: November 08, 2019, 06:38:49 PM »
Please check that the account has an associated package, tremble you can have more details of what is happening by reviewing the records

Offline
*
Re: Login issues with CWP
« Reply #3 on: November 08, 2019, 06:40:32 PM »
Please check that the account has an associated package, tremble you can have more details of what is happening by reviewing the records

How would I go about checking this?

Offline
*
Re: Login issues with CWP
« Reply #4 on: November 08, 2019, 06:48:38 PM »
Quote
Every time I have this problem I check to see if there is any other tabs open and loged in.  Make sure you do not have
any other session. Log out from any other windows and this should not happen

I don't have any browser instances opened anywhere else, I even rebooted the server.

Offline
***
Re: Login issues with CWP
« Reply #5 on: November 09, 2019, 01:58:17 AM »
Please check that the account has an associated package, tremble you can have more details of what is happening by reviewing the records


Kindly follow the jose solution and it will be resolved. I had the same issue and it was resolved by this way.

Offline
***
Re: Login issues with CWP
« Reply #6 on: November 11, 2019, 10:04:38 PM »
O.P. Also, If you cannot log into CWP user interface at all, then you would need to use SSH program such as Putty to log into the command shell backend of your server and check users from there.

for example...from command shell in Putty you could type

less /etc/passwd

or

awk -F: '{ print $1}' /etc/passwd (this shows just the usernames)

or

cut -d: -f1 /etc/passwd (also shows just usernames)

or

getent passwd

or

getent passwd | cut -d: -f1


If you want to just check for a particular user on your system...

getent passwd | grep username (where username is the user you are looking for...ie admin )

Once you have an account that can log in, then you may check packages for that user by...

CWP dashboard>User Accounts>Edit Account (little cog on RHS of user list)...

under "Account Edit", you can check/select "Package"

If there are none in this list, then you need to create them under dashboard>packages (there should at least be a default package in list)



« Last Edit: November 11, 2019, 10:10:46 PM by adamjedgar »

Offline
****
Re: Login issues with CWP
« Reply #7 on: November 11, 2019, 10:25:52 PM »
When logging in with admin credentials the screen flashes and returns to the login screen.
I didn't see any log errors.

https://www.youtube.com/watch?v=zWQs9MIlweo

Every time I have this problem I check to see if there is any other tabs open and loged in.  Make sure you do not have
any other session. Log out from any other windows and this should not happen

Agree!  been there done that.

Offline
*
Re: Login issues with CWP
« Reply #8 on: November 13, 2019, 01:50:12 PM »
Please check that the account has an associated package, tremble you can have more details of what is happening by reviewing the records

Can you please explain how I do this?  I cannot login to the web panel at all.


Offline
*
Re: Login issues with CWP
« Reply #9 on: November 13, 2019, 01:52:50 PM »
O.P. Also, If you cannot log into CWP user interface at all, then you would need to use SSH program such as Putty to log into the command shell backend of your server and check users from there.

for example...from command shell in Putty you could type

less /etc/passwd

or

awk -F: '{ print $1}' /etc/passwd (this shows just the usernames)

or

cut -d: -f1 /etc/passwd (also shows just usernames)

or

getent passwd

or

getent passwd | cut -d: -f1


If you want to just check for a particular user on your system...

getent passwd | grep username (where username is the user you are looking for...ie admin )

Once you have an account that can log in, then you may check packages for that user by...

CWP dashboard>User Accounts>Edit Account (little cog on RHS of user list)...

under "Account Edit", you can check/select "Package"

If there are none in this list, then you need to create them under dashboard>packages (there should at least be a default package in list)

Thanks for the reply.  I dont think there is an issue with my password being incorrect.  if I try to login to the web panel with my credentials it just returnes to the login screen,  if I login with my credentials but purposely enter the wrong password it says "FAILED" in red.

Offline
*
Re: Login issues with CWP
« Reply #10 on: November 14, 2019, 09:07:39 AM »
Could you login with your user account?