Author Topic: Security - Hide all processes  (Read 1384 times)

0 Members and 1 Guest are viewing this topic.

Offline
***
Security - Hide all processes
« on: July 03, 2018, 06:25:23 AM »
I swear this is getting very irritating. I keep on getting this message.

Quote
Danger: Hidden Processes - SECURITY ISSUE
Hide all processes if not owned by the user is NOT activated on your server, click here to enable it.

I've clicked on it and did enabled it like a hundred times already. Each time, it turned green and showed.
Quote
[STATUS: ACTIVE PERMANENT]

But after sometime it get disabled on its own and I will get that message again.

Also Mod Security, I don't want to use it because I don't understand it. It breaks a lot of stuff on my websites. The warning message keeps showing up. I just dismissed it. But I do understand the warning because I don't have it enabled.

What's up with Hidden Processes - SECURITY ISSUE? I did enabled it.  >:(

I am on CWPpro version: 0.9.8.679

Offline
*
Re: Security - Hide all processes
« Reply #1 on: July 04, 2018, 09:23:14 PM »
I find that that happens to me as well but only after the server has been rebooted.

Offline
*
Re: Security - Hide all processes
« Reply #2 on: April 11, 2019, 09:33:38 AM »
I have the exact same problem. This may be a bug.

Offline
*
Re: Security - Hide all processes
« Reply #3 on: May 10, 2019, 02:19:17 PM »
Yep, happening on one of my installations too.
 :(

Online
***
Re: Security - Hide all processes
« Reply #4 on: May 11, 2019, 11:39:59 AM »
I can confirm that this issue still persists after a long time.

Offline
*****
Re: Security - Hide all processes
« Reply #5 on: May 12, 2019, 04:21:32 AM »
Hi, just press the close button.

Offline
***
Re: Security - Hide all processes
« Reply #6 on: May 18, 2019, 06:30:56 AM »
I have the same problem...annoying true.

I have clicked on this thing dozens of times and without fail, out of the blue it has changed status either to temporary, or disabled!

Having said that, i do like the feature...just wish it worked properly. I guess in time it will get sorted, and there are far worse issues that im concerned about that i would like fixed well before this one!

Offline
*
Re: Security - Hide all processes
« Reply #7 on: May 18, 2019, 11:17:47 AM »
I had the same issue.  After a reboot, it defaulted to not being implemented.  I personally opted for a manual fix.

This feature uses the hideid option when mounting the /proc folder.  I made it a permanent fix by adding the following line to my /etc/fstab file:

proc   /proc    proc   defaults,hidepid=2   0   0

Warning: Be very careful, as an incorrect fstab file can stop your machine from booting properly.  Make backups or snapshots.

Hopefully, a future CWP update will resolve this.

Offline
*
Re: Security - Hide all processes
« Reply #8 on: June 04, 2019, 11:43:46 AM »
This feature uses the hideid option when mounting the /proc folder.  I made it a permanent fix by adding the following line to my /etc/fstab file:

Code: [Select]
proc   /proc    proc   defaults,hidepid=2   0   0
Thanks for the workaround!