Author Topic: Domain doesn't resolve  (Read 1052 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
Domain doesn't resolve
« on: March 23, 2018, 01:46:24 AM »
Hi, all settings looks to be ok, hostname resolvses to IP NS, but new added domain, doesn't work at all. It seems like the virtual host has some issues. Recapitulation:

1. CentOS Web Panel Settings - all right
2. Your Hostname is: ab.xxzz.com and it resolves to IP: xxx.xx.xxx.207
3. Edit Name Servers - all right (ns names and IPs)
4. domain in CWP - ns on domain registrar are same as on CWP

the only thing is that the CWP server is not the "master" of DNS. The DNS settings will be done on a cPanel server with PowerDNS.

Any ideas why the websites on the CWP are not resolving?
Thanks

Offline
*
Re: Domain doesn't resolve
« Reply #1 on: March 23, 2018, 09:43:10 AM »
if cwp is not dns server then you shouldn't look for issue on the cwp server if you have a dns resolving issues

http://leafdns.com/ site will give you realtime dns info for your domain
VPS & Dedicated server provider with included FREE Managed support for CWP.
http://www.studio4host.com/

*** Don't allow that your server or website is down, choose hosting provider with included expert managed support for your CWP.

Offline
*
Re: Domain doesn't resolve
« Reply #2 on: March 23, 2018, 12:53:40 PM »
if cwp is not dns server then you shouldn't look for issue on the cwp server if you have a dns resolving issues

I don't understand your answer. Also I don't know where should I enable it to work like a dns server, but BIND DNS Server is running and the NS have been set up in same way like on our another cPanel servers. That means there are two NS:

ns1.blabla - IP
ns2.blabla - IP

This NS are registered on our DNS server and on WHM panels. So here we did the same, but something is wrong here... For example the hostname on this CWP resolves right, but another users domains don't.

Offline
*
Re: Domain doesn't resolve
« Reply #3 on: March 23, 2018, 01:18:14 PM »
NS set up on the domain registrar:

ns9.martfox.com
ns10.martfox.com

NS set up in CWP:

ns9.martfox.com + IP
ns10.martfox.com + IP

The zone file of this domain in CWP looks like this:

Code: [Select]
; Generated by CWP
; Zone file for vpshostprovider.com
$TTL 14400
vpshostprovider.com.      86400        IN      SOA     ns9.martfox.com. martfoxhosting.gmail.com. (
2013071600      ; serial, todays date+todays
86400           ; refresh, seconds
7200            ; retry, seconds
3600000         ; expire, seconds
86400 )         ; minimum, seconds

vpshostprovider.com. 86400 IN NS ns9.martfox.com.
vpshostprovider.com. 86400 IN NS ns10.martfox.com.

vpshostprovider.com. IN A 142.44.195.207

localhost.vpshostprovider.com. IN A 127.0.0.1

vpshostprovider.com. IN MX 0 vpshostprovider.com.

mail IN CNAME vpshostprovider.com.
www IN CNAME vpshostprovider.com.
ftp IN CNAME vpshostprovider.com.

LeafDNS shows errors:

http://leafdns.com/index.cgi?testid=012998D5

So I think there isn't much more to do on the domain registrar side and here in CWP panel and I have no idea what I'm doing wrong. Just FYI the WHM domain server and cPanel server use DNS synchronisation and the NS service is running as PowerDNS. I'm sure, if I will go to set up this domain which is not working currently on the CWP, on any cPanel server with same NS values, the domain will work immediately

Offline
*
Re: Domain doesn't resolve
« Reply #4 on: March 23, 2018, 02:22:49 PM »
Ok, we decide to stay with cPanel even it costs $13/month. Within 24 hours we weren't able to solve a trivial issue such this one with setting up NS on CWP to get websites working. If we set up a cpanel server we put just the two NS names into the cpanel configuration, choose the name server service and that's it.

Regards

Offline
*
Re: Domain doesn't resolve
« Reply #5 on: March 23, 2018, 04:03:19 PM »
as you can see on your test nameservers are NOT working, meaning if you don't use cwp for dns then you can leave dns server down on cwp, as it is not needed then.

DNS issues you need to resolve on the DNS servers this can't be any simpler.
If you would use dns on your server then you would simply save dns servers on cwp and that is it.
VPS & Dedicated server provider with included FREE Managed support for CWP.
http://www.studio4host.com/

*** Don't allow that your server or website is down, choose hosting provider with included expert managed support for your CWP.

Offline
*
Re: Domain doesn't resolve
« Reply #6 on: March 23, 2018, 05:27:34 PM »
If you would use dns on your server then you would simply save dns servers on cwp and that is it.

But we used the DNS on our CWP and BIND was running all the time as mentionted twice in this thread. If it would not, then the hostname wouldn't work as well, or am I wrong?

What do you mean with "simply save dns servers on cwp and that is it."???