Author Topic: self hosted DNS - NS Zone has no address records (A or AAAA)  (Read 713 times)

0 Members and 1 Guest are viewing this topic.

Offline
****
self hosted DNS - NS Zone has no address records (A or AAAA)
« on: February 06, 2018, 12:53:40 PM »
Setting up own hosted NS/DNS

NS zone
Quote
$TTL 14400
ns1.my.domain.      86400      IN      SOA      ns1.my.domain.      some.email.net.      (
                  2018020612 ;serial, todays date+todays
                  86400 ;refresh, seconds
                  7200 ;retry, seconds
                  3600000 ;expire, seconds
                  86400 ;minimum, seconds
      )


ns1.my.domain.      86400      IN      NS      ns1.my.domain.

ns1.my.domain.      0      IN      A      myIP
localhost.ns1.my.domain.      0      IN      A      127.0.0.1
Reloading the NS zone produces
Quote
zone ns1.my.domain/IN: loaded serial 2018020612
OK

Domain Zone setup
Quote
$TTL 14400
my.domain.      86400        IN      SOA     ns1.my.domain. some.email.net. (
            2013071600      ; serial, todays date+todays
            86400           ; refresh, seconds
            7200            ; retry, seconds
            3600000         ; expire, seconds
            86400 )         ; minimum, seconds

my.domain. 86400 IN NS ns1.my.domain.

my.domain. IN A 179.43.171.29

localhost.my.domain. IN A 127.0.0.1
Reloading the Domain NS zone produces
Quote
zone my.domain/IN: NS 'ns1.vtol.me' has no address records (A or AAAA)
zone my.domain/IN: not loaded due to errors.

Now why would that happen considering that zone ns1.my.domain checked out ok?
« Last Edit: February 06, 2018, 01:04:32 PM by n8v8r »

Offline
****
Re: self hosted DNS - NS Zone has no address records (A or AAAA)
« Reply #1 on: February 06, 2018, 01:05:18 PM »
is there a way in CWP to set a glue record for NS to the domain?

Offline
****
Re: self hosted DNS single IP - NS Zone has no address records (A or AAAA)
« Reply #2 on: February 06, 2018, 01:43:17 PM »
Might be happening due to some misconception of setting only a single NS for single IP born out of this wiki http://wiki.centos-webpanel.com/how-to-setup-name-servers
Quote
If you are using one IP then it should looks like:
ns1.demo.com --> 185.4.149.83
ns1.demo.com --> 185.4.149.83
Considering that named does not accept duplicate ns entries (ns1) just a single NS was setup.

After having deleted NS and Domain zone a new Domain zone was created and afterwards through Edit Nameservers NS1 and NS2 (single IP) were added and the error is gone.
« Last Edit: February 06, 2018, 02:32:04 PM by n8v8r »