Author Topic: Install Apache 2.4.x and suPHP 0.7.2  (Read 5339 times)

0 Members and 1 Guest are viewing this topic.

Install Apache 2.4.x and suPHP 0.7.2
« on: April 07, 2015, 12:04:24 PM »

Re: Install Apache 2.4.x and suPHP 0.7.2
« Reply #1 on: April 07, 2015, 04:51:36 PM »
I have created a simple bash file which you can run to install Apache 2.4 and suPHP 0.7.2 on your CWP server

Quote
cd /usr/local/src
wget -c http://dl-package.bullten.in/cwp/apache-upgrade.sh
chmod +x apache-upgrade.sh
sh apache-upgrade.sh | tee /var/log/apache_upgrade.log


You still need to edit your Vhost file [ /usr/local/apache/conf.d/vhosts.conf] and add [Require all granted] under each domain Host.

 
« Last Edit: April 08, 2015, 07:38:28 AM by BullTen »

Re: Install Apache 2.4.x and suPHP 0.7.2
« Reply #2 on: April 08, 2015, 10:42:40 AM »
Added feature to add "Require all granted" to Vhost file for pre existed domains. Still for new domains you need to add that manually.

Offline
*
Re: Install Apache 2.4.x and suPHP 0.7.2
« Reply #3 on: May 21, 2016, 06:32:28 AM »
Download link broken  :(

Offline
*
Re: Install Apache 2.4.x and suPHP 0.7.2
« Reply #4 on: May 23, 2016, 07:05:55 PM »
Will be better if you put Require all granted into Apache virtual host template and after that rebuild vhosts :)
“Would you tell me, please, which way I ought to go from here?”
“That depends a good deal on where you want to get to,” said the Cat.
“I don’t much care where–” said Alice.
“Then it doesn’t matter which way you go,” said the Cat.
Neo2SHYAlien's Blog

Offline
*
Re: Install Apache 2.4.x and suPHP 0.7.2
« Reply #5 on: December 23, 2016, 12:21:55 PM »
have all done but he gets still to the root and not to my vhosts

Offline
*****
Re: Install Apache 2.4.x and suPHP 0.7.2
« Reply #6 on: December 23, 2016, 01:32:54 PM »
this will not work please wait for centos 7 CWP it have Apache 2.4.xx support.