Author Topic: WHMCS+CWP Problem  (Read 320 times)

0 Members and 1 Guest are viewing this topic.

Offline
**
WHMCS+CWP Problem
« on: June 10, 2017, 11:32:15 AM »
Hello guys,
I have WHMCS 6.3.1 and CWP 0.9.8.249. I downloaded and installed the WHMCS module from the WiKi page. I fixed the permissions just in case. Put the IP of the WHMCS in the config and the hash in the key file.Did the configuration of the module like it`s shown on the payed one page. Tested the command in my browser IP:2030/api/?key=KEY&api=account_new&domain=DOMAIN&username=USERNAME&password=PASSWORD&package=PACKAGE-NUMBER&email=CLIENT-EMAIL&inode=10000&nofile=100&nproc=25 and I got status OK. In CWP I get the new user. I tested the command with cURL and again got status OK and saw the new user in the CWP. And here comes the problem:
When I try to add a new user from the WHMCS I see:
Code: [Select]
Order Accept Encountered Problems
Check All Fields (only lower caps are allowed and no special characters)!
The only place I don`t have a lower case strings is the Access Hash and I don`t input any special chars. The hash there is generated from random.org. The Access Hash is the same in the /usr/local/cwp/.conf/api_key.conf and in the WHMCS. Tryed to put htmlspecialchars(strtolower($params[""])) in the centoswebpanel.php but it didn`t help. Any idea how to fix this problem? Any help will be appreciated.
Current uptime:
UNIX is a very simple OS, but you have to be a GENIUS to understand it ...

Offline
**
Re: WHMCS+CWP Problem
« Reply #1 on: June 23, 2017, 01:39:57 AM »
After waiting so many days for a reply I gave up on waiting. Last night I wake up 1:30, sit down on my notebook and I rewrote the addon almost from zero. Now the addon is working fine with WHMCS 6.3.1. Also tested on WHMCS 7.1.2 and also working fine. I want to make some more improvements and I will share it with you.
Current uptime:
UNIX is a very simple OS, but you have to be a GENIUS to understand it ...