Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - henrycoule

Pages: [1]
1
CentOS-WebPanel Bugs / Missing Sock file for end user
« on: December 07, 2019, 08:42:04 PM »
I noticed that some of my user accounts are unable to login to the control panel and when I looked at the logs I saw there is a missing sock file as shown here

[crit] 16544#0: *8 connect() to unix:/usr/local/cwp/php71/var/sockets/testuser.sock failed (2: No such file or directory) while connecting to upstream, client: #.#.#.#, server: localhost, request: "GET /testuser/ HTTP/1.1", upstream: "fastcgi://unix:/usr/local/cwp/php71/var/sockets/testuser.sock:", host: "srv.domain.com:2083"

All users logging to the control panel have a sock file created here /usr/local/cwp/php71/var/sockets/ but I realized my user with the issue doesn't have a sock file there. Initially, since it was a test user, I deleted and re-created the account and the sock file was created but after a while, it was gone again. Now it is happening to real users and they cannot log in to the control panel. They are getting errors like "502 Bad Gateway"

2
CentOS 7 Problems / Re: BIND DNS Server - Failed
« on: November 12, 2019, 04:20:04 AM »
On the terminal, if you type the command
Code: [Select]
which named what do results do you get?

3
CentOS 7 Problems / Re: Cpanel Server migration errors
« on: November 12, 2019, 04:16:58 AM »
I already found the solution. It is just silly how CWP is trying to transfer the accounts. but I sorted it out.

4
CentOS-WebPanel Bugs / DNS Zone Editor Bug
« on: November 12, 2019, 04:14:30 AM »
On the User Panel, when you click the DNS ZONE EDITOR, you can add a record but you cannot delete anything including the recorded you added. If you make a mistake you cannot delete and you are stuck waiting on a server administrator to do this from the command line.

It doesn't make sense to make someone add an entry that they cannot remove. Was this a mistake or that's the intention?

5
CentOS-WebPanel Bugs / Re: Hourly Email not working
« on: November 12, 2019, 04:08:49 AM »
From your screenshot, I can see that email has been hacked. Please change the password on that email account and scan the machine which is using this email for any viruses or keyloggers.

6
CentOS-WebPanel Bugs / Softaculous is very slow
« on: November 06, 2019, 07:49:56 AM »
Softaculous from my end users side is very very slow. Takes like 10 to 15mins to open up each time and anything you click is another 10 or 15 mins. From the Admin side, it is blazing fast! Anyone ever experienced this? Any fix? Any ideas?

7
New Modules / Re: [module] WHMCS (Fix)
« on: November 06, 2019, 07:10:55 AM »
I really like your idea of fetching the packages from the server into WHMCS but I was missing the autologin from the other package so I combined yours and the other one to get both worlds. If anyone is interested I can share it.

Update! - New version available | 1.0.1

 * Date: 16/03/2019
 * Version Release: 1.0.1
 * + Added function ihoscwp7_LoaderFunction

List of Packages are now automatically loaded

ScreenShot



8
That's true, the only place it works is the left side-bar menu

9
CentOS 7 Problems / Cpanel Server migration errors
« on: October 12, 2019, 07:10:43 AM »
Cpanel server migration is failing on every account. I will see the backup packaged created on the cPanel server but right about that time when the progress gets to 60% at CWP side, it fails, each time! I get the error


[2019-10-12 07:07:49] - Start import process CPANELCWP_20191012070749
[2019-10-12 07:07:50] - Import Account testacc
[2019-10-12 07:07:50] - Create Backup Account testacc
[2019-10-12 07:07:59] - Start Transfer Backup testacc
[2019-10-12 03:08:01] - File not Found testacc

10
CentOS 7 Problems / Re: User Panel stuck
« on: October 12, 2019, 07:05:32 AM »
Ok, thanks. I noticed it fails when I have a remote mysql working with CWP but once I brought MySQL back, user panel was working again. I have to get support on this. Thanks once again

11
CentOS 7 Problems / User Panel stuck
« on: October 09, 2019, 05:30:17 PM »
I can log in to the admin control panel without any issues but the user control panel is stuck at the login page with the button saying "Please wait" after I enter the credentials. I have restarted the service to no avail

12
cPanel Server migration is also failing for me. It will create the cpmove-??? backup on my cPanel server then when it is time to transfer it fails (always at 60%). Manually creating the backup on the cPanel server and moving to CWP works but that's some work if you have lots of accounts.

Pages: [1]