Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - TheRavenKing

Pages: [1]
1
Migration from other control panels / Migration failed from cPanel to CWP
« on: October 21, 2018, 05:42:13 PM »
Today, I wanted to migrate my cpanel account to CWP, but it just fails after copying the files, I can see there is the user created but no access granted.

Tried it even without my email accounts same error: after file copy it stops, no progress indicator and some weird errors about mailboxes from the past which have been deleted. Not sure what to do as it's not good start to swap from cPanel to CWP.

OK, small step further, it failed on my created package, but when using the 'default' it seems to go through the whole process, but it has failed in creating the mysql dbs and mailboxes, any on any ideas?

In List accounts:
Notice: Undefined offset:1 in /usr/local/cwpsrv/htdocs/resources/admin/modules/list_accounts.php on line 0
Notice: Undefined offset:1 in /usr/local/cwpsrv/htdocs/resources/admin/modules/list_accounts.php on line 0
Notice: Undefined offset:1 in /usr/local/cwpsrv/htdocs/resources/admin/modules/list_accounts.php on line 0
Notice: Undefined offset:1 in /usr/local/cwpsrv/htdocs/resources/admin/modules/list_accounts.php on line 0

Listing my account, but above those 4 rows of errors....

2
NEW installation.

Configuration file /usr/lib/systemd/system/pure-ftpd.service is marked executable. Please remove executable permission bits. Proceeding anyway.

Can I change the permission to 0644 from the original 0755 with

chmod 0644 /usr/lib/systemd/system/pure-ftpd.service

Or will that break the ftp service?

3
Installation / Migration cPanel to CWP
« on: October 14, 2018, 02:25:35 PM »
Hi,
I have a VPS with cPanel and want to migrate to CWP but don't want to change IP of my cPanel user account.
to avoid huge downtime, I have set the refresh of my domain to 300 and created two new name servers pointing to the same IP as my user account is using on cPanel.

Can I create a new CWP VPS with same IP as I use in my current cPanel account?

Current situation:
cPanel VPS: x.x.x.150
cPanel user account: x.x.x.151

New situation:
CWP VPS: x.x.x.151
CWP user account: x.x.x.151

ns1.nameserver: x.x.x.151
ns2.nameserver: x.x.x.151

Any help/advise much appreciated.

4
E-Mail / /usr/sbin/tmpwatch: No such file or directory
« on: March 09, 2017, 09:56:54 AM »
Hi All,

I am getting this message in my Anacron log, why does it happen and how to fix it?
Thank you

/etc/cron.daily/amavisd:

/etc/cron.daily/amavisd: line 1: /usr/sbin/tmpwatch: No such file or directory
/etc/cron.daily/cwp:

5
SSL / Hostname SSL with Letsencrypt, can't renew certificate
« on: March 06, 2017, 10:02:59 PM »
Hi All,

I have installed on my CentOSv6 with Apache the let's encrypt for the server, it works fine, but I can't renew it  :-\

Used these instructions in December last year....  http://wiki.centos-webpanel.com/hostname-ssl-with-letsencrypt

Error:

The following certs could not be renewed:
  /etc/letsencrypt/live/sub.domain.com/fullchain.pem (failure)
IMPORTANT NOTES:
 - The following errors were reported by the server:

   Domain: sub.domain.com
   Type:   unauthorized
   Detail: Invalid response from
   http://sub.domain.com/.well-known/acme-challenge/UcnoQ8dI8D6PsGIMEpcvwTyPQL1ImGopjQqAsl0PBao:
   "
Not Found

Any ideas?

6
Crashed.....when trying to install php v7.x in the php selector.

part of log.

Nothing to do
buildconf: checking installation...
buildconf: autoconf version 2.63 (ok)
rebuilding aclocal.m4
rebuilding configure
configure.ac:276: error: Autoconf version 2.64 or higher is required
build/ax_check_compile_flag.m4:60: AX_CHECK_COMPILE_FLAG is expanded from...
autom4te: /usr/bin/m4 failed with exit status: 63
rebuilding main/php_config.h.in
configure.ac:276: error: Autoconf version 2.64 or higher is required
build/ax_check_compile_flag.m4:60: AX_CHECK_COMPILE_FLAG is expanded from...
autom4te: /usr/bin/m4 failed with exit status: 63
autoheader: '/usr/bin/autom4te' failed with exit status: 63
/usr/local/cwp/.conf/php_conf/php7.conf: line 1: ./configure: No such file or directory
make: *** No targets specified and no makefile found.  Stop.
make: *** No rule to make target `install'.  Stop.
Stopping httpd: [  OK  ]
Starting httpd: (98)Address already in use: make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs
[FAILED]

Build Completed
###################

After a reboot it came with message

WARNING! You are not running CWP Apache and this could cause that your domains do not work!

under service status:
Apache Webserver      httpd dead but subsys locked

How to fix httpd dead but subsys locked?

7
Hi,

I created a folder /test
placed .htaccess file in it with following content:

AddHandler application/x-httpd-php56 .php

Checking the php info, it shows error:

Warning: phpinfo(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.

Contents of File: /opt/alt/php56/usr/php/php.ini

[Date]
; Defines the default timezone used by the date functions
; http://php.net/date.timezone
date.timezone = "Europe/London"


8
Hi,

I spend some good time to get my php settings to my requirements.
After using the PHP Version Switcher to use a different php version I noticed all my settings are back to 'default',  :(
Even the settings in the: Simple PHP.ini editor are 'reset' to default...

Is there a setting or trick to recompile but keep my modified settings or extend the Simple PHP.ini editor and make sure this one is not reset?

Thanks.

9
CentOS-WebPanel Bugs / SOLVED: mail not sending - permission denied
« on: November 09, 2016, 11:41:32 AM »
Hi,

I can receive email, but they keep stuck in the queue with the following error:

(temporary failure. Command output: Can't open log file /var/log/dovecot-info.log: Permission denied

-rw-------   1 vmail mail  10118 Nov  9 09:49 dovecot.log

How to fix this, and why does it happen?

Thanks

10
CentOS-WebPanel Bugs / Mail explorer - error / warning
« on: September 13, 2016, 11:46:09 AM »
Mail explorer gives following error /warning

Warning: Invalid argument supplied for foreach() in /usr/local/cwpsrv/htdocs/resources/admin/modules/mail_explorer.php on line 0

11
CentOS-WebPanel Bugs / When deleting an user, not everything is deleted
« on: August 11, 2016, 06:47:55 PM »
Hi,

When you delete an user not everything is deleted, like mailboxes and zonefiles.

Cheers.

12
Hi,

When you go to the Postfix Mail queue manager and click on an single email and press the Remove this email button it will delete all emails,
not just the one your viewing.


13
Installation / Disable SElinux or not with installation?
« on: June 09, 2016, 10:11:24 AM »
Hiya,

What I can't find in the installation instructions is the SElinux setting, do we disable this like in cPanel?

Any reply would be appreciated.

14
CentOS-WebPanel Bugs / Backup gives PHP errors
« on: June 08, 2016, 08:33:23 AM »
PHP Notice:  Undefined variable: Emp489gY2js3pMb in /usr/local/cwpsrv/htdocs/resources/admin/include/cron_backup.php(1) : eval()'d code(1) : eval()'d code on line 7

Notice: Undefined variable: Emp489gY2js3pMb in /usr/local/cwpsrv/htdocs/resources/admin/include/cron_backup.php(1) : eval()'d code(1) : eval()'d code on line 7
PHP Notice:  Undefined variable: Emp489gY2js3pMb in /usr/local/cwpsrv/htdocs/resources/admin/include/cron_backup.php(1) : eval()'d code(1) : eval()'d code on line 7

Notice: Undefined variable: Emp489gY2js3pMb in /usr/local/cwpsrv/htdocs/resources/admin/include/cron_backup.php(1) : eval()'d code(1) : eval()'d code on line 7

15
CentOS-WebPanel Bugs / Edit zone records throws error:
« on: June 07, 2016, 04:17:29 PM »
Hi Support,

List of DNS Zone files from /var/named/

When I try to edit a zone record it throws following error:

Notice: Undefined offset: 3 in /usr/local/cwpsrv/htdocs/resources/admin/modules/zone_editor.php(1) : eval()'d code(1) : eval()'d code on line 98

What other information would you require other than that this;

Apache version: Apache/2.2.27
PHP version: 5.6.14 [PHP Switcher]
MySQL version: 10.1.14-MariaDB
FTP version: 1.0.36

Edit: I switched back to the default PHP 5.4.45 version, but error still exists.
More edit: the file is encoded so I can't check what variable is going wrong in conversion...

I can't imagine I am the  only one with this problem, am I?

Pages: [1]