Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - pipoy

Pages: [1]
1
PHP Selector / PHP8 Ioncube not working
« on: July 19, 2023, 12:45:49 AM »
Has anyone here also having the same issue?

I have enabled Ioncube with both php and php-fpm with successful install.
But when I load my website, it says ionCube PHP Loader needs to be installed.

Other php version seems to be working. Only with PHP8.

2
CentOS 7 Problems / I cannot unsuspend users.
« on: July 14, 2023, 01:01:20 PM »
I noticed one of my dormant user is eating up a lot of CPU which I dont know why. It is just a dormant website.

So I decided to suspend the specific user and the issue was fixed.

However, I cannot unsuspend the user back.
I tried it with other dormant user and the same issue.

Here are some more problems I encountered in relation.
1. I cannot adjust the INODE. I am trying to save it to 0 for those users.
2. The Green ON/OFF suspend button is green and says ON. But the Disk Usage bar is still orange.
3. I cannot login to the user. The error says "quota" in red.
4. The dormant websites are actually working for some reason.

Anyone encountering the same issue? Any fix on this?

3
Information / Cant install Laravel using CWP Script
« on: November 16, 2022, 05:29:00 AM »
Anyone here who also cannot install a Laravel app using the automation script?

2 of my servers are stuck in the installation and dont even install a Laravel app successfully.

I deployed a fresh one and it looks like there is no problem. The CWP demo does not have the same problem as well.

So it has to be a bug somewhere if you are already using CWP for a long time.

4
DNS / how to use SRV records
« on: June 28, 2021, 06:23:38 AM »
Hi,

I have customer with a Minecraft server with a specific custom port, 25576.

The Minecraft default port is 25565 which is already unavailable and used by another customer.

The customer with a custom port wants to use his domain, which is DNS managed by our CWP, directly without putting the custom port.

Because his Minecraft players are mistakenly getting connected to the 25565.

If I am not mistaken, SRV record will resolve this, but I cannot seem to have it working.

Name: domain.com
Protocol: tcp
Weight: 5
Target: domain.com
Symbolic Name: http
Priority: 0
Port: 25576
TTL: 60







any help?

Thanks




5
PHP / Need to increase max_execution_time in Master Value
« on: May 16, 2021, 03:35:17 PM »
Anyone here knows how to increase the Master Value of php?





I have changed all php.ini values. But the master value remains 30 for the max_execution_time

6
Information / WHMCS Account creating problem. CSS broken
« on: May 01, 2021, 04:42:01 AM »
So, after so many months of testing and using my server for my own production environment, suddenly, creating users via WHMCS has some issues inside CWP.

After account creation, upon logging in the user, this is how it looks like.







It's fine when creating a user in the normal way.

After so many months of creating users via WHMCS, then it became this. Anyone knows the problem?

7
CentOS 7 Problems / Removing Quotas
« on: April 21, 2021, 12:33:42 AM »
Hi,

I have configured quota before for disk /dev/vda1.

Now, I have added a new partition for /home in /dev/vdb because the users are growing.

I have setup the quota as before and configured it as /home this time.

but the problem here is that the quotas in the UI did not change and it is still reading the quota from /dev/vda1



Upon checking User Quota via repquota -a, I have 2 quotas.

The old one from /dev/vda1 and the new one at /dev/vdb


*** Report for user quotas on device /dev/vda1
Block grace time: 7days; Inode grace time: 7days
                        Space limits                File limits
User            used    soft    hard  grace    used  soft  hard  grace
----------------------------------------------------------------------


** Report for user quotas on device /dev/vdb
Block grace time: 7days; Inode grace time: 7days
                        Space limits                File limits
User            used    soft    hard  grace    used  soft  hard  grace



Question is how do totally delete the configuration from /dev/vda1

8
Installation / MongoDB Install failed
« on: July 07, 2020, 08:40:51 AM »
Cant install mongodb and this is the error appears.



Code: [Select]
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: mirrors.glesys.net
 * epel: my.fedora.ipserverone.com
 * extras: mirrors.glesys.net
 * updates: mirrors.glesys.net
http://downloads-distro.mongodb.org/repo/redhat/os/x86_64/repodata/repomd.xml: [Errno 14] curl#63 - "Callback aborted"
Trying other mirror.


 One of the configured repositories failed (MongoDB 2.6 Repository),
 and yum doesn't have enough cached data to continue. At this point the only
 safe thing yum can do is fail. There are a few ways to work "fix" this:

     1. Contact the upstream for the repository and get them to fix the problem.

     2. Reconfigure the baseurl/etc. for the repository, to point to a working
        upstream. This is most often useful if you are using a newer
        distribution release than is supported by the repository (and the
        packages for the previous distribution release still work).

     3. Run the command with the repository temporarily disabled
            yum --disablerepo=mongodb-org-2.6 ...

     4. Disable the repository permanently, so yum won't use it by default. Yum
        will then just ignore the repository until you permanently enable it
        again or use --enablerepo for temporary usage:

            yum-config-manager --disable mongodb-org-2.6
        or
            subscription-manager repos --disable=mongodb-org-2.6

     5. Configure the failing repository to be skipped, if it is unavailable.
        Note that yum will try to contact the repo. when it runs most commands,
        so will have to try and fail each time (and thus. yum will be be much
        slower). If it is a very temporary problem though, this is often a nice
        compromise:

            yum-config-manager --save --setopt=mongodb-org-2.6.skip_if_unavailable=true

failure: repodata/repomd.xml from mongodb-org-2.6: [Errno 256] No more mirrors to try.
http://downloads-distro.mongodb.org/repo/redhat/os/x86_64/repodata/repomd.xml: [Errno 14] curl#63 - "Callback aborted"
Redirecting to /bin/systemctl restart mongod.service
Failed to restart mongod.service: Unit not found.

9
Information / Email hosting only
« on: May 16, 2020, 12:17:41 AM »
Hi,

Can anyone guide me on how to create a package for email hosting only?
And not permit the user to create a website.

For every account, there is always a domain name and public_html. So by default, they can create websites.
But I am trying to figure out how can they be restricted in creating websites.

Perhaps setting nproc and apache_nproc to 0?


10
Information / How Incremental backup works? CWPpro
« on: May 10, 2020, 01:26:04 AM »
Hi,

For CWP pro users.

Is it just me or the incremental backup is just the same as full backup but uncompressed?

By definition: Incremental Backup
a security copy which contains only those files which have been altered since the last full backup.

But when I look at my backups, it's the whole account being backed up that is uncompressed.

11
Apache / Run Node js with CWP
« on: May 09, 2020, 05:18:49 AM »
I followed this guide to install node js

https://wiki.centos-webpanel.com/how-to-install-and-setup-node-js-on-cwp

After this part
Configure webservers for domain to be used for nodejs Application:
CWP.Admin left Menu -> Webserver settings -> Webserver Domain Conf -> Select Username -> Select Domain/Subdomain -> create configuration -> select any option with (custom port) -> check the box Rebuild webserver conf for domain on save -> Enter port number you have used in the application for the custom port, leave IP as 127.0.0.1 -> save changes


I get Service Unavailable.

Service Unavailable
The server is temporarily unable to service your request due to maintenance downtime or capacity problems. Please try again later.

Anyone here knows how to solve this?

My application requires LAMP.

I deployed a brand new server with just CWP just to see what's the issue. Same thing.

So i must be missing 1 step or CWP is creating this error.

12
Information / Cannot create email in user side
« on: April 28, 2020, 07:42:47 PM »
Anyone here experiencing CWP is unable to create new email addresses in the user side?

When you click Add, it will just stuck in processing.

I have 6 servers. 3 new ones. I noticed it with those first. Then I turned to my old 3 servers. And the same issue.


EDIT:

I confirm that this is an issue because CWP's own demo has the same issue.

In fact, I conclude that this is on the latest update. I created an email on the user side and it was a success. Then I logged in to the root user of the demo to update it to latest CWP update. After that, I logged in once again in the user and the issue is confirmed

13
Information / Mailgun SMTP for Postfix
« on: April 12, 2020, 10:55:29 AM »
Hi,

Im trying to use mailgun as SMTP for the postfix email server. So that any user email will be sent via Mailgun SMTP.

But I cannot get it working.

I followed the guide here
https://documentation.mailgun.com/en/latest/user_manual.html#smtp-relay


Some of the lines are already in the original main.cf config as default installation of CWP.
But I cannot get it working

I instantly see error SMTP Error (250): Authentication failed when I hit send.

Some config shows normal behavior. But I receive bounce email and the message is
Remote-MTA: dns; smtp.mailgun.org
Diagnostic-Code: smtp; 550 5.7.1 Relaying denied


Here is my config.


Code: [Select]
# postfix config file

# uncomment for debugging if needed
#soft_bounce=yes

# postfix main
mail_owner = postfix
setgid_group = postdrop
delay_warning_time = 4

# postfix paths
html_directory = no
command_directory = /usr/sbin
daemon_directory = /usr/libexec/postfix
queue_directory = /var/spool/postfix
sendmail_path = /usr/sbin/sendmail.postfix
newaliases_path = /usr/bin/newaliases.postfix
mailq_path = /usr/bin/mailq.postfix
manpage_directory = /usr/share/man

# network settings
inet_interfaces = all
mydomain = yourdomain.com
myhostname = "my.actualhostname.com"
mynetworks = $config_directory/mynetworks
mydestination = $myhostname =  "my.actualhostname.com"
relay_domains = proxy:mysql:/etc/postfix/mysql-relay_domains_maps.cf

# mail delivery
recipient_delimiter = +

# mappings
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
transport_maps = hash:/etc/postfix/transport
#local_recipient_maps =

# virtual setup
virtual_alias_maps = proxy:mysql:/etc/postfix/mysql-virtual_alias_default_maps.cf, proxy:mysql:/etc/postfix/mysql-virtual_alias_maps.cf, regexp                                                                                              :/etc/postfix/virtual_regexp
virtual_mailbox_base = /var/vmail
virtual_mailbox_domains = proxy:mysql:/etc/postfix/mysql-virtual_domains_maps.cf
virtual_mailbox_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailbox_maps.cf, proxy:mysql:/etc/postfix/mysql-virtual_alias_pipe_maps.cf
virtual_minimum_uid = 101
virtual_uid_maps = static:101
virtual_gid_maps = static:12
virtual_transport = dovecot
dovecot_destination_recipient_limit = 1

# debugging
debug_peer_level = 2
debugger_command = PATH=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin
                 xxgdb $daemon_directory/$process_name $process_id & sleep 5

relayhost = [smtp.mailgun.org]:587
smtp_sasl_password_maps = static:mailgun@user.com:mysmtppassword

# authentication
smtp_sasl_auth_enable = yes
smtp_sasl_security_options = noanonymous
smtpd_sasl_local_domain = $myhostname =  "my.actualhostname.com"
broken_sasl_auth_clients = yes
smtpd_sasl_type = dovecot
smtpd_sasl_path = private/auth

# tls config
smtp_use_tls = yes
smtpd_use_tls = yes
smtpd_tls_security_level = may
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
tls_random_source = dev:/dev/urandom
smtp_tls_session_cache_database = btree:$data_directory/smtp_tls_session_cache
# Change mail.example.com.* to your host name
smtpd_tls_key_file = /etc/pki/tls/private/hostname.key
smtpd_tls_cert_file = /etc/pki/tls/certs/hostname.bundle
smtpd_tls_CApath = /etc/ssl/certs

# rules restrictions
smtpd_client_restrictions =
smtpd_helo_restrictions =
smtpd_sender_restrictions =
smtpd_recipient_restrictions = permit_sasl_authenticated, permit_mynetworks, reject_unauth_destination, reject_non_fqdn_sender, reject_non_fqdn                                                                                              _recipient, reject_unknown_recipient_domain
# uncomment for realtime black list checks
# ,reject_rbl_client zen.spamhaus.org
# ,reject_rbl_client bl.spamcop.net
# ,reject_rbl_client dnsbl.sorbs.net
smtpd_helo_required = yes
unknown_local_recipient_reject_code = 550
disable_vrfy_command = yes
smtpd_data_restrictions = reject_unauth_pipelining

# Other options
# email size limit ~20Meg
message_size_limit = 204800000
mailbox_size_limit = 2048000000

# Vacation Scripts
vacation_destination_recipient_limit = 1
recipient_bcc_maps = proxy:mysql:/etc/postfix/mysql-virtual_vacation.cf

14
CentOS-WebPanel Bugs / Bug on deleting cron job on user account
« on: December 06, 2017, 03:23:08 AM »
I think there is a bug when deleting cron job on user side.

When you try to delete a cron job, a different job gets delete. Not the one you really want to delete.

15
CentOS-WebPanel Bugs / New Users are Suspended
« on: November 03, 2017, 11:47:31 AM »
hi,

I have issues with user password in CWP

1. When adding new users and tried to login using that user, it's suspended even it not from the list of users.
I explored more, and the reason why it is suspended because I did not use the random password generated. I entered a password on my own

2. Now that I used the random generated password, I can login using that user without the suspended error.
However, when I tried changing the password, it doesnt. It also wants the random generated password


3. I dug a little deeper. I think CWP wants a password that has lower and upper case plus a special and numeric characters.
But I am not entirely sure. Because the problem here is that there is no warning both admin and user side. This took me 2hrs to figure out.


4. A weak password shows a message
Code: [Select]
Changing password for user blahblah
The password I want shows a message
Code: [Select]
Changing password for user blahblah
The password I want is only lower and upper caps plus numbers. No special characters.

An accepted password shows
Code: [Select]
Changing password for user blahblah.
passwd: all authentication tokens updated successfully.


As you can see, there isn't really an error or warning message.

Im not sure if this is a bug. Or really how CWP works. ==


Pages: [1]