Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - Starburst

Pages: [1] 2
1
Just went to update PHP on  the CentOS 8 servers running CWPpro, and when I pull up PHP Version Switcher v2 or PHP Selector v2, Neither show 7.3.22 or 7.4.10.

But on the CWPpro - CentOS 7 is does show and allows you to update.

CentOS 7 & 8 servers are both running CWPpro version: 0.9.8.1008


I'm guessing this is a bug in CWP for CentOS 8.
OR
CWP hasn't released PHP 7.3.22 for CentOS 8 yet.


If anyone has any info, please comment below.

2
This is on CentOS 8, but since there isn't a group for it yet, I'm posting it here.

When I login I get that wonderful box in the lower right saying, "Available updates - SECURITY ISSUE, CWP found 1 available yum/rpm updates for your server, click here to check it."

I click on it, and then the update list is empty.

I'm guessing this is a bug, since CentOS 8 uses DNF, and not YUM anymore.

3
E-Mail / SpamAssassin High CPU Usage
« on: September 06, 2020, 03:44:16 AM »
Followed the Wiki at http://wiki.centos-webpanel.com/how-to-configure-spamassassin

Thought when you rebuilt the Email Server and had this option checked, it enabled it.
But apparently it doesn't, since all the line listed in the Wiki are missing.


After Enabling now though, CPU usable is at 100% for spamd

33279 root      20   0  185136  74772   8532 R 100.0   0.9   0:01.48 spamd


Does the Wiki have to still be done for CWPpro 0.9.8.1006?
Or am I missing something?

4
CentOS-WebPanel Bugs / CWP->CWP Migration Error - CentOS 8
« on: August 25, 2020, 11:46:29 PM »
I'm trying to start migrating account from CentOS 7 to 8, but the CWP to CWP Migration on CentOS 8 isn't working.

I can do the identical steps on 2 CentOS 7 servers and no problem.

The CentOS 8 server keeps giving:

Error API TOKEN
There is a problem with your TOKEN API
Contact support

I get alerts from csf that the server is connecting via SSH.

Need help.
I think they need to add a CentOS 8 forum for problems.

Thanks.

5
Installation / GoAccess for CentOS 8
« on: August 25, 2020, 06:43:37 PM »
I installed CWP on CentOS 8, only thing I see "missing" so far is GoAcess isn't available thru dnf.

And during the cron.daily, it gives the following mesage:


######################
Update Server Packages
######################
Redirecting to /bin/systemctl restart cwpsrv.service
Redirecting to /bin/systemctl restart httpd.service
Error: Unable to find a match: goaccess
--2020-08-25 03:14:16--  http://static.cdn-cwp.com/files/3rdparty/stats/goaccess/goaccess.conf
Resolving static.cdn-cwp.com (static.cdn-cwp.com)... 167.114.21.226, 151.80.90.199, 137.74.148.116, ...
Connecting to static.cdn-cwp.com (static.cdn-cwp.com)|167.114.21.226|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 19637 (19K) [text/x-config]
Saving to: ‘/etc/goaccess.conf’

     0K .......... .........                                  100% 1.24M=0.02s

2020-08-25 03:14:16 (1.24 MB/s) - ‘/etc/goaccess.conf’ saved [19637/19637]

Redirecting to /bin/systemctl reload httpd.service
Redirecting to /bin/systemctl reload httpd.service

6
DNS / Slave DNS Server & Manager Question
« on: August 24, 2020, 09:11:47 PM »
I just setup Slave DNS Server & Manager on CentOS 8, everything seems to be working, but when I access CWP's DNS Zone List, it doesn't show any of the zones.

Towards the bottom of http://wiki.centos-webpanel.com/slave-dns-server-manager-download-version, is:

CWPpro WebServer configuration

Edit File: /etc/named.conf and add this in options section before closing }

//Slave dns configuration
allow-transfer {111.112.113.114;};
allow-recursion {111.112.113.114;};
also-notify {111.112.113.114;};
masterfile-format text;


My question is, is this for the Web Server or the DNS Manager Server?

Further up in the instructions, it has you already edit this file.

Thanks

7
CWP API / WHMCS and CWP on CentOS 8
« on: August 22, 2020, 08:41:39 PM »
Will the current cwp7 script for WHMCS work on the CWP running on CentOS 8?
The last update was 30/March/2020.

8
E-Mail / Mail SSL Cert problem
« on: August 21, 2020, 03:22:07 AM »
Had a client that was using mail.domain.com without a problem with Thunderbird.

I did a kernel upgrade tonight along with upgrading PHP to 7.3.21, and he called saying he was getting a certificate error.
Saying the certificate didn't match the main hostname.
He didn't make any changes.
And I can't see how a kernel & PHP update could have caused this.
But I did do a server reboot after the kernel update.

Had him delete and recreate mailbox, same error.
Same error before mail. became an option for the SSL certificates.

Anyone have any ideas what might have happened?

9
Information / CentOS 8 Support - When or Never???
« on: August 07, 2020, 07:33:30 PM »
CentOS 7 stops Full updates Q4 2020, which starts next month.

cPanel and Plesk both are supporting CentOS 8 now since all required packages are available.
Even ISPConfig 3.2 is going to have CentOS 8 support.

When is CWP going to follow suit, and support CentOS 8?
Or is CWP development dead?

10
SSL / Hostname SSL won't update
« on: June 13, 2020, 12:09:49 AM »
Just did a new install of CWP, and I know the trick where to change the hostname to update the SSL, but for some reason it is not changing.
It's still the self signed SSL that gives an error.

Need to get this server up & running.

Any suggestions.

CentOS Linux release 7.8.2003 (Core)
CWP version: 0.9.8.986 - Have not registered as Pro yet.

11
Apache / Apache doesn't seem to be updating
« on: April 07, 2020, 11:36:18 PM »
In CWP 7 is seems like Apache is stuck on version 2.4.39, currently as of this post Apache is at 2.4.43, which also supports TLS 1.3.

Just running yum isn't doing any update.
Or if CWP running a modified Apache?

Any suggestions?

Thanks

12
Other / What runs differently in daily.crom between Pro and Non-Pro
« on: February 23, 2020, 03:39:59 PM »
Anyone know what runs differently in the daily.crom whether it's a Non-Pro or Pro version?

13
CentOS 7 Problems / Nagios Xi and CWP Pro problem
« on: February 22, 2020, 09:12:58 AM »
I use Nagios XI to monitor 3 servers.
Currently 2 are Pro and 1 isn't.

Nagios monitors all processes and report fine on all 3.

But when the daily cron is run on the 2 Pro CWP servers it stops reporting correctly to Nagios unless that server is rebooted.
The Non-Pro CWP server is fine.

Any suggestions?

14
CentOS Configuration / IPv6 support
« on: February 12, 2020, 02:57:55 AM »
Are there any plans to support strictly IPv6 or IPv4 & IPv6?

I tried to install CWP on a IPv6 only box, and it didn't do anything.

15
LiteSpeed / OpenLiteSpeed
« on: February 12, 2020, 02:56:30 AM »
I see more and more hosts offering OpenLiteSpeed.
Since LiteSpeed in a paid option in CWP, would it be difficult to add support for OpenLiteSpeed?

Pages: [1] 2