Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - jmshosting

Pages: [1]
1
CWP API / API Functions -> Account -> Update - Not working
« on: October 17, 2020, 11:55:56 AM »
When a customer chooses to upgrade their package, one thing does not work.
For "Account pack change" (changepack) working to 100%.

But when it has to update ionode, processes (nproc) and openfiles (nfiles) at the same time. That's not how it works.

At a debug so it says everything I want it to do. But on the admin website that is not updated.

I have seen the "New Account" had other flakes just nproc and nfiles that and these are not the same as the update. Is it a miss from the developers or is it with the wheat "forgotten"

My command:
Code: [Select]
curl -k "https://myserver:2304/v1/account" -X POST --data "key=MYKEY&action=udp&user=USER&package=@5&inode=175000&processes=80&openfiles=200"
Code: [Select]
curl -k "https://myserver:2304/v1/account" -X POST --data "key=MYKEY&action=udp&user=USER&package=TestPackage&inode=175000&processes=80&openfiles=200"
Debug output:
Code: [Select]
Key:MYKEY, action:accout_upd, ip:MYIP
{status:OK} -> {key:MYKEY,action:udp,user:USER,adds:null,server_ips:null,email:null,package:null,backup:null,inode:175000,processes:80,openfiles:200}

Why is "package:null" in the debug output? I have try to use both "package=@5" and "package=TestPachage".
Text info from API page: "package:   Package name or ID with @ front Ex: @12"

How to fix?

2
Information / Changelog is missing
« on: October 14, 2020, 04:46:45 PM »
I can't found any changelog for CWP  version.
Today I get new update. I have received total 2 updates in one week. But no information about what is new or what bugs are fixing.

Site https://control-webpanel.com/changelog has old info, last update was for Version 0.9.8.994, 2020-06-25.

Please fix a better changelog. So we know what changes have been made.

3
CentOS-WebPanel GUI / Problem when User add SubDomains
« on: October 03, 2020, 11:52:05 AM »
After one of your updates, the subdomain is placed under $HOME and not under $HOME/public_html as it was done before.

That's okay as long you do not have enablat SELinux. Turns on SELinux, so there is a risk that the Subdomain be bent or content not vissas for the visitor. Plus but get lot of errors in audit.log.

All Users need now to choose base path.
Quote
Eg.

After update of CWP
/home/testuser/test2.subdoamin.com

Before update of CWP.
/home/testuser/public_html/test.subdoamin.com

Iam is useing CWPpro version: 0.9.8.1015.

Pages: [1]