Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - stephenhare

Pages: [1]
1
Updates / File Manager no longer accessible in user accounts in V 0.9.8.941
« on: February 20, 2020, 10:21:00 PM »
In the latest version (0.9.8.941) it is not possible for users to access the File Manager (trying either in dashboard on left margin menu).

When an attempt is made, a new tab opens asking for log in detail to the user's control panel. If Username and password are entered then the another copy of the control panel opens. It is not possible to access the File Manager.

2
Hi,

When migrating a cPanel account using the built-in tool, the email accounts passwords don't seem to be migrated and users cannot log into their email accounts (webmail, etc).

Workaround 1: The advice from this link works on moving the hashed password from a cPanel text file to the "postfix" database in CWP: http://wiki.centos-webpanel.com/how-to-manually-import-emails from about half way down (How to copy email passwords from cPanel server). It should be possible to automate this as part of the migration tool, no?

Workaround 2. Each email account can have its password reset from the CWP account panel.

3
Updates / cPanel account migration not working in V0.9.8.875
« on: September 01, 2019, 02:27:36 PM »
Hi,
I have just tried cPanel account migration from cPanle full backup and it is no longer working as of the latest version V0.9.8.875.

I have tried both with and without the "process faster" tick box selected. The migration stop after the Decompress and Account creation. File copy does not occur. Below are the last few lines of the migration log with Its and domain redacted. No error message.

Regards, Stephen

Last lines of log...
11_ccff/homedir/cache/cache_3ebbab63ff1d3bffdaddb17747049f2d||backup-8.30.2019_19-04-11_ccff/homedir/cache/cache_500b979b057366633c678b1fab38c960||backup-8.30.2019_19-04-11_ccff/homedir/cache/cache_85daced7c4de2f5a2c332a7d8a7a3803||backup-8.30.2019_19-04-11_ccff/homedir/.libnet-openssh-perl/||backup-8.30.2019_19-04-11_ccff/homedir/public_html/.htaccess
2019-09-01 14:12:55 Exploring user directory in the backup : ccff
2019-09-01 14:12:55 Successful User Validation ccff
2019-09-01 14:12:55 {"user":"ccff","domain":"HIDDEN_DOMAIN.co.uk","action":"add","pass":"HIDDEN_PASSWORD","email":"no@email.com","package":"3","inode":0,"limit_nproc":40,"limit_nofile":100,"server_ips":"NEW_IP","backup":"ON"}
2019-09-01 14:12:57 {"status":"OK"}
2019-09-01 14:12:57 The account was created
2019-09-01 14:12:57 sed -i 's/$6$Erv5yWrR$Hei7XvkW.FD3yf7wEmA9.fPwFJAVKeK5sUTMOCjSVZqbYKxAWkUBp1agvG/lNWqSw5UffgqqWLB8YgxUJ9ZxO//$6$PEWCu13Nzhq5QpWO$ESBnTyIQC/k5JUT9PI2Z1OJSrFmuic2tGvD1PALMNWl3I8KHOLSHPZcsNoB/v1kvQZep7E6HntYhgUrrdlPDW0/g' /etc/shadow
2019-09-01 14:12:57 rsync -av /home/tmpback/backup-8.30.2019_19-04-11_ccff/dnszones /home/ccff/
2019-09-01 14:12:57 sed -i 's/HIDDEN_OLD_IP/HIDDEN_NEW_IP/g' /home/ccff/dnszones/*.db

4
Updates / New users cannot display websites with V0.9.8.874
« on: August 30, 2019, 08:30:11 PM »
Hi,

After creating a new user on V0.9.8.874, it is only possible to display the default CWP apache page, even after removing index.html.

Try the following in V0.9.8.874:

1. Create new user account for domain name with name servers already pointing at server: Created
2. Install WP in root folder using installer: Installed
3. Goto domain name to look at installation and the default CWP shows. Cannot display WordPress

When I roll back to V0.9.8.873 and repeat the above steps, then I can set the new WordPress install instructions.

There is no index.html only the index.php o the WP install. The VHOST files seems correct (but maybe I have missed something).

I have rolled back my server to .873 for now.

5
Hi,

FILE MANAGER
After today's update the File Manager within the users' control panel is no longer accessible. Clicking on the File Manager button takes you to the log in screen, where logging in again will take you to the log in screen again!

Must be a simple bug.

I like the new ability to log into a user account with one click from the user list in the Admin panel. I guess this must have broken the file manager link.

phpMyAdmin
Access to this from user panel now requires password. On previous user panel version it was possible to access phpMyAdmin without separately logging in.

Stephen

6
Hi,

There doesn't seem to be any way to create a package that contains email forwarding but not email accounts.

Simply setting the number of email accounts allowed to zero also stops the user from creating email forwards. Maybe, there needs to be two separate values to put in package the setup... One for accounts and one for email forwarders?

(By the way... I love CWP I se it improving all the time. Sorry if this topic in wrong category!)

7
With the latest CWP, it is not possible to switch between user account control panels without first logging out of the account that one is leaving before closing the tab.

If one simply closes the browser tab for that control panel and then (via the user account list) select another control panel to log into, it is impossible to log in. (Possibly there is a Cookie or session still open as most browsers nowadays allow you to reopen a recently closed tab.)

Workaround: One can log into the account that one has recently left and then logout before trying to log into another account.

8
CentOS-WebPanel Bugs / cPanel password migration bug
« on: August 02, 2019, 12:50:59 PM »
With the latest release of CWP, there is an issue when migrating cPanels.

The procedure asks for the cPanel password. Upon completion of migration, it is not possible to log into the control panel for the new account. It seems that a ransom password has been set.

Workaround: in the List Users section change the password for the control panel to the correct password and it is then possible to log into the account.

9
CentOS-WebPanel Bugs / Filemanager Cannot upload large files to server
« on: August 02, 2019, 12:39:48 AM »
Hi,
I have just updated today 2 August 2019. I cannot say if it this latest update that has caused the following problem or not.
It is not possible to upload large files to the server using the Filemanager. I have tried logged in as Admin with root access. It is not possible to upload files (around 80MB), using the drag and drop interface of directory selection. Does not work using the Basic File manager either. (Wanting to upload cPanel migration files).

It is also not possible to upload files when logged in as an CWP user.

I have tried with small files (approx 30kB) and this works. The problem seems to be with larger files.

10
Using the PHP.ini editor
The default php.ini file starts will an illegal time zone of Berlin/London.
date.timezone=Berlin/London

This is preventing the "Basic Edition" on the left from working correctly, with only the "Advanced Edition" on the right showing.

If you change the time zone from the illegal value of "Berlin/London" to "Europe/London" and Update, and then refresh the page, you will now see the "Basic Edition" is now functioning correctly.

Where do I find the master value of this incorrect timezone, so that all new accounts work correctly?
(I am using php-fpm)

Thanks,
Stephen

11
Hi,
I have noticed that the WordPress installer passes some some symbol characters (created by the random password generator) incorrectly to the wp-config.php

For example...
This randomly created password: IDlj_I_L>GxX
Appears in the wp-config.php file as: define( 'DB_PASSWORD', 'IDlj_I_L' );

Presumuably, this needs an update to the installer to correct?

Regards,
Stephen

Pages: [1]