Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Jason

Pages: [1] 2 3 4
1
Addons / Re: Team Speak 3 - Manager
« on: June 17, 2019, 12:32:39 PM »
TeamSpeak3 control panel module


We don't support TeamSpeak anymore and we also don't recommend others to use it.
Reason: If you get late with the payment you could get a penalty of $100 or more.


Now you can easily install TeamSpeak3 server with one click in CentOS WebPanel.

TeamSpeak3 control panel Features
- install & delete server (with one click)
- start, stop, restart & check teamspeak3 server status (with one click)
- display query admin login details and token (encrypted data for security)

How to install and start TS3 server?
Check that you do not have ts3 user installed on your linux system as TeamSpeak3 server creates ts3 user and runs server under ts3 username.
1. Click on install TeamSpeak3 server button
2. Click on start TeamSpeak3 server button
3. After you started Team Speak 3 server you can click on Check Admin Data button to get admin login details
*Admin login details are encrypted for security but they are all the time available by clicking on Check Admin Data button.

How to delete TeamSpeak3 server and ts3 user?
1. Click on Stop TeamSpeak 3 server button.
2. Click on Delete Team Speak 3 server button.
*this will delete server files and remove ts3 user from the server.


How to Team Speak3 module to CentOS-WebPanel menu?
Itís easy, go to include folder and make new file named 3rdparty.php ,in this file you add links one per line.
eg.
<a href="index.php?module=ts3_manager">TS3 Manager</a>

Files are included in installations from version 0.2

Pitty, as TS and ShoutCast was the only reasons we where using your CWP software seems useless now with no TS and no shoutcast for us , so we did not renew after losing SSL on main domain with no waring and support would not help with SSL a simple solution , al you need to do is click on host name change to get the new SSL but they want a support fee to do that LOL

2
Starting the shout-cast sever now, gives me this error after working perfectly for months:

You are not the owner of /var/run/screen/S-shoutcast.
Screen shoutcast_8000 not exists

Can any one shine some light on my problem please?

I have un-installed re- installed and sterted over no luck CFS ports are open etc..

3
How to / Re: [Tutorial] How to install SSL on hostname?
« on: June 15, 2019, 12:07:21 AM »
Hello,

I could see that a lot of users are asking "How to install SSL on hostname" and I found a few tutorials some of which are working and others do not. Also, the tutorials which are working are lenghty and not for linux newbie.

So, I will teach you here how to install and configure Letsencrypt Free SSL on hostname in CWP in simple 3 steps.

1 - Check that you should have an A record for the hostname. For example if your server hostname is cp.hostinpk.com, then you should have an A record for "cp" pointing to server IP

2 - Login to CWP Admin Panel>> Server Settings>>Change Hostname and then hit "Change Hostname" button after putting your desired hostname (in my case cp.hostinpk.com). This will only generate a valid LE SSL for your hostname when an A record is present against hostname

3 - Perform following command from shell
Code: [Select]
service cwpsrv reload
THAT's IT. Enjoy the green padlock while accessing the CWP services (admin panel, user panel, webmail, etc..)

Thank You works like a charm :)

4
same problem :(

5
SSL / Re: AutoSSL has expired on domain, can't renew it..
« on: March 15, 2019, 11:48:27 PM »
Hello,

I have an AutoSSL cert on a subdomain that has expired,
I clicked the Renew Now button under SSL Configurations,
The green popup indicated it was successful, but it hasn't renewed the cert.

I am trying to get this cert to auto update when it expires.

Also tried reload and restarting web server.

I ran the commands posted in this thread but not sure if they did anything:
http://forum.centos-webpanel.com/ssl/autorenew-ssl-is-enabled-yet-my-certificates-will-expired-after-6-days/msg12229/#msg12229

Any help appreciated.

Did you ever get this resolved I am facing the same issue?

Deleting the SSL and re adding it gives me DNS of your domain does not point to this server pops up.


6
Addons / Re: WHMCS installing issue
« on: November 26, 2018, 07:34:56 PM »
just to be sure, in you CWP's [API] panel area, did you use a parenthesis? (" % ")  in the "IP Origin" field..

i had the same problem, and i contacted CWP Support, and that fixed it for me.

Hope it helps.


Thank You  ;D it does not log in automatically but at least now, its at the correct login link.
Much appreciated  x1705

7
Addons / Re: WHMCS installing issue
« on: November 18, 2018, 02:01:15 PM »
http://wiki.centos-webpanel.com/whmcs-module-for-cwp-api

1. Extract file cwp7.zip in your whmcs folder
WHMCS/modules/servers/

 Password

This does work to un-suspend, delete, create etc, But the user can not login from WHMCS Billing side.
The link in admin side WHMCS, while looking at users service to open CWP is also wrong.
I use it but users keep asking, "Why can I not log in from my WHMCS billing to my CWP Panel it shows 404?"
It seems an easy fix ?

Greets 

8
CentOS 7 Problems / Re: Clamav + Amavis not auto starting
« on: November 09, 2018, 06:05:04 PM »
This is not a huge issue but when I do a server reboot now (Centos 7 VPS, 2 core, 4gb, 40gb, 4tb) my ClamAV, AMaViS and SpamAssassin do not auto start (little moon "asleep?" icon). They start fine when I click start for them, they are configured correctly but I'm just curious as to why they don't autostart.

Thanks in advance for any insight!

Reviving old post from the dead....

I also have this issue, if I start it like you  do it uses 100% CPU,  I run this after every reboot to fix:

service clamd stop
rm -f /var/run/clamd.amavisd/clamd.sock
service clamd start


9
Updates / Re: Not change CWPpro version?!?
« on: November 08, 2018, 02:37:28 PM »
CWP team is working on a big update and soon 741 version will be released with a fantastic client area theme. Also, there will be many changes (backend) in admin panel. Most probably, it will be released this week.

(I am already testing this new version on my dev installation. It seems to be very professional)

Any News on the update ?

At the time of replying this post, I am testing the latest version of CWP (dev) and its great. I hope that they will release in next week as most of the work seems to be completed.

A great addition is the new web servers section with several templates (with PHP FPM support)

Awesome !! Thank you for the update  :) We cant wait any more lol  ;D

10
Updates / Re: Not change CWPpro version?!?
« on: November 08, 2018, 02:02:01 PM »
CWP team is working on a big update and soon 741 version will be released with a fantastic client area theme. Also, there will be many changes (backend) in admin panel. Most probably, it will be released this week.

(I am already testing this new version on my dev installation. It seems to be very professional)

Any News on the update ?

11
Updates / Re: Last Update - gave root access to all users via ssh
« on: November 06, 2018, 10:34:53 AM »
After the last update all users that access sftp via ssh now have access to root - with read/write capabilities

I did run the fix permissions however - that did not work ( did not change anything )

before the last update they were only able to see there home folder

Hi I just tested this and I could not get ROOT with a normal SSH account.

12
Updates / Re: Not change CWPpro version?!?
« on: November 01, 2018, 05:15:13 PM »
Here are some screenshots of new Client area theme.

http://prntscr.com/ld69z2
http://prntscr.com/ld6ah4
http://prntscr.com/ld6aa5

Thank you for the sneak preview, much appreciated !  8)

13
Updates / Re: Not change CWPpro version?!?
« on: November 01, 2018, 01:05:45 AM »
CWP team is working on a big update and soon 741 version will be released with a fantastic client area theme. Also, there will be many changes (backend) in admin panel. Most probably, it will be released this week.

(I am already testing this new version on my dev installation. It seems to be very professional)

Do you have any news about release date of update?

Yes please or any screen shots , I am very excited :)

14
MySQL / Re: Yum Manager and # yum update failing to update Maria SQL
« on: October 30, 2018, 12:30:53 AM »
That's weird.
It will be investigated.

Thank you kind support.

15
MySQL / Yum Manager and # yum update failing to update Maria SQL
« on: October 29, 2018, 05:35:35 AM »
Hi When I use Yum Manager in pro version it does not update the latest MariaDB-server.x86_64

Also if I run *Yum update in SSH, I get this error :

error: %pre(MariaDB-server-10.2.18-1.el7.centos.x86_64) scriptlet failed, exit status 1
Error in PREIN scriptlet in rpm package MariaDB-server-10.2.18-1.el7.centos.x86_64
MariaDB-server-10.1.36-1.el7.centos.x86_64 was supposed to be removed but is not!
  Verifying  : MariaDB-server-10.1.36-1.el7.centos.x86_64                   1/2
  Verifying  : MariaDB-server-10.2.18-1.el7.centos.x86_64                   2/2

Failed:
  MariaDB-server.x86_64 0:10.1.36-1.el7.centos
  MariaDB-server.x86_64 0:10.2.18-1.el7.centos

Complete!

Is anyone else having this issue?

Greets


Pages: [1] 2 3 4