Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - amqshaker

Pages: [1]
1
(Solution)- worked for me

I dont know anything about linux. I search and try every solution to see if its working or not.

Last year, I used my own computer to host CWP webserver. Now, I just bought a VPS server and same old auto SSL problem hunted me- DNS not pointing to your server...

This time I tried everything I learned last year but noting worked. Then..

I found the solution. This time- My hosting company using some kind of proxy. So even though my DNS setting was right and name-server was pointing to correct public IP, I was not getting the auto SSL. So, I activated NAT-ed mode using my private IP from CWP settings. Man that was it, main domain got the SSL.

For hostname SSL, I then went to Server Settings -> Change Hostname. Then Hit Enter (my host-name was correct so didn't change anything). After, I cleared my browser cache and logged in my hosting server via SSL url.


2
01. A) From Domains -> List Domains. Delete the Affected Domain.
    B) Only if, List Domains is empty  then- Go to User Accounts -> List Accounts. Delete the user account with the Affected Domain.

02. Go To Server Settings -> Change Hostname. Click change Hostname (Keep all settings same).

03. Adjust the file from /etc/hosts:

    nano /etc/hosts

    **Make the values like this[Change here]:     
     
127.0.0.1   localhost localhost.localdomain localhost4 localhost4.localdomain4
[your server local ip]   example1.example.com     example1
::1         localhost localhost.localdomain localhost6 localhost6.localdomain6
     

04. If you followed option A before. From Domains -> Add Domain. Add the Affected Domain name now.
    Only if, you followed option B before. User Accounts -> List Account. Add new user account with the Affected Domain name.

05. Go To DNS Functions ->  List DNS Zones ->  (Affected Domain) Click Rebuild Zone.

06. Again Go To DNS Functions ->  List DNS Zones ->  (Affected Domain) -> Edit Files. Now- Firstly, Delete line start with- www (it has a cname record). Secondly, Paste these three lines below in the middle of the file-

   ns1         14400   IN      A       (Public IP)
   ns2         14400   IN      A       (Public IP)
   www         14400   IN      A       (Public IP)

07. Go to Webserver Settings -> SSL Certificates -> Auto SSL. Install SSL for the Domain.

3
01. A) From Domains -> List Domains. Delete the Affected Domain.
    B) Only if, List Domains is empty then- Go to User Accounts -> List Accounts. Delete the user account with the Affected Domain.

02. Go To Server Settings -> Change Hostname. Click change Hostname (Keep all settings same).

03. Adjust the file from /etc/hosts:

    nano /etc/hosts

    **Make the values like this[Change here]:     
     
127.0.0.1   localhost localhost.localdomain localhost4 localhost4.localdomain4
[your server local ip]   example1.example.com     example1
::1         localhost localhost.localdomain localhost6 localhost6.localdomain6
     

04. If you followed option A before. From Domains -> Add Domain. Add the Affected Domain name now.
    Only if, you followed option B before. User Accounts -> List Account. Add a new user account with the Affected Domain name.

05. Go To DNS Functions ->  List DNS Zones ->  (Affected Domain) Click Rebuild Zone.

06. Again Go To DNS Functions ->  List DNS Zones ->  (Affected Domain) -> Edit Files. Now- Firstly, Delete line start with- www (it has a cname record). Secondly, Paste these three lines below in the middle of the file-

   ns1         14400   IN      A       (Public IP)
   ns2         14400   IN      A       (Public IP)
   www         14400   IN      A       (Public IP)

07. Go to Webserver Settings -> SSL Certificates -> Auto SSL. Install SSL for the Domain.

4
01. A) From Domains -> List Domains. Delete the Affected Domain.
    B) Only if, List Domains is empty  then- Go to User Accounts -> List Accounts. Delete the user account with the Affected Domain.

02. Go To Server Settings -> Change Hostname. Click change Hostname (Keep all settings same).

03. If you followed option A before. From Domains -> Add Domain. Add the Affected Domain name now.
    Only if, you followed option B before. User Accounts -> List Account. Add new user account with the Affected Domain name.


04. Go To DNS Functions ->  List DNS Zones ->  (Affected Domain) Click Rebuild Zone.

05. Again Go To DNS Functions ->  List DNS Zones ->  (Affected Domain) -> Edit Files. Now- Firstly, Delete line start with- www (it has a cname record). Secondly, Paste these three lines below in the middle of the file-

ns1         14400   IN      A       (Public IP)
ns2         14400   IN      A       (Public IP)
www         14400   IN      A      (Public IP)

06. Go to Webserver Settings -> SSL Certificates -> Auto SSL. Install SSL for the Domain.

5
01. A) From Domains -> List Domains. Delete the Affected Domain.
    B) Only if, List Domains is empty  then- Go to User Accounts -> List Accounts. Delete the user account with the Affected Domain.

02. Go To Server Settings -> Change Hostname. Click change Hostname (Keep all settings same).

03. If you followed option A before. From Domains -> Add Domain. Add the Affected Domain name now.
    Only if, you followed option B before. User Accounts -> List Account. Add new user account with the Affected Domain name.


04. Go To DNS Functions ->  List DNS Zones ->  (Affected Domain) Click Rebuild Zone.

05. Again Go To DNS Functions ->  List DNS Zones ->  (Affected Domain) -> Edit Files. Now- Firstly, Delete line start with- www (it has a cname record). Secondly, Paste these three lines below in the middle of the file-

ns1         14400   IN      A       (Public IP)
ns2         14400   IN      A       (Public IP)
www         14400   IN      A      (Public IP)

06. Go to Webserver Settings -> SSL Certificates -> Auto SSL. Install SSL for the Domain.

6
I have tried - https://forum.centos-webpanel.com/ssl/let's-encrypt-autossl-solved/   also  http://forum.centos-webpanel.com/ssl/ssl-expire/msg19631/#msg19631  and also http://forum.centos-webpanel.com/ssl/dns-of-your-domain-doesn't-point-to-this-server-or-you-have-htaccess-5490/msg19395/#msg19395   nothing worked. Here is how I solved my new user account which was not getting SSL.

01. Go To DNS Functions ->  List DNS Zones ->  (Affected Domain) Click Delete Zone.

02. From User Account -> New Account. Create a new User account (Using the Affected Domain and public IP address).

03. Again Go To DNS Functions ->  List DNS Zones ->  (Main Domain) Click Rebuild Zone.

04. Go To DNS Functions ->  List DNS Zones ->  (Main Domain) -> Edit Files. Now- Firstly, Delete line start with- www (it has a cname record). Secondly, paste these three lines below in the middle of the file-

ns1         14400   IN      A       (Public IP)
ns2         14400   IN      A       (Public IP)
www         14400   IN      A      (Public IP)

05. Go to Webserver Settings -> SSL Certificates -> Auto SSL. Install SSL for the Domain.

7
MySQL / Mysql Package Exhausted
« on: March 31, 2018, 04:40:58 AM »
Apache: Apache/2.4.29
PHP: 7.2.1
MySQL: 10.1.31-MariaDB

Hello everyone,
From standard user account, i am unable to create any new database/user. it always says this- Mysql Package Exhausted!

Pages: [1]