Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - vbpal

Pages: [1] 2
1
 >:(

it seems that the latest cwp 9.8.940 won't let me create any auotsll certs. can we get an eta on when this will be fixed.  same error as above.

2
Addons / Re: Free billing system for CWP Septemeber 2019???
« on: January 31, 2020, 02:05:10 PM »
Any thoughts on using WooCommerce with CWP for billing. I wonder if it's worth writing a plugin for it.

3
CentOS-WebPanel Bugs / Re: Default page changed to index.html on all sites!
« on: November 22, 2019, 04:09:53 AM »
I experienced this issue this afternoon with a select number of domains on 1 account. I don't see the issue on other accounts. Has anyone identified a root cause?

4
CentOS-WebPanel Bugs / Re: DNS Template overridden?
« on: October 26, 2019, 08:12:42 PM »

5
CentOS-WebPanel Bugs / DNS Template overridden?
« on: October 26, 2019, 01:37:27 PM »
Hi,

I noticed that even when I change the DNS template file located in: /usr/local/cwpsrv/htdocs/resources/conf/dns/bind/zones/default.tpl , every time there's a CWP update, this file gets replaced by the original default values.

Does anyone know how to prevent this or stop it?  Thanks.

6
SSL / Re: CWP support for TLSv1.3
« on: October 23, 2019, 03:16:01 AM »
Hi Louis,

Do you have a set of instructions I can follow to recompile everything?

I'm assuming it would be:

recompile openssl
recompile apache
recompile php (I'm not currently using nginx)

Thanks.

7
CentOS-WebPanel Bugs / User-Panel Subdomain Uppercase vs lowercase
« on: October 06, 2019, 12:21:36 AM »
Has anyone experienced an issue with creating a subdomain with using an uppercase subdomain vs lowercase on: CWPpro version: 0.9.8.899

If you use an uppercase subdomain an error occurs but with a lowercase subdomain it proceeds to create the subdomain.

Thanks

8
DNS / Re: Slave DNS Manager
« on: August 02, 2019, 07:43:12 PM »
Any word on the directions above?

Also:

I've installed the slave manager and server on the slave host but came across a few problems:

1) The php version cannot be changed to anything above 5.6 since the files were encoded for ioncube 5.6

2) When I tried to login with the username root and the default password published, it just says access denied. There's nothing in the error logs or access logs indicating an error such as a db error or mis-configuration.

Any ideas on how to fix this?

9
DNS / Re: Slave DNS Manager
« on: July 23, 2019, 01:08:49 AM »
Hi,

I'm reading the instructions on: http://wiki.centos-webpanel.com/slave-dns-server-manager-download-version and where it says: Slave DNS Server & Manager, are all the steps suppose to be done on the slave server such as downloading and installing the manager into the public folder as well as the creation of the account?

10
Suggestions / Re: Custom API
« on: July 10, 2019, 04:49:24 PM »
Any word on DNS via API?

11
CentOS 7 Problems / Logrotate for access_log and modsec_audit.log
« on: July 06, 2019, 01:16:44 PM »
Hi all,

I've encountered an interesting problem. I'm using the latest CWPro on CentOs 7 64bit. My logrotate for apache logs are configured as: 

/usr/local/apache/domlogs/*.log /usr/local/apache/logs/*log{
        daily
        missingok
        rotate 15
        compress
        delaycompress
        notifempty
        sharedscripts
        dateext
        postrotate
                service httpd restart > /dev/null
        endscript
}

I've noticed that everything within the directory /usr/local/apache/domlogs/*.log has been properly rotated, however

The files:

-rw-r--r--. 1 root   root    12072873 Jul  6 06:20 error_log
-rw-r-----  1 root   root   135950722 Jul  6 08:33 modsec_audit.log
-rw-r--r--. 1 root   root    17917588 Jul  6 08:45 access_log

Have not been rotated. I did a test run using logrotate -d -f and it shows it would have rotated AND logrotate status shows:

"/usr/local/apache/logs/modsec_audit.log" 2019-7-6-8:10:21 so in theory this is all correct. I also checked permissions which seem appropriate.

Any ideas on why this is happening only for the logs in /usr/local/apache/logs?

12
Thank you for your response. I ended up having to clear the web-browser cache and close all windows. This resolved the issue.

Would it be possible in the future to have an updated change-log with any notes on things such as this so that admin's such as myself don't get a surprise panic? Thanks again for the hard work and wonderful control panel.

13
CentOS-WebPanel Bugs / Major bug in admin panel in CWPro 0.9.8.837
« on: June 30, 2019, 03:07:55 AM »
My control panel was just auto-upgraded to CWPro 0.9.8.837 and now when I log into the control panel (admin site only, not client), after a few seconds I get the message "Invalid Session!" in the top 5 processes box and any link that is clicked on immediately kicks you out of your session. Is anyone else having this issue?

 >:(

14
DNS / Re: DNS Slave
« on: June 20, 2019, 02:42:24 PM »
I see the DNS slave option however I don't see documentation on it. What's the api/key pass that we put in? Is this for another CWP or CWPro setup? It's not clear.

15
Suggestions / Re: Why is this project closed source?
« on: June 14, 2019, 02:50:44 PM »
The url: https://docs.control-webpanel.com/docs/developer-tools/ is very helpful however, how do i add menu items cleanly into the menu, is there a specific way to do this without losing them in a new build of cwppro?

Is this all done via a clone of the theme?

Pages: [1] 2