Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - bellafronte

Pages: [1] 2
1
Mod_Security / Re: Crontab not working after installing Mod Security
« on: January 22, 2020, 06:14:15 PM »
if you Uninstall Mod Security your cron work again?

2
DNS / Re: Slave DNS Server & Manager - doesnt work
« on: January 19, 2020, 02:41:09 AM »
Same problem here, you find a solution for this?

3
Information / Re: Empty user list
« on: January 17, 2020, 07:33:08 PM »
The problem is in js.php we are discussing this here http://forum.centos-webpanel.com/index.php?topic=8116.0

Maybe an ETA to fix this huge issue will be appreciated.


4
Information / Re: Empty user list
« on: January 17, 2020, 03:16:24 PM »
You are running what version of CWP?

6
Updates / Re: js.php 500 error after upgrade to 0.9.8.928
« on: January 17, 2020, 02:23:28 PM »
Panel is useless in this version. Do NOT UPGRADE TO THIS VERSION

7
Updates / js.php 500 error after upgrade to 0.9.8.928
« on: January 17, 2020, 01:46:03 PM »
All my servers using CWP version 0.9.8.928 presents a 500 error in js.php making all functionalities of web panel that depends on this PHP+javascipt stop working,


8
Updates / Re: CWPpro version: 0.9.8.928
« on: January 17, 2020, 01:26:53 PM »
This should be reported through the change log. We can't be blind to every update.

I have already written to the support team several times, but they don't seem to pay much attention.

It really is a big problem, the current version (0.9.8.928) has the panel completely bugged.

Usually I don't have problems, but there are some bugs that take me seriously and it's very annoying.

After upgrade to this version all javascript dependencies on CWP panel not work anymore.


9
Dovecot / Re: Mail Quota
« on: January 16, 2020, 04:56:31 AM »
No email quotas until now?

10
How to / Re: Cron job works from command line but not in cron
« on: January 13, 2020, 03:02:18 AM »
Finally I resolved my issue recreating the accounts, cron works fine before that.

11
How to / Re: Cron job works from command line but not in cron
« on: January 13, 2020, 02:02:29 AM »
Cron is available to run periodic jobs; cron daemon reads the contents of crontabs every minute and passes appropriate commands to the task queue. The intention is not to run jobs at one minute intervals: you run scripts/processes to do that. Anacron is a variation of cron.

Syntax error:
Code: [Select]
* * * * * tetra /usr/local/bin/php /home/tetra/help/public_html/api/cron.php
* * * * * nobody /usr/local/bin/php /home/tetra/help/public_html/api/cron.php

Code: [Select]
crontab -u tetra -e
Code: [Select]
*/5 * * * * /usr/local/bin/php -f /home/tetra/help/public_html/api/cron.php(5min interval & -f may be optional with CentOS)

Quote
755
- appropriate for directories, not files - try 600 or 644 (less secure)

This is basic *nix stuff.
(UNIX System V R4.2 NCR trained circa 1992 - numerous *nix flavours since.)

Thanks ejsolutions for the great explanation!  :)

12
How to / Re: Cron job works from command line but not in cron
« on: January 13, 2020, 01:58:17 AM »
Hello,

The following works for me from the command line:

/usr/local/bin/php /home/tetra/help/public_html/api/cron.php

However, I've tried the following cron jobs and none of them have produced any results:

* * * * * tetra /usr/local/bin/php /home/tetra/help/public_html/api/cron.php
* * * * * nobody /usr/local/bin/php /home/tetra/help/public_html/api/cron.php
* * * * * /usr/local/bin/php /home/tetra/help/public_html/api/cron.php
* * * * * /opt/alt/php-fpm70/usr/bin/php /home/tetra/help/public_html/api/cron.php

The permissions for that file are 755. I've checked my cron logs, and I'm not 100% sure it is being run at all, but honestly I do not know how to identify for sure. This is for the past hour and I've had 1 minute crons in this queue for over an hour and this is the only output from tail (I wasn't able to do this as the user, I had to do it as root):

Code: [Select]
Jul 22 14:10:01 server3 CROND[24716]: (root) CMD (/usr/lib64/sa/sa1 1 1)
Jul 22 14:20:01 server3 CROND[25605]: (root) CMD (/usr/lib64/sa/sa1 1 1)
Jul 22 14:30:01 server3 CROND[28042]: (root) CMD (/usr/lib64/sa/sa1 1 1)
Jul 22 14:40:01 server3 CROND[21551]: (root) CMD (/usr/lib64/sa/sa1 1 1)
Jul 22 14:50:01 server3 CROND[7167]: (root) CMD (/usr/lib64/sa/sa1 1 1)
Jul 22 15:00:01 server3 CROND[4888]: (root) CMD (/usr/share/clamav/freshclam-sleep)
Jul 22 15:00:01 server3 CROND[4889]: (root) CMD (/usr/lib64/sa/sa1 1 1)
Jul 22 15:01:01 server3 CROND[4969]: (root) CMD (run-parts /etc/cron.hourly)
Jul 22 15:01:01 server3 run-parts(/etc/cron.hourly)[4969]: starting 0anacron
Jul 22 15:01:01 server3 run-parts(/etc/cron.hourly)[4978]: finished 0anacron
Jul 22 15:10:01 server3 CROND[6247]: (root) CMD (/usr/lib64/sa/sa1 1 1)
Jul 22 15:20:01 server3 CROND[6985]: (root) CMD (/usr/lib64/sa/sa1 1 1)
Jul 22 15:30:01 server3 CROND[7756]: (root) CMD (/usr/lib64/sa/sa1 1 1)
Jul 22 15:40:01 server3 CROND[10443]: (root) CMD (/usr/lib64/sa/sa1 1 1)
Jul 22 15:50:02 server3 CROND[14263]: (root) CMD (/usr/lib64/sa/sa1 1 1)
Jul 22 16:00:01 server3 CROND[15617]: (root) CMD (/usr/lib64/sa/sa1 1 1)
Jul 22 16:01:01 server3 CROND[15689]: (root) CMD (run-parts /etc/cron.hourly)
Jul 22 16:01:01 server3 run-parts(/etc/cron.hourly)[15689]: starting 0anacron
Jul 22 16:01:01 server3 run-parts(/etc/cron.hourly)[15698]: finished 0anacron
Jul 22 16:10:01 server3 CROND[16183]: (root) CMD (/usr/lib64/sa/sa1 1 1)

@bentsea I made several tests and figure out that accounts that I have migrated from cPanel (using the restore cP account available on CWP GUI) for some reason cron not work at all. if I create an account in CWP cron works perfectly.

Maybe this looks stupid but works for me  ???

is the cron issue occurring on a migrated cpanel account?

13
Hello folks,

I came across a very strange and dangerous situation that gave me a huge scare. I enabled shell access with jailkit for an account and after this, all files under /home/user are gone (literally all, lost disappears  :o ).

I do not believe in what happened and try to make the same to another user: files have gone too. Save by backup

I running the latest version of CWP 7 and CentOS 7, someone sees this happens? A lookup to logs or messages but I can't find anything  :'(

14
How to / Re: Cron job works from command line but not in cron
« on: January 12, 2020, 08:17:43 PM »
One minute crons!  ::)
Ask your trained sysadmin to help.

What is the relation about 1-minute crons and cron does not work? I believe that you are a trained sysadmin that does not have any problem to share acknowledgment, right?  ;)

15
Other / Re: Cron Jobs: For WordPress & Invoice Ninja
« on: January 12, 2020, 05:31:49 PM »
You still have this issue?

Pages: [1] 2