Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Bashed

Pages: [1] 2
1
CentOS-WebPanel GUI / Can't Switch to Dark Theme?
« on: June 21, 2018, 07:03:15 PM »
I chose dark theme, even rebooted and logged out and back in. Still on default theme.


2
CentOS 7 Problems / IPs not pinging
« on: May 13, 2017, 07:29:40 PM »
Can't get a /26 pinging from the server with Centos 7. Cisco switch setting is fine for this particular VLAN.

Code: [Select]
interface Vlan16
 description Server 16
 ip address xxx.xxx.99.129 255.255.255.192
end

I modified the network script to below, restarted networking and even rebooted server. Can't pinging anything except gateway and 130 main IP.

Code: [Select]
TYPE=Ethernet
BOOTPROTO=static
DEFROUTE=yes
IPV4_FAILURE_FATAL=no
NAME=em1
UUID=xxx.xxx
DEVICE=em1
ONBOOT=yes
IPADDR=xxx.xxx.99.130
PREFIX=26
GATEWAY=xxx.xxx.99.129
DNS1=8.8.8.8
DNS2=8.8.4.4

3
Installation / Migration from Interworx
« on: January 06, 2016, 12:39:44 AM »
Is there a way to migrate over from Interworx to CWP?

4
CentOS-WebPanel GUI / Re: CWP won't start up after reboot
« on: October 18, 2015, 12:58:33 AM »
Ok fixed the issue, but prior I did uninstall CSf via command line.

After fixing the networking issue, I reinstalled CFS via ssh.

But, even though it's up and functioning CWP still shows firewall as "off" in admin panel.

I restarted csf via CWP and it shows

csf and lfd are not disabled!

How can I fix this?

5
CentOS-WebPanel GUI / Re: CWP won't start up after reboot
« on: October 17, 2015, 07:49:45 PM »
Tried to run update_cwp and got these errors..



I also ran service iptables stop, nothing.

6
CentOS-WebPanel GUI / CWP won't start up after reboot
« on: October 17, 2015, 07:39:52 PM »
I can't get CWP started up after rebooting the vps. Been working fine for couple months. 2030,2031 is already enabled in CSF. I'm in the vps via the VNC.


7
Suggestions / Re: Few Suggestions
« on: September 03, 2015, 10:06:33 PM »
Anyone? :)

8
Suggestions / Few Suggestions
« on: August 14, 2015, 11:30:47 PM »
Theme. Make it beautiful. Use bootstrap. It's free. Kill the sluggish theme (and menu) that everyone has complained about.

Support:
Attracta SEO
Cloudflare CDN

Updates:
Apache / PHP config similar to Easy Apache. That would be really awesome.

Thanks.

9
PHP / Re: sh: zip: command not found
« on: July 06, 2015, 09:28:19 PM »
Really need help here please.

This is what the script developer said about the particular WP plugin:

Quote
Please note the following major requirements of WP Twin:
- system() and exec() PHP functions should be allowed to run on the server.
- zip, unzip, mysql, mysqldump, grep, and sed have to be available commands on the server.
- The UID that scripts run under has to have rights to write files. (We have a test file that can confirm the UID and the commands above)
- The mySQL database user has to have FULL rights to the database.

The thing is, disable_functions in php.ini is blank anyway.

I ran a test file they gave me:

Results.


WPTwin Test File

UID:

cURL: cURL is installed

ZIP and MYSQLDUMP:
MySql Dump Path:
MySql Path:
zip Path:
unzip Path:
grep Path:
sed Path:

Notice: Undefined index: t in /home/---/public_html/wptwintest.php on line 39

10
PHP / Re: sh: zip: command not found
« on: July 06, 2015, 12:05:45 AM »
Didn't work unfortunately.

It's not my software to modify it's path internally too, it's obfuscated. So I cannot edit it's own files like that unfortunately.


I ran

ln -s /usr/bin/zip /usr/sbin/zip

Back to

[Sun Jul 05 18:58:19 2015] [error] [client xxx.xxx.23.22] sh: zip: command not found


My simple goal here:
I need to be able to call the command zip from within a PHP script without having to use the direct path /usr/bin/zip because it's out of my control to edit every single plugin needing zip access and modify their path.

11
PHP / Re: sh: zip: command not found
« on: July 05, 2015, 07:03:13 PM »
I changed "zip" to "/usr/bin/zip" and the out come was:

Code: [Select]
string(42) "updating: domains/xxxxxx.co/ (stored 0%)"
Now, how do I do change this in the VPS so that path is always defined and able to be called by any script without having to manually define the full path?

I want to add /usr/bin/zip to the executable path for the web server.

I've tried:

Code: [Select]
export PATH=$PATH:/usr/bin/zipAND

Code: [Select]
cd /usr/bin
Code: [Select]
sudo ln -s /usr/bin/zip zip
but neither helped

12
PHP / Re: sh: zip: command not found
« on: July 05, 2015, 12:04:48 AM »
if you are using php selector then you need to check the php version which you are using for zip extension

Confused what you mean. It's already set to 5.4 PHP and zip is already compiled.  I included that output in my previous post.

 You are running PHP version: 5.4.27

Installed dependencies first too.

These are the flags which I already compiled.

Code: [Select]
./configure
--prefix=/opt/alt/php54/usr
--with-zlib
--enable-soap
--enable-exif
--with-config-file-path=/opt/alt/php54/usr/php
--with-config-file-scan-dir=/opt/alt/php54/usr/php/php.d
--enable-phar
--enable-bcmath
--enable-calendar
--with-curl
--with-iconv
--with-mysql
--with-mysqli
--with-mysql=mysqlnd
--with-mysqli=mysqlnd
--with-mcrypt
--with-gettext
--with-xsl
--with-xmlrpc
--with-pdo-mysql=mysqlnd
--enable-posix
--enable-ftp
--with-openssl
--enable-mbstring
--with-jpeg-dir=/usr
--with-freetype-dir=/usr
--with-kerberos
--with-xsl
--with-bz2
--enable-sockets
--enable-zip
--with-gd
--with-imap
--with-imap-ssl
--enable-sockets
--with-pcre-regex
--libdir=/usr/lib64
--with-mysql-sock=/var/lib/mysql/mysql.sock

Output of phpinfo.php ends up being

string(0) ""

13
PHP / Re: sh: zip: command not found
« on: July 04, 2015, 10:43:06 PM »
[root@server ~]# yum install zip
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: mirror.atlanticmetro.net
 * extras: mirror.trouble-free.net
 * rpmforge: repoforge.mirror.constant.com
 * updates: mirror.cogentco.com
Setting up Install Process
Package zip-3.0-1.el6.x86_64 already installed and latest version
Nothing to do


[root@server ~]# php -m
[PHP Modules]
bcmath
bz2
calendar
Core
ctype
curl
date
dom
ereg
exif
fileinfo
filter
ftp
gd
gettext
hash
iconv
ionCube Loader
json
libxml
mbstring
mcrypt
mysql
mysqli
mysqlnd
openssl
pcre
PDO
pdo_mysql
pdo_sqlite
Phar
posix
Reflection
session
SimpleXML
soap
sockets
SPL
sqlite3
standard
tokenizer
xml
xmlreader
xmlrpc
xmlwriter
xsl
zip
zlib



14
PHP / Re: sh: zip: command not found
« on: July 04, 2015, 10:40:08 PM »
This is not related to the plugin apparently.

I tried a phpinfo.php file using only the following code:

Code: [Select]
<?php
var_dump
exec('zip -r domains.zip "domains"') );
// phpinfo();
?>

The php error log is now: [Sat Jul 04 17:44:27 2015] [error] [client xxx.xxx.xxx.xxx] sh: zip: command not found

15
PHP / sh: zip: command not found
« on: July 04, 2015, 08:56:01 PM »
Trying to run a Wordpress plugin, getting this in log file

How do I correct this? It appears zip module is already installed as a dependency by default.

Pages: [1] 2