Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - cynique

Pages: 1 [2] 3 4 ... 7
16
CentOS 7 Problems / Re: PHP version Switcher not working
« on: July 29, 2020, 11:53:37 AM »
CWP version: 0.9.8.998 (free)
PHP version: 7.4.8

Check your disc space.

This has allowed me to discover a lot of crap left over in  /usr/local/src ! Devs take note.
Quote
acme.sh          imagick-3.1.2.tgz  ioncube                           ioncube_loaders_lin_x86-64.zip.5  modsecurity-2.9.1         redis-5.3.1
apcu-5.1.12      imagick-3.4.4      ioncube_loaders_lin_x86-64.zip    ioncube_loaders_lin_x86-64.zip.6  modsecurity-2.9.1.tar.gz  redis.tgz
apcu-5.1.12.tgz  imagick-3.4.4.tgz  ioncube_loaders_lin_x86-64.zip.1  ioncube_loaders_lin_x86-64.zip.7  package.xml               xcache-3.2.0
build            install.sh         ioncube_loaders_lin_x86-64.zip.2  ioncube_loaders_lin_x86-64.zip.8  pcre2-10.34               xcache-3.2.0.tar.gz
cwp-el7-latest   intl-3.0.0         ioncube_loaders_lin_x86-64.zip.3  mcrypt-1.0.1                      pcre2.zip                 zendopcache-7.0.5
imagick-3.1.2    intl-3.0.0.tgz     ioncube_loaders_lin_x86-64.zip.4  mcrypt-1.0.1.tgz                  php_switch_pre.conf       zendopcache-7.0.5.tgz

17
CentOS 7 Problems / Re: PHP version Switcher not working
« on: July 29, 2020, 11:33:06 AM »
I am using PHP Switcher. It is not updated from PHP 7.2.27 to PHP 7.2.29.

Is PHP 7.4 only available in the pro version?
I'm running stable release CWP (highly advisable as devs breaks things on a whim!) and 7.4.8 is the latest available in Pro and free versions.

18
CentOS 7 Problems / Re: Resource usage issues
« on: July 29, 2020, 11:18:03 AM »
That file has examples and if you care to compare it with your cPanel installation, you'll also have examples.   ::)

Code: [Select]
user:postfix
exe:/usr/libexec/postfix/tlsmgr
exe:/usr/libexec/postfix/qmgr
exe:/usr/libexec/postfix/pickup
exe:/usr/libexec/postfix/smtpd
exe:/usr/libexec/postfix/smtp
exe:/usr/libexec/postfix/bounce
exe:/usr/libexec/postfix/scache
exe:/usr/libexec/postfix/anvil
exe:/usr/libexec/postfix/cleanup
exe:/usr/libexec/postfix/proxymap
exe:/usr/libexec/postfix/trivial-rewrite
exe:/usr/libexec/postfix/local
exe:/usr/libexec/postfix/pipe
exe:/usr/libexec/postfix/spawn

Your incomplete post doesn't detail the command line being executed, so unable to be more precise. If you can't figure it out then perhaps a sysadmin needs to be employed.

19
CentOS 7 Problems / Re: PHP version Switcher not working
« on: July 29, 2020, 11:12:39 AM »
So you're not using PHP Switcher? 7.4.8 is the latest in my CWP Pro list!

20
CentOS 7 Problems / Re: PHP version Switcher not working
« on: July 29, 2020, 10:32:12 AM »
Code: [Select]
yum clean all
yum -y install ccache
Then run PHP switcher again.

For completeness PHP 7.2.29 is now also installing fine.
BTW, don't arbitrarily choose versions, take one from the CWP dropdown list - you're only compounding/complicating the issue.

21
CentOS 7 Problems / Re: PHP version Switcher not working
« on: July 29, 2020, 10:21:46 AM »
Quote
tar: php-7.2.32.tar.gz: Cannot open: No such file or directory
There's your clue! Likely you have a network connectivity issue (or a repo problem): I've just tried upgrading 7.3.19 to 7.3.20 and it's running fine, as I type.
I install ccache, for quicker compiles..  resulting in
PHP version: 7.3.20

22
CentOS 7 Problems / Re: Resource usage issues
« on: July 29, 2020, 09:28:06 AM »
You work in education but seemingly unable to read & digest!
WHM/cPanel masks those very same process warnings by having pre-configured ignores. If you don't believe me - go and look for yourself. You have already been given the answer - edit csf.pignore. (This could have been done in the now removed official CSF GUI.)
It ain't difficult and you don't need a Degree to suss it out. :-\

23
Suggestions / Re: Geoip block
« on: July 29, 2020, 09:21:52 AM »
It is included within CSF but CWP removed the official GUI in favour of their own custom cut-down one, for some crazy reason.
Easy to add on the command line, if you care to read the CSF documentation.

24
Quote
There may be trouble ahead..

25
CSF Firewall / Re: My firewall is off and i can't turn it on
« on: July 26, 2020, 06:43:50 PM »
If you have a dynamic IP address at your client machine (home PC/laptop) then sign up for a dynamic IP service (ex. no-ip.org). Add this new FQDN to /etc/csf/csf.dyndns. Then set CSF DYNDNS_IGNORE=1 and DYNDNS_INTERVAL=600 - you'll not get locked out again.

A reboot is normal, when (re)installing a firewall due to the low-level interaction with the kernel and iptables.

26
SSL / Re: Host SSL erorr, cant create auto SSL on host
« on: July 26, 2020, 10:48:51 AM »
Had a mismatch in host certificate.
Re-saved host, deleted auto ssl, created new but did not help. Tried few times and now get an error:

- host......lv
Error Message: [Sun Jul 26 10:55:54 EEST 2020] Single domain='host.al.......lv' [Sun Jul 26 10:55:54 EEST 2020] Getting domain auth token for each domain [Sun Jul 26 10:55:55 EEST 2020] Create new order error. Le_OrderFinalize not found. { "type": "urn:ietf:params:acme:error:rateLimited", "detail": "Error creating new order :: too many certificates already issued for exact set of domains: host.......lv: see https://letsencrypt.org/docs/rate-limits/", "status": 429 } [Sun Jul 26 10:55:55 EEST 2020] Please check log file for more details: /root/.acme.sh/acme.sh.log

So now I dont have the ssl on the domain, cant create it.

I get on domain -  No Intermediate/Chain certificate were found.

Help please, how to resolve this?
Try to actually read the error message, and wait.

28
CentOS-WebPanel Bugs / cron_autossl_all_domains.php
« on: July 22, 2020, 09:59:49 PM »
Quote
CREATION FAILEDS: 0
CREATEDS: 0
RENEWAL FAILEDS: 0
RENEWEDS: 0
LMFTFY

CREATION FAILURES: 0
CREATED: 0
RENEWAL FAILURES: 0
RENEWALS: 0

29
DNS / Re: Setup rDNS on a standalone physical server
« on: July 21, 2020, 11:25:30 PM »
"rDNS/PTR record check: SUCCESS
rDNS/PTR = ; <<>> DiG 9.11.4-P2-RedHat-9.11.4-16.P2.el7_8.6 <<>> -x +short @8.8.8.8;; global options: +cmd;; Got answer:;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 12280;; flags: qr rd ra ad; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 1;; OPT PSEUDOSECTION:; EDNS: version: 0, flags:; udp: 512;; QUESTION SECTION:;+short.in-addr.arpa. IN PTR;; AUTHORITY SECTION:in-addr.arpa. 2508 IN SOA b.in-addr-servers.arpa. nstld.iana.org. 2020071869 1800 900 604800 3600;; Query time: 174 msec;; SERVER: 8.8.8.8#53(8.8.8.8);; WHEN: Sun Jul 19 23:22:51 PKT 2020;; MSG SIZE rcvd: 116
rDNS A record = [Check SenderBase] [Check RBL]

.. it says that rDNS/PTR is successful.

I don't understand where am I going wrong. Help would be much appreciated.
You need to read a bit more?
Try asking your Google about NXDOMAIN?

30
DNS / Re: Setup rDNS on a standalone physical server
« on: July 21, 2020, 06:02:37 PM »
Like too many people: the rules/advice don't apply to them!
"unfortunately everyone's talking about asking your hosting provider to set it up for you."

Pages: 1 [2] 3 4 ... 7