Author Topic: Wrong Hostname? SSL Issue  (Read 885 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
Wrong Hostname? SSL Issue
« on: December 27, 2020, 08:24:45 PM »
Hello,

I've had issues with installing CWP. I created a thread already in the installation section. I have been successful though and fixed the main installation issues! It turned out that i had forgotten to change my hostname on Vulters end and the DNS on their systems. I have been able to transfer all my sites over and get proper SSLs installed!

However, on my CWP panels (admin and user, as well as mall and ftp) I seem to have a non-secure connection as the SSL is connected to the old Hostname. I did reinstall CWP with the new hostname and even entered that into the control panel (Server Settings > Change Hostname) and via. SSH. But when reissuing the SSL, the old hostname still pops up.

Furthermore, under Server Settings > Change Hostname the "rDNS/PTR" section has my IP.vulter.com then in a orange square "FAILED".

The "Your Hostname is: HOSTNAME and it resolves to IP: IPADDRESS" section has the correct hostname and IP and no known errors!

Am I missing a step?!

Thanks,
Donald Louch from DevLexicon

Offline
*****
Re: Wrong Hostname? SSL Issue
« Reply #1 on: December 29, 2020, 07:42:43 AM »
hostname should be like subdomain of your main domain and should have dns A record :
check this tutorial https://www.mysterydata.com/how-to-change-and-install-ssl-for-hostname-in-cwp-control-web-panel/

Offline
*
Re: Wrong Hostname? SSL Issue
« Reply #2 on: December 30, 2020, 12:25:52 AM »
hostname should be like subdomain of your main domain and should have dns A record :
check this tutorial https://www.mysterydata.com/how-to-change-and-install-ssl-for-hostname-in-cwp-control-web-panel/

Thank you for your reply!

Nice article Sandeep! However, I have tried those steps and have the hostname/subdomain listed on my Vultr DNS with the right IP and everything.

I then just now, went in and changed the hostname again (from Server Settings > Change Hostname) and still having the same issue. However it now shows up with proper hostname on the certificate but still has the error of "Not a Secure Connection" and that
Quote
"This root certificate is not trusted."

Offline
*****
Re: Wrong Hostname? SSL Issue
« Reply #3 on: December 30, 2020, 07:16:47 AM »
hostname should be like subdomain of your main domain and should have dns A record :
check this tutorial https://www.mysterydata.com/how-to-change-and-install-ssl-for-hostname-in-cwp-control-web-panel/

Thank you for your reply!

Nice article Sandeep! However, I have tried those steps and have the hostname/subdomain listed on my Vultr DNS with the right IP and everything.

I then just now, went in and changed the hostname again (from Server Settings > Change Hostname) and still having the same issue. However it now shows up with proper hostname on the certificate but still has the error of "Not a Secure Connection" and that
Quote
"This root certificate is not trusted."

can you check this log probably you reached rate limit 429
/root/.acme.sh/acme.sh.log

Offline
*
Re: Wrong Hostname? SSL Issue
« Reply #4 on: December 30, 2020, 02:33:36 PM »
can you check this log probably you reached rate limit 429
/root/.acme.sh/acme.sh.log

So I looked in the /root/.acme.sh/acme.sh.log and I had well over 5,000 lines of logged items. I'm not quite sure what I'm looking for?! I found lines that said code 400 and code 200 quite a bit. However, I don't believe I saw anything with code 429 or the wording of "Reached Rate Limit"?

Thanks,
Donald Louch from DevLexicon

Offline
**
Re: Wrong Hostname? SSL Issue
« Reply #5 on: January 03, 2021, 08:16:55 PM »
hostname should be like subdomain of your main domain and should have dns A record :
check this tutorial https://www.mysterydata.com/how-to-change-and-install-ssl-for-hostname-in-cwp-control-web-panel/

The hostname has to be different than an account on the system.

Also you have to log into Vultr and set the servers main IP to the hostname.

At Vultr, this is at:

Products -> (select your server) -> Settings -> Click on the pencil next to the Vultr default Reverse DNS.
Change it to your hostname, then click on the Checkmark to save.

Vultr has various time to update the rDNS. I've seen as fast as a couple minutes, to over an hour.

Then ALSO in your domains DNS, you have to have an A record for the hostname and IP.

Hope this answers your question.

Offline
*
Re: Wrong Hostname? SSL Issue
« Reply #6 on: January 03, 2021, 10:26:51 PM »
The hostname has to be different than an account on the system.

Also you have to log into Vultr and set the servers main IP to the hostname.

At Vultr, this is at:

Products -> (select your server) -> Settings -> Click on the pencil next to the Vultr default Reverse DNS.
Change it to your hostname, then click on the Checkmark to save.

Vultr has various time to update the rDNS. I've seen as fast as a couple minutes, to over an hour.

Then ALSO in your domains DNS, you have to have an A record for the hostname and IP.

Hope this answers your question.

Hello Starburst,

Thank you so much for your reply! I have done that and now the "under Server Settings > Change Hostname the "rDNS/PTR" section has my IP.vulter.com then in a orange square "FAILED"." issue now is fixed and now say's "SUCCESS" in green!

However, even after reinstalling the SSL through "Changing the Hostname" I still get a message saying the connection isn't secure.

I did click on the SSL Check that is listed beside "Your Hostname" text and it stats that "The Common Name" and the "Issuer" is my old hostname from before. How do I change those settings?

Thanks,
Donald Louch from DevLexicon

Offline
*
Re: Wrong Hostname? SSL Issue
« Reply #7 on: January 08, 2021, 12:33:28 AM »
Hello,

So I now have the proper "Common Name", and "Issuer" listing on the SSL! However, when going to the admin panel it still show that the connection is not secure. After some more digging I found another error which was to do with the "Intermediate/Chain certificate" and it not being found. With this, I noticed that the SSL was labeled as Self-Signed.

I have went through SSH and entered:
Code: [Select]
sh /usr/local/cwpsrv/htdocs/resources/scripts/generate_hostname_ssl
Which is how I was finally able to get the Common Name and Issuer to change!

Is there a way to use something like Let's Encrypt to properly install a SSL for the hostname and panels?!

Cheers,
Donald Louch from DevLexicon