Author Topic: WebPanel Glitched, Root Cron Jobs Deleted Wrong Entry, No Backup  (Read 323 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
WebPanel Glitched, Root Cron Jobs Deleted Wrong Entry, No Backup
« on: December 29, 2020, 04:22:58 PM »
In my CWP7 admin panel > Server Settings > Crontab for root

I added a custom cronjob, tested it out, and then wanted to delete it so hit the "Delete" button next to it.

But my web panel glitched out! And it deleted the one right above it.  At first I thought it was my own issue, and I clicked "Delete" on the wrong cron job.

Then I attempted to delete it again... and it deleted the (other one) right above it!

Frustrated I gave up with that and was able to delete it via SSH crontab.

I know initially I had 4 cron jobs set-up, and "accidentally" deleted 2.

Here are the remaining ones:

Code: [Select]
1 root /usr/local/cwp/php71/bin/php -d max_execution_time=18000 -q /usr/local/cwpsrv/htdocs/resources/admin/include/cron_autossl_all_domains.php
(50) (20) (*) (*) (*)
 
2 root /usr/local/cwp/php71/bin/php -d max_execution_time=18000 -q /usr/local/cwpsrv/htdocs/resources/admin/include/alertandautorenewssl.php
Daily (at midnight)

I did not add any cron jobs manually, so the 4 should be default.

Can someone please reference their own, or tell me which ones were deleted so that I can restore them?

Thank you!

Offline
*
Re: WebPanel Glitched, Root Cron Jobs Deleted Wrong Entry, No Backup
« Reply #1 on: January 04, 2021, 02:21:51 AM »
I think I got it.. looking at the cron logs and some googling

Code: [Select]
15 0 * * * /usr/local/cwp/php71/bin/php-cgi -d max_execution_time=10000000 -q /usr/local/cwpsrv/htdocs/resources/admin/include/cron_newbackup.php
The other one I believe was
Code: [Select]
38 0 * * * "/root/.acme.sh"/acme.sh --cron --home "/root/.acme.sh/cwp_certs" > /dev/null I recreated that one by using the
Code: [Select]
install-cronjob command on
Code: [Select]
.acme.sh