Author Topic: CANT LOGIN CWP PANEL ERROR CRON.PHP  (Read 319 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
CANT LOGIN CWP PANEL ERROR CRON.PHP
« on: December 30, 2020, 01:44:02 PM »
Hello,

Test what is the cwp PHP version and if it is updated to 7.2

/usr/local/cwp/php71/bin/php -v
PHP 7.2.30

if PHP was not updated to 7.2 then try manually
yum update cwpphp --enablerepo=cwp

**Manual update CentOS 7 (ignore if you have CentOS 6)**
```
chattr -i -R /usr/local/cwpsrv/htdocs
cd /usr/local/cwpsrv/htdocs
wget static.cdn-cwp.com/files/cwp/el7/cwp-el7-0.9.8.961.zip
unzip -o -q cwp-el7-0.9.8.961.zip
rm -f cwp-el7-0.9.8.961.zip
```

**Manual update CentOS 6 (ignore if you have CentOS 7)**
```
chattr -i -R /usr/local/cwpsrv/htdocs
cd /usr/local/cwpsrv/htdocs
wget dl1.centos-webpanel.com/files/cwp/cwp2-0.9.8.765.zip
unzip -o cwp2-0.9.8.765.zip
rm -f cwp2-0.9.8.765.zip
```


**Manual update for services (This steep must be done for CentOS 6 and 7)**
```
cd /usr/local/cwpsrv/var/services/
wget static.cdn-cwp.com/files/cwp/el7/cwp-services.zip
unzip -o -q cwp-services.zip
rm -f cwp-services.zip
```

Test if all is ok, it should run update without errors
```
sh /scripts/update_cwp
```

If you get error like:
> Cannot load the ionCube PHP Loader - it was built with configuration API320151012,NTS, whereas running engine is API320170718,NTS

then run this:

```
sed -i "s/ioncube_loader_lin_7.0/ioncube_loader_lin_7.2/g" /usr/local/cwp/php71/php.ini
sh /scripts/restart_cwpsrv
```



I DO ALL THIS BUT DOSENT WORK AGAIN. WHAT IS THE VERSION OF CWP FOR CENTOS 7 NOW?

WHEN UPDATE I GET ERROR ON

PHP Fatal error:
The encoded file /usr/local/cwpsrv/htdocs/resources/admin/include/cron.php has expired.
 in Unknown on line 0
« Last Edit: December 30, 2020, 01:53:01 PM by Menna »

Offline
*
Re: CANT LOGIN CWP PANEL ERROR CRON.PHP
« Reply #1 on: December 30, 2020, 03:23:50 PM »
its working now. change code from current version of cwp :  CWP7: 0.9.8.1028