Author Topic: Trouble installing SSL on hostname - config file empty?  (Read 371 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
Trouble installing SSL on hostname - config file empty?
« on: January 02, 2021, 03:41:48 PM »
Hi, I've been trying to avoid adding another topic on this but I can seem to figure it out.  I've been reading all the previous posts but can't seem to see what I'm doing wrong.

I've read - /var/log/cwp/autossl.log
It states
AutoSSL Failed install for Hostname: host.xxxxxx.com
Please check AutoSSL logs for more details: /root/.acme.sh/acme.sh.log

I've check - /root/.acme.sh/acme.sh.log
The only thing I can see that doesn't seem right is but i'm not expert

_currentRoot='/usr/local/apache/autossl_tmp/'
d
 config file is empty, can not read CA_KEY_HASH
......
......
config file is empty, can not read CA_EAB_KEY_ID
config file is empty, can not read CA_EAB_HMAC_KEY
config file is empty, can not read CA_EMAIL

I think I have my A record setup correctly, when I run a lookup it states type A with the correct domain name and IP address.

I'm sorry, I can't seem to see what I'm doing wrong or going wrong.  Hoping someone can point me in the right direction.  Thank you!



Offline
*
Re: Trouble installing SSL on hostname - config file empty?
« Reply #1 on: January 02, 2021, 06:49:06 PM »
First create another subdomain name from the domain manager, adding "examplename" A "@".

Then from the menu or url access /admin/index.php?module=change_hostname and change the subdomain name to the new one you created.

This is how we get another SSL certificate to be regenerated.