Author Topic: WebServers Vhost Template  (Read 4102 times)

0 Members and 1 Guest are viewing this topic.

WebServers Vhost Template
« on: January 22, 2021, 10:25:25 AM »

I have created two custom templates and add my custom code. I did an https redirection in .tpl file and in .stpl (SSL) template I did a change to the docroot path for a domain name.

When I do a change through CWP WHM for the domain name it creates new vhosts files for a domain name, but for .tpl file, system adds suffix .disabled and after that when you open a domain name in web browser I have an error. Fix for this is just to rename .tpl file and remove .disabled suffix. Restart Apache server and domain is up and running with settings I put in a custom template file.

My main issue is when I add this template as the default, main webservers configuration. Option, Apache default PHP-FPM template, and when SSL expires and system automatically renews it site became forbidden for access because .tpl file has suffix .disabled. The solution is, rename and remove a suffix, restart Apache and get the domain up and running.

Where do I get wrong and why CWP add suffix .disabled to a custom template?

Thanks, Vlade.

Re: WebServers Vhost Template
« Reply #1 on: January 22, 2021, 11:32:54 AM »
I have seen a similar problem too, with a custom template - somewhat annoying that it's renamed disabled.
Additionally, the editor introduces corruption to the template, adding spurious ~~@~~ (IIRC) characters at options +SymLinksIfOwnerMatch
Could this be the reason for it being marked disabled?

Re: WebServers Vhost Template
« Reply #2 on: March 12, 2021, 09:35:33 AM »
disabled is probably because you have some strange characters in the template, like character %
VPS & Dedicated server provider with included FREE Managed support for CWP.

*** Don't allow that your server or website is down, choose hosting provider with included expert managed support for your CWP.

Re: WebServers Vhost Template
« Reply #3 on: March 12, 2021, 02:05:13 PM »

You were right... Issue was the code for redirection in .tpl file.