Author Topic: Monit sending alerts to root@localhost.yourdomain.com  (Read 2599 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
Monit sending alerts to root@localhost.yourdomain.com
« on: January 30, 2021, 06:05:51 PM »
I just made a new install of CWP 7 and turned on Monit. For some reason even though I have changed the alert address it insists on sending the alerts to: "root@localhost.yourdomain.com" where it gets stuck in the postfix mail queue. - I never have had this problem before.

Where do I go to change this address? Thanks in advance.

Offline
*****
Re: Monit sending alerts to root@localhost.yourdomain.com
« Reply #1 on: February 01, 2021, 09:39:32 AM »
Hi, there.

Try to use CWPadmin: CWP Settings => Edit settings. Admin email + forward server system emails
You can ask me to solve any problem with your server for some money in pm  ;)
Services Monitoring & RBL Monitoring
http://centos-webpanel.com/services-monitor
Join our Development Team and get paid !
http://centos-webpanel.com/develope-modules-for-cwp

Installation Instructions
http://centos-webpanel.com/installation-instructions
Get Fast Support Here
http://centos-webpanel.com/support-services

Offline
*
Re: Monit sending alerts to root@localhost.yourdomain.com
« Reply #2 on: July 31, 2021, 04:53:58 PM »
Nope.  This did not work for my particular situation.

Offline
*
Re: Monit sending alerts to root@localhost.yourdomain.com
« Reply #3 on: November 11, 2021, 09:24:13 PM »
I am having the same thing

Offline
*
Re: Monit sending alerts to root@localhost.yourdomain.com
« Reply #4 on: January 25, 2022, 05:16:48 AM »
I had the same issue.

After some digging, here is what I found:

CWP Dashboard -> Email -> MailServer Manager

Fix your Current Settings in Postfix:

mydomain = mydomain.com
myhostname = websrv.mydomain.com
(change the names to match your information)

Don't forget to check:

✔AntiSpam/AntiVirus (recommended)
✔rDNS Check (recommended)    
✔Install DKIM & SPF (recommended)
✔Install Policyd (recommended)

Then, "REBUILD MAIL SERVER" .

Depending on the speed of your machine, I had to wait a good 20 min, maybe more.
After that, I checked:

CWP Settings -> Edit settings
make sure you have set an email in the = CSF/LFD Alerts

Then I rebooted the server, check email settings,s and the CWP dashboard (CWP info) box for "Hostname".

Fixed :)

Hope this helps.