Author Topic: Err_too_many_redirects on WordPress /wp-admin/  (Read 2571 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
Err_too_many_redirects on WordPress /wp-admin/
« on: March 07, 2021, 08:11:23 PM »
I used to have a free cwp with apache-only webserver and everything was working perfectly except that its performance was terrible.
So I bought cwp pro to use php-fpm selector but now when I try to login as admin in my WordPress site it shows too many redirects error.
Here's everything I've done:
1.Build php8.0.2 from php-fpm selector and activate it.
2.Edit htaccess on my domain to use that build.
3.change webserver from apache only to Apache+nginx+varnish
4. Rebuild webserver

Homepage and site is working on http and https but on https it's not showing the green padlock on chrome browser.
I've tried removing ssl certificate and reinstall but it didn't work, I've also tried purging cloudflare cache and removing device cookies, I've also turned off force https on cloudflare.

Offline
*****
Re: Err_too_many_redirects on WordPress /wp-admin/
« Reply #1 on: March 08, 2021, 03:31:16 PM »
try this htaccess rule:

Code: [Select]
SetEnvIf X-Forwarded-Proto "https" HTTPS=on
RewriteEngine on
RewriteCond %{HTTPS} !=on
RewriteCond %{HTTP:X-Forwarded-Proto} !https [NC]
RewriteRule ^ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

remove any https redirect before adding,

Offline
*
Re: Err_too_many_redirects on WordPress /wp-admin/
« Reply #2 on: March 08, 2021, 04:52:43 PM »
try this htaccess rule:

Code: [Select]
SetEnvIf X-Forwarded-Proto "https" HTTPS=on
RewriteEngine on
RewriteCond %{HTTPS} !=on
RewriteCond %{HTTP:X-Forwarded-Proto} !https [NC]
RewriteRule ^ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

remove any https redirect before adding,

This fixed the admin panel but now the site is havinixed content because it is served through site.com/wp-content/cache/site.gzip

I turned off gzip compression in nginx.conf and the site is working fine, is there a way to use gzip without this happening?