Author Topic: User's PHP.INI Editor not working  (Read 4028 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
User's PHP.INI Editor not working
« on: October 29, 2021, 11:09:58 AM »
hello,
the user's php.ini displaying none.
i have already enter via advance editor, after i click save. it going blank again

https://prnt.sc/1xpogg2

Offline
*
Re: User's PHP.INI Editor not working
« Reply #1 on: October 29, 2021, 11:44:59 AM »
update:
based on: https://wiki.centos-webpanel.com/how-to-configure-php-options-under-cwp-admin-and-cwp-user

my php.ini path not display as the wiki's pictures (/home/user/...


and i tried to edit public_html/.user.ini manually
and it working...

but still cannot edit from cwp user panel



before massive update 1-2 weeks ago.. everything is ok
« Last Edit: October 29, 2021, 12:37:09 PM by digdug »

Offline
*
Re: User's PHP.INI Editor not working
« Reply #2 on: October 30, 2021, 05:11:59 AM »
anyone ?

Offline
***
Re: User's PHP.INI Editor not working
« Reply #3 on: October 31, 2021, 02:36:36 AM »
Seems you have a permission problem with your ini file.
(Perhaps edited by root user?)

What are your user using? php-cgi, php-fpm.?

Regards,
Netino

Offline
*
Re: User's PHP.INI Editor not working
« Reply #4 on: October 31, 2021, 07:28:57 AM »
Seems you have a permission problem with your ini file.
(Perhaps edited by root user?)

What are your user using? php-cgi, php-fpm.?

Regards,
Netino
Apache version: Apache/2.4.51
PHP version: 7.4.25
MySQL version: 10.2.40-MariaDB
FTP version: 1.0.47
MySql Port: 3306
Web Servers: nginx-apache
Distro Name: CentOS Linux release 7.9.2009 (Core)
Kernel Version: 3.10.0-1160.45.1.el7.x86_64
CWP version: 0.9.8.1098

cwp free... will upgrading soon if everything working well

this is happen after massive update (3-4 revision in one hours or two hours only ) about 1-2 weeks ago....
then i think i mess with permission like u said... but this is fresh install
i re deploy centos 7 and install cwp
without do anything
i add 1 domain then i enter the user panel... bang..... it's same
default config without any editing....

manual add php.ini not working.. system not read it.
manual add .user.ini working but not display at cwp panel (still path empty php.ini )

Offline
***
Re: User's PHP.INI Editor not working
« Reply #5 on: November 01, 2021, 03:50:13 AM »
Where you is adding that file.?
The location is:
Code: [Select]
/home/USER/public_html/.user.ini
(Note the dot '.' at the beginning of that filename)

For example, if you have an USER named 'digdug', you will must have a file like:
Code: [Select]
-rw-r--r-- 1 digdug digdug 296 Nov  1 00:39 /home/digdug/public_html/.user.ini
with permission 644.
(the 'user' in '.user.ini' is just literal, not a user of your system)
« Last Edit: November 01, 2021, 03:53:19 AM by Netino »

Offline
*
Re: User's PHP.INI Editor not working
« Reply #6 on: November 01, 2021, 06:02:49 AM »
Where you is adding that file.?
The location is:
Code: [Select]
/home/USER/public_html/.user.ini
(Note the dot '.' at the beginning of that filename)

For example, if you have an USER named 'digdug', you will must have a file like:
Code: [Select]
-rw-r--r-- 1 digdug digdug 296 Nov  1 00:39 /home/digdug/public_html/.user.ini
with permission 644.
(the 'user' in '.user.ini' is just literal, not a user of your system)

Where you is adding that file.?
i dont edit anything, fresh install.

and yes. i try to edit via ftp/file manager file .user.ini the config of php changed like i increase max vars then i try to check... the max var change with same value at file .user.ini

but inside the GUI CWP user Panel. option edit php.ini still blank and cannot added

will you check it ? i can give u user test account from cwp user

Offline
*
Re: User's PHP.INI Editor not working
« Reply #7 on: November 01, 2021, 05:01:41 PM »
i run this
Code: [Select]
<?php
$inipath 
php_ini_loaded_file();

if (
$inipath) {
    echo 
'Loaded php.ini: ' $inipath;
} else {
    echo 
'A php.ini file is not loaded';
}
?>
with result : Loaded php.ini: /home/rdigihub/public_html/php.ini

but still empty at cwp

Code: [Select]
Video at : https://terabox.com/s/1YOWLd1WaGK0TUTkx5I8k1A  passcode: es7q

Offline
***
Re: User's PHP.INI Editor not working
« Reply #8 on: November 02, 2021, 04:40:06 AM »
Check if you default php.ini file is enable your user defined ini file.

For example, if you are using PHP-FPM, the file: /opt/alt/php-fpm74/usr/php/php.ini
Code: [Select]
(...)
;;;;;;;;;;;;;;;;;;;;
; php.ini Options  ;
;;;;;;;;;;;;;;;;;;;;
; Name for user-defined php.ini (.htaccess) files. Default is ".user.ini"
;user_ini.filename = ".user.ini"
(...)

If disabled, enable it.

Offline
*
Re: User's PHP.INI Editor not working
« Reply #9 on: November 02, 2021, 11:35:51 AM »
Check if you default php.ini file is enable your user defined ini file.

For example, if you are using PHP-FPM, the file: /opt/alt/php-fpm74/usr/php/php.ini
Code: [Select]
(...)
;;;;;;;;;;;;;;;;;;;;
; php.ini Options  ;
;;;;;;;;;;;;;;;;;;;;
; Name for user-defined php.ini (.htaccess) files. Default is ".user.ini"
;user_ini.filename = ".user.ini"
(...)

If disabled, enable it.

i have already do that and nothing happen

but i give a try again
i do just like ur reply

https://prnt.sc/1y5rqqe

https://prnt.sc/1y5rmh1

still same
https://prnt.sc/1y5ry7h


and as i inform before
already try to deploy new vps... with centos 7 and cwp auto installer (from tutorial install)
without any modification
when installation finish
i add new domain
and enter user panel cwp check the php.ini
it same...

i think something was not correct with cwp default package
so new installation will face this problem


The different between 2 cwp that i use (at video) is:
1. pro and non pro
2. kernel version. the pro one (php.ini normal) installed about 4-5 month ago... and the free one (php.ini not normal) fresh installation 2 week and re install few days ago
« Last Edit: November 02, 2021, 11:40:33 AM by digdug »

Offline
***
Re: User's PHP.INI Editor not working
« Reply #10 on: November 04, 2021, 09:55:14 PM »
Did you try to restart PHP-FPM servers.?

Like:
Code: [Select]
# systemctl restart php-fpm53.service
# systemctl restart php-fpm54.service
# systemctl restart php-fpm55.service
# systemctl restart php-fpm56.service
# systemctl restart php-fpm70.service
# systemctl restart php-fpm71.service
# systemctl restart php-fpm72.service
# systemctl restart php-fpm74.service

In using PHP-FPM, they have theirself servers, that need to be restarted.

Offline
*
Re: User's PHP.INI Editor not working
« Reply #11 on: November 05, 2021, 07:49:35 AM »
is that save with reboot server ? if yes.. then i did

because i dont know what is wrong... i prefer reboot than restart service

Offline
***
Re: User's PHP.INI Editor not working
« Reply #12 on: November 06, 2021, 10:31:17 PM »
is that save with reboot server ? if yes.. then i did

because i dont know what is wrong... i prefer reboot than restart service

Yes, should work with reboot.

Did you try to update Ioncube.?!
Code: [Select]
# /scripts/update_ioncube

Offline
*
Re: User's PHP.INI Editor not working
« Reply #13 on: November 09, 2021, 12:35:09 PM »
already move some of my client to my friends

and move my client (without email) manual MOVE public_html and db....
to CYBERPANEL build 2

NOW CWP need BUG to make SUPPORT DESK "BUSY"

SINCE BIG BIG BIG multitimes UPDATE few WEEKS AGO 4-5 update at 1 day

Offline
*
Re: User's PHP.INI Editor not working
« Reply #14 on: November 09, 2021, 12:36:54 PM »
But SOME DAY  i',m sure i will use CWP AGAIN (IF) CWP STOP ACT LIKE COMMERSIAL OS W***** and try to use their marketing system. create update to give new bug and for upgrade core version



....IF.....