Author Topic: Yum manager - unable to update packages  (Read 4675 times)

0 Members and 1 Guest are viewing this topic.

Offline
**
Yum manager - unable to update packages
« on: February 10, 2022, 01:14:21 PM »
I am getting the message

Delta RPMs disabled because /usr/bin/applydeltarpm not installed.

"List of available packages for update" still shows the same list of products to update.

Offline
**
Re: Yum manager - unable to update packages
« Reply #1 on: February 10, 2022, 01:23:39 PM »
I used the directions at

https://www.cyberciti.biz/faq/delta-rpms-disabled-because-applydeltarpm-not-installed/

got message

No Presto metadata available for mariadb cwp

used the following article to resolve

https://stackoverflow.com/questions/37030605/no-presto-metadata-available-for-base-error-downloading-packages

Request some experts to confirm if this is the correct solution

Offline
***
Re: Yum manager - unable to update packages
« Reply #2 on: February 10, 2022, 07:41:55 PM »
what OS?

Offline
*
Re: Yum manager - unable to update packages
« Reply #3 on: February 11, 2022, 10:39:34 AM »
I have the same issue:

CWPpro version: 0.9.8.1128
Distro Name: CentOS Linux release 7.9.2009 (Core)
Kernel Version: 3.10.0-1160.53.1.el7.x86_64
Platform: x86_64

I think I installed the minimal version of CentOS as per instructions.

Is the solution to run ?
Code: [Select]
yum install deltarpm

Thanks
« Last Edit: February 11, 2022, 10:41:20 AM by shoulders »

Offline
*
Re: Yum manager - unable to update packages
« Reply #4 on: February 11, 2022, 12:01:17 PM »
No issues on rocky linux 8.5

Offline
****
Re: Yum manager - unable to update packages
« Reply #5 on: February 15, 2022, 05:53:24 AM »
yum install deltarpm


Side Note.  If the packages that won't install are MariaDB, that because Maria can't be auto updated.  It has to be a manual install.
Google Hangouts:  rcschaff82@gmail.com

Offline
*
Re: Yum manager - unable to update packages
« Reply #6 on: February 15, 2022, 09:00:18 AM »
yum install deltarpm


Side Note.  If the packages that won't install are MariaDB, that because Maria can't be auto updated.  It has to be a manual install.

How are us end user supposed to update MariadDB?

I thought when the updates were minor or patch level then you could just update.

I am a windows user so all of this is complicated
« Last Edit: February 15, 2022, 09:06:36 AM by shoulders »

Offline
****
Re: Yum manager - unable to update packages
« Reply #7 on: February 15, 2022, 01:24:20 PM »
yum install deltarpm


Side Note.  If the packages that won't install are MariaDB, that because Maria can't be auto updated.  It has to be a manual install.

How are us end user supposed to update MariadDB?

I thought when the updates were minor or patch level then you could just update.

I am a windows user so all of this is complicated

The End User isn't supposed to update anything.  If you want to run a hosting company, you need to know what you are doing.  A google search will land you on MariaDB's "How to update" page, which explains EXACTLY why they force manual updates, and how to do it.  Remember, they are a free software, that does not want to be liable for your data.
Google Hangouts:  rcschaff82@gmail.com

Offline
*
Re: Yum manager - unable to update packages
« Reply #8 on: February 15, 2022, 01:35:23 PM »
I am not running a hosting company. I am just running my own websites locally. I reckon a good portion of CWP users are the same as me. :)

Also I am running in VirtualBox which allows me to power down and do a Full Veeam backup, and soon I will setup automated backups to my TrueNAS box.

I will backup, run the command, and see where I get up to. I also have links to manually updating MariaDB.

Thanks for the feedback. This will all get added to my Tutorial/Setup Instructions.