Author Topic: ionCube Loader - Failed loading /usr/local/ioncube/ioncube_loader_lin_7.4.so  (Read 1138 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
Hi,

I created a subdomain where I have installed some scripts.
The application requires that I have ionCube Loaded installed.

--

Script error: the ionCube Loader for PHP needs to be installed. The ionCube Loader is the industry standard PHP extension for running protected PHP code, and can usually be added easily to a PHP installation. For Loaders please visit get-loader.ioncube.com and for an instructional video please see http://ioncu.be/LV

--

So, I checked in the terminal to see what version of ionCube was installed and see a few errors.
Not sure exactly how to fix the errors, any tips appreciated.

--

Failed loading /usr/local/ioncube/ioncube_loader_lin_7.4.so:  /usr/local/ioncube/ioncube_loader_lin_7.4.so: undefined symbol: file_globals
Failed loading /usr/local/sourceguardian/ixed.7.4.lin:  /usr/local/sourceguardian/ixed.7.4.lin: undefined symbol: executor_globals
PHP 7.4.27 (cli) (built: Jan 11 2022 06:11:26) ( ZTS )
Copyright (c) The PHP Group

--


Offline
***
Did you build your PHP 7.4.x version with the ionCube option enabled?

By default, it's not enabled, and just loading the loaders won't work.

Offline
*
@Starburst

If I'm looking at the correct settings, IonCube appears to be enabled for PHP (7.4.27)

https://snipboard.io/GwAH2X.jpg

Offline
*
I updated to PHP 7.4.32

In PHP-FPM Selector, Managing options for PHP-FPM 7.4
I selected PHP 7.4.32 from the drop-down, enabled all.

-

PHP-FPM Information for PHP 7.4

Configuration:

ionCube Loader

For Loader updates visit www.ioncube.com/loaders.php
For support visit support.ioncube.com
This Loader also includes features for real-time error reporting and malware protection. Visit ioncube24.com for more details.

Loader version => 12.0.1
ionCube24 features => unconfigured

Directive => Local Value => Master Value
ic24.api.log_msg_errors => 0 => 0
ic24.api.max_timeout => 7 => 7
ic24.api_access_key => ******** => ********
ic24.api_check_ip => 1 => 1
ic24.enable => 0 => 0
ic24.home_dir => no value => no value
ic24.phperr.enable => auto => auto
ic24.phperr.ignore => 0 => 0
ic24.sec.block_stdin => 1 => 1
ic24.sec.block_uploaded_files => 1 => 1
ic24.sec.enable => auto => auto
ic24.sec.exclusion_key => ******** => ********
ic24.sec.initial_action => block => block
ic24.sec.initial_cache_all => 1 => 1
ic24.sec.initial_notify => always => always
ic24.sec.initial_state => 1 => 1
ic24.sec.stop_on_error => 1 => 1
ic24.sec.trusted_include_paths => ******** => ********
ic24.slt => 7 => 7
ic24.update_domains_retry_interval => 30 => 30
ioncube.loader.encoded_paths => no value => no value

Offline
***
When you goto your system prompt via SSH and type 'php -v'

Does it show ionCube?

Offline
*
@Starburst

No, when I type php -v

I get:

Failed loading /usr/local/ioncube/ioncube_loader_lin_7.4.so:  /usr/local/ioncube/ioncube_loader_lin_7.4.so: undefined symbol: file_globals
Failed loading /usr/local/sourceguardian/ixed.7.4.lin:  /usr/local/sourceguardian/ixed.7.4.lin: undefined symbol: executor_globals
PHP 7.4.27 (cli) (built: Jan 11 2022 06:11:26) ( ZTS )
Copyright (c) The PHP Group

Last night I clicked install for that FFMPEG Installer, I shoulda left that alone.
After that, the server froze, I was able to run that tail command to check FFMPEG status
But it took ages then threw up AJAX error, then I lost access to CWP.

Been locked out of the front-end of CWP since.

The data-center did some checks last night, sorted one or two issues, disabled ionCube module,
Because I think it needs to be installed again, we couldn't run yum update either, getting AJAX errors.

I'm able to access the server via FTP and Putty, but can't access CWP front-end: 504 Gateway Time-out
Didn't try rebooth encase we lost access to the server, websites etc. are running fine.
« Last Edit: November 28, 2022, 11:46:47 PM by emar »

Offline
***
Do you have SSH access to your server?

Try to login and see if the CWP & CSF services are running.

There are some CWP repair tools in /scripts

Offline
*
I got in with Putty yes,

[root@svr1 ~]# service csf status
Redirecting to /bin/systemctl status csf.service
csf.service - ConfigServer Firewall & Security - csf
   Loaded: loaded (/usr/lib/systemd/system/csf.service; enabled; vendor preset: disabled)
   Active: active (exited) since Fri 2022-09-23 15:49:37 IST; 2 months 5 days ago
 Main PID: 1241 (code=exited, status=0/SUCCESS)
   CGroup: /system.slice/csf.service

Warning: Journal has been rotated since unit was started. Log output is incomplete or unavailable.



--



[root@svr1 ~]# service cwpsrv status
Redirecting to /bin/systemctl status cwpsrv.service
cwpsrv.service - CentOS Web Panel service (daemon)
   Loaded: loaded (/usr/lib/systemd/system/cwpsrv.service; enabled; vendor preset: disabled)
   Active: active (running) since Mon 2022-11-28 03:43:13 GMT; 20h ago
 Main PID: 3492 (cwpsrv)
   CGroup: /system.slice/cwpsrv.service
           3492 cwpsrv: master process /usr/local/cwpsrv/bin/cwpsrv
           3493 cwpsrv: worker process
           3494 cwpsrv: worker process

Nov 28 03:43:13 svr1.x.it systemd[1]: Starting CentOS Web Panel se....
Nov 28 03:43:13 svr1.x.it cwpsrv[3488]: cwpsrv: [warn] he "ssl" dir...
Nov 28 03:43:13 svr1.x.it cwpsrv[3488]: cwpsrv:the configuration fi...
Nov 28 03:43:13 svr1.x.it cwpsrv[3488]: cwpsrv:configuration file /...
Nov 28 03:43:13 svr1.x.it cwpsrv[3490]: cwpsrv: [warn] he "ssl" dir...
Nov 28 03:43:13 svr1.x.it systemd[1]: Started CentOS Web Panel ser....
Hint: Some lines were ellipsized, use -l to show in full.


Offline
*

[root@svr1 ~]# service cwpsrv restart
Redirecting to /bin/systemctl restart cwpsrv.service

** (pkttyagent:17326): WARNING **: 05:23:59.003: Unable to register authentication agent: GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: Cannot determine user of subject
Error registering authentication agent: GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: Cannot determine user of subject (polkit-error-quark, 0)

Offline
*
I got CWP support to help and they fixed the issue/s.

Thanks!

Offline
***
GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: Cannot determine user of subject
Error registering authentication agent: GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: Cannot determine user of subject (polkit-error-quark, 0)
Have you seen the posts on this forum how to fix this error? Try it -- it's an effective fix and will get rid of this message.