Author Topic: AutoSSL not working  (Read 1660 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
AutoSSL not working
« on: February 18, 2023, 10:47:48 AM »
Hey.

Please help me figure this issue out. Im completely lost and have no idea what I am doing wrong

Iíve a VPS server from hostwinds with CWP installed. (Domain also from hostwinds)

I cannot get AutoSSL working under my user account. It just gives me this error no matter what I have tried.

DNS of your domain doesn't point to this server or you have htaccess restriction

On CWP:
My hostname is set to the default hostwinds shows my server as.
My nameservers has been set to default hostwind offers (mdns1.hostwindsdns.com) (mdns2.hostwindsdns.com)
rDNS is set to my domain and CWP says that it is working.

On Hostwinds:
Iím records A is set to my domain (example.com)
HS is set to the mdns1.hostwinds.com and same for mds2

I have noticed that on my root server there is a .htaccess file, but under my users file manager there isnít one.

I cannot get past that error listed above and I am out of ideas what to try next.

Thank you to everyone trying to help beforehand!





Offline
***
Re: AutoSSL not working
« Reply #1 on: February 18, 2023, 08:17:05 PM »
Auto SSL free, provided by LE. and LE limit 1 domain only 3 times (if im not wrong) request per week...
if you do request more then 3 it will fail...


SSL is only need Domain Pointed to Hosting no matter u use IN A or IN NS


the problem that i found with cwp are...
(hope already fixed)
sometimes we need to remove old SSL first before we do a new request
sometimes we cannot add ssl from user control panel, need cwp root panel
sometime domain already pointed but not detected by cwp (in this case, u need refresh your dns or bind

Offline
*
Re: AutoSSL not working
« Reply #2 on: February 20, 2023, 06:28:28 AM »
Okay that is very good to know. I wasnít able to get to work after going through the settings multiple times

My solution in the end was Cloudflares SSL. I gave it a shot and it immediately started working. 
So I guess the problem was too many requests then although I only managed to install it on the root account for testing. Or there was something wrong with my hosting service DNS

Thank you for the response and information. Iíll keep this in mind

Offline
***
Re: AutoSSL not working
« Reply #3 on: February 21, 2023, 09:24:50 AM »
Okay that is very good to know. I wasnít able to get to work after going through the settings multiple times

My solution in the end was Cloudflares SSL. I gave it a shot and it immediately started working. 
So I guess the problem was too many requests then although I only managed to install it on the root account for testing. Or there was something wrong with my hosting service DNS

Thank you for the response and information. Iíll keep this in mind


if that happen you can use zerossl that will give you free ssl for 1 times, at least it can make you use free ssl until LE released new quota (cons: 1 domain only can get 1 times free, i forgot 1 month or 3 month)

Offline
*
Re: AutoSSL not working
« Reply #4 on: February 26, 2023, 12:59:41 PM »
After my SSL LE request failed I am getting no ssl domains listed after selecting the User

This is in the root panel

Anyone else?  How do we fix?

Thanks

Offline
****
Re: AutoSSL not working
« Reply #5 on: March 11, 2023, 04:39:20 PM »
Make sure your HTTP server doesn't have a 301 redirect from HTTP to HTTPS. To get an SSL cert, it needs to be negotiated via HTTP, so http://domain.com/.well-known/acme-challenge/ needs to be accessible. Forwarding to https:// means it won't work.

Also, on one server I had to use Cloudflare's DNS authenticator method with LetsEncrypt, instead of the normal HTTP challenge. Token based authentication with Cloudflare worked immediately and has renewed successfully for several years now.

Offline
*
Re: AutoSSL not working
« Reply #6 on: March 24, 2023, 07:57:28 AM »
Can Anybody Help me with same issue.
I have been facing an issue in Control Web Panel that Auto SSL isn't working on new subdomain where it shows error "DNS of your domain doesn't point to this server or you have .htaccess restrictions" which i have checked and DNS is working fine with IP but i tried solution from past forum but still it didn't solve the issue by changing hostname.


Offline
****
Re: AutoSSL not working
« Reply #7 on: March 25, 2023, 08:00:03 AM »
^ That's why I posted my comment above. I encountered that error before and you have to make sure you are not redirecting the site from HTTP to HTTPS. It needs to negotiate the AutoSSL certificate via (non-SSL) HTTP.