Author Topic: CWP Pro proposing gdb-headless updates when not needed  (Read 931 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
CWP Pro proposing gdb-headless updates when not needed
« on: May 28, 2023, 09:22:27 AM »
Hello,

For a while now CWP proposes gdb-headless.x86_64 8.2-19.el8 to be updated while the system does not need that update. I am running Almalinux 8.8 (Sapphire Caracal).

Is there any way I can turn this notification off please?

Thank you in advance!

Nick

P.S. I have spent two minutes doing human puzzles; isn't it a bit too excessive?

Offline
****
Re: CWP Pro proposing gdb-headless updates when not needed
« Reply #1 on: May 28, 2023, 08:01:41 PM »
CWP is just a frontend for YUM, so it is just presenting whatever suggestions yum is recommending for update. If you don't need gdb-headless, consider removing it. I recommend NOT running any unnecessary services on your server, as it just serves to increase your attack surface. Better to run lean an nimble and only install what you absolutely need.

Offline
*
Re: CWP Pro proposing gdb-headless updates when not needed
« Reply #2 on: May 29, 2023, 09:45:49 AM »
For some reason I had both gdb-headless-8.2-19 and gdb-headless-8.2-18 installed so the CWP web GUI was probably seeing gdb-headless-8.2-18 present and was proposing to update it even though dnf was not reporting anything to be updated (didn't try yum).

I have uninstalled gdb-headless-8.2-18 and packages depending on it (which uninstalled gdb-headless-8.2-19 as well) then reinstalled the dependencies, which only installed gdb-headless-8.2-19, thus removing gdb-headless-8.2-18.

No more messages.

Offline
****
Re: CWP Pro proposing gdb-headless updates when not needed
« Reply #3 on: May 29, 2023, 02:14:44 PM »
Good job! Exactly the right way to deal with that scenario.
(And of course, I meant CWP's YUM module is a frontend for yum -- not the whole of CWP being a yum frontend!)